cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Highlighted
Staff
Staff

ANY custom Wattman settings causing "thread_stuck_in_device_driver" BSOD

Hello,
Problem:
When adjusting any custom wattman settings, (adjusting fan curve, increasing power limit, setting clocks, etc..) or even just turning on virtual resolution, the system hangs and i receive BSOD "thread_stuck_in_device_driver".

My set up:

GPU: 2x reference air VEGA 64

CPU: 1x Ryzen 7 2700x

MOBO: X470 Gaming Wifi 7

RAM: 32GB 3200 cl14

DISPLAY 1: 1x 4k Display 60hz

DISPLAY 2: 1x 4k Display 60hz (tested both TV -HDMI- and monitor -DP/HDMI-)

DISPLAY 3: 1x 2560x1440 display 144hz

Observations:
-Disconnecting one of the connected displays allows wattman settings to be manipulated and applied as expected.
or
-Lowering resolution of one of the 4K monitors to 1080p allows wattman settings to be manipulated and applied as expected.


-No change in behaviour is seen when connecting 1 monitor through hdmi instead of DP.

-Turning off Crossfire has no effect if all 3 displays are connected to the same Vega.

-Crossfire disabled: i can connect 1 Display to the second card and both will function as expected independently.

I've tried with both December adrenaline driver and the latest Jan update. (SAFE mode DDU in between)

I know its a very uncommon occurrence, i just wanted to see if anyone has seen this or know of an easy way to fix.


Thanks!

0 Kudos
3 Replies
Highlighted
Esteemed Contributor III

Re: ANY custom Wattman settings causing "thread_stuck_in_device_driver" BSOD

I presume that you have a PSU of at least 1100 Watts for two Air-Cooler Vega64 in Crossfire with three monitors attached.

From Microsoft concerning your Blue-screen Error: Bug Check 0xEA THREAD_STUCK_IN_DEVICE_DRIVER - Windows drivers | Microsoft Docs

Cause

A device driver is spinning in an infinite loop, most likely waiting for hardware to become idle.

This usually indicates problem with the hardware itself, or with the device driver programming the hardware incorrectly. Frequently, this is the result of a bad video card or a bad display driver.

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: ANY custom Wattman settings causing "thread_stuck_in_device_driver" BSOD

I noticed your reply on my thread. I had some minimal success with using virtual resolution to set my lower Res monitor to 4k as well.

Are any of your monitors mirroring or are all 3 different? I usually experience this issue the worst when mirroring.

I still haven't "solved" it but I would definitely try using virtual resolution to set the 1440 to 4k which allowed me to change some settings. I ended up just setting all 3 to 1440p which allowed me to aggressively undervolt/overclock.

Good luck, keep me updated!

0 Kudos
Highlighted
Adept I
Adept I

Re: ANY custom Wattman settings causing "thread_stuck_in_device_driver" BSOD

I have the similar issue.

System:

MSI Z170A Krait Gaming

i7 6700K

Gigabyte reference Vega 64

All the settings in Wattman work except HBM2 frequency

I spent some time finding what causes it and found that it's the HDMI port

I have two 4K monitors connected to DP and one 1080p to HDMI

If I unplugg that HDMI monitor everything works or the system will just freeze and leads to BSOD

Funny thing is I also have another drive for my Hackintosh and the issue doesn't exist on that system

So maybe it's the Windows driver to blame?

0 Kudos