Showing results for 
Search instead for 
Did you mean: 


Journeyman III

AMD RX580 Start a game and get Black Screen with Fan at 100%

Hello!! I've been having the problem with my graphic RX580 recently, It started doing times to times but it get worse.

When I'm playing Apex Legends suddenly my screen turns black and the game crashes showing an Amd error that says "Amd Software detected that a driver on your system has timed out" . That happen some times I thought that it was the thermal paste cause I never changed it before and I have the graphic since 6 years ago. So I did change it, every temp its normal and even more cold that I was having previously, but now my problem its worse. When I try to open Apex Legends now don't even load the first cinematic that my graphic crashes showing the Black Screen with Not signal on my screen and the fans rolls at 100%, but I still listening the music or video that I was listening. So I have to turn off the pc with the power button, its the only way that my pc respond. And its happening now with all the games.

  • I tried to install before versions of the drivers, i cleaned my pc with the AMD clean up of drivers, (i should try DDU)
  • I changed the thermal pads of my graphic
  • I unistalled apex and download again
  • I checked all the connections of the graphic, if the power cable was right connected
  • The temperature its right.

What can being causing these problem? how can confirm if it is my PS?

By doing these checks now I can get into the lobby of Apex but still crashes when I try to get to a game

I checked the properties in the adapters of my graphics controller in the system and screen and this came out:
Controller Vendor: Advanced Micro Devices, Inc.
Controller Date: 5/10/2021
Controller version 30.0.13025.5005
and the system does not find controller updates, it says that I have the latest and recommended.
Like my Sentey monitor controller are from 2006 and version 10.0.19041.1151, Vendor: Microsoft

Maybe the Bios? I have the last driver for my graphic and I tried the previous versions and still get crashes 

My components are:

AMD Radeon AORUS RX 580 8gb rev1

PS: Thermaltake Smart 700w

Motherboard: Gigabyte GA-H270-Gaming 3

8af56e49-6fa5-4005-9e60-3ac7709e9d44.jpgThese are the data that MSI afterbunner shows me when I get into the gameThese are the data that MSI afterbunner shows me when I get into the gameAnd these one its before of the crashAnd these one its before of the crash

0 Replies