Showing results for 
Search instead for 
Did you mean: 


Journeyman III

AMD MSI RX480 4GB No longer showing signal on boot, no HDMI input on motherboard

Specs: AMD RX480 Gaming X 4GB I5 - 3740 @ 3.2Ghz

8GB DDR3 @ 1333mhz (I think, thats what task manager says)



DELL optiplex 7010 motherboard

I was playing games like usual, temps were fine, frames were good and cpu temps were fine as well everything was working how it should. (Last night)

Here comes today around 1PM and now nothing works. My peripherals dont light up when i turn on my pc like they do usually, my gpu lights and cpu fan start spinning but now I have no output. Its not like there was a windows update downloading as i turned off my pc.

Today it just randomly stopped working. I tried switching to my old GTX 750 (peripherals lit up like usual when I turned on my pc) but there was no output from that either.

I haven’t touched any settings that would render my pc unusable, so I dont know why it randomly decided to stop working one day after working for like all of last month :(

I tried booting without a drive, my pc has no scorch marks anywhere and my psu is new so its good. My GPU is working fine the fans work and the lights do too.

I don’t possibly know what it could be and now the power button won’t even turn off my pc I don’t know what to do.

When I press the power button, it turns on normally, gpu fans spin like normal, lights turn on, cpu fan spins but my peripherals like mouse n keyboard and mic dont light up like they do typically when I turn on my pc.

HDMI Cord plugged into GPU and I don't have access to a VGA Cable so I can't use my motherboards vga port (It doesn't have an HDMI Port) to check anything like the bios. ​

(My peripherals always light up when I turn on my pc, but now they dont leading me to believe i couldnt even get into the bios but IDK, any help appreciated.)


Update: My GTX750 does boot my pc normally now, it lets me get into the bios, boots to where it normally would but now its on the windows installer since I had to boot off of a USB device that would let my pc boot to the login screen when my RX480 was working normally. I can't seem to really get to the login screen now though :/ do I have to reinstall windows or something?

0 Replies