Showing results for 
Search instead for 
Did you mean: 


Journeyman III

AMD GPU reset bug - Unraid VM

I am trying to run Unraid OS and create Win10 VM with hardware passthrough for the AMD RX5700XT gpu to the VM (with some other items eventually like usb ports etc)

When i create the VM initially the driver are installed for 3 items listed as unknown components. 2 System type devices and the network card. This is resolved by custom drivers for them from VirtIO Drivers ISO.

The only item not yet updated is the GPU which is picked up as Microsoft basic display adapter. I need to then after clean reboot of the VM install the adrenalin amd gpu drivers for the rx5700xt (gigabyte). There after its picked up as the rx5700xt but when the VM is rebooted it doesnt come up again.... you forced to Force Stop VM. This causes the gpu to not be released from the VM and when I try boot up again I get a error : Internal Error: Unknown PCI header type '127' for device '0000:0c:00.0' which translates to my gpu card.

Unraid says that AMD should fix this Reset Bug. Space Invader One has also spoken about this in youtube videos and other alike.

Hack fix for this...but not nice if you running other VMs on the host....

How to easily reset a passed through AMD Graphics card without rebooting - YouTube 

Space Invader One trying his own rx5700xt card for pass through....reset bug hit him....

Please assist AMD - this is my first AMD rig and my friend who is running Intel and Nvidia is laughing at me for buying AMD, his Unraid system with GPU passthrough is working first time ....



7 Replies
Journeyman III

the only hope is to wait a while for new drivers. also advise to describe the problem in support amd. although they may be monitored here as well. I do not know ))

have you tried working on older drivers?

Journeyman III


i have the same problem with my rx5709xt running in Windows 10 guest on ESXi hypervisor (6.7u3 with latest Dezember patches). 

i was so abset, that I’ve bought another Nvidia 1650 super GPU to check if it is an ESXi issue. On Nvidia I have no problems with VM reset - it even works out of the box!

actually there are lot of people reporting same thing. It looks like AMD could fix this bug easily in firmware.

AMD Team: is there any release date for this bug fix?

This is the first time since 12 years where I’ve tried AMD product again (last one was K5 CPU) - but compared to intel / Nvidia products they have always some glitches... somehow disappointing.



Journeyman III

I had the same issue with my Proxmox setup. Luckily there is an unofficial Linux kernel patch available so I just ended up rebuilding the Proxmox kernel using this patch to fix the AMD reset bug on my AMD Ryzen Threadripper 3970X + AMD Radeon RX 5700 XT setup. The unofficial AMD Navi Linux Kernel patch is available at and the AMD Vega 10/AMD Vega 12 patch at

As far I'm aware the author of this patch is already in contact with AMD to get them to work on an official driver fix for around half a year. Until then I guess that kernel patch is unfortunately the best we can do. It’s a pain to keep a modified kernel up to date. I really hope to see a clean official drive fix from AMD soon.


They dont care... its been well over a year.. they think that its not worth their effort.. Only way you can influence is NOT to buy AMD... which is sad

Journeyman III

This is exactly why i don't buy from AMD anymore.  They are in the processor business, not GPU.  They should stay where they had it right for a time.  pffff....   6 months to get fakking firmware right?  These people dont care about your old money that you spent.  I bought one AMD card, never again.


I can only agree with you. This was the first and last AMD GPU I've bought for my private and business purposes.

In the meantime I've bought NVIDIA GTX1650 (not the same performance, bought just for testing) - and there are absolutely no issues with ESXI / passthrough.

Journeyman III

With the header 127 bug, there is a kernal patch for that you can use. I am not sure if it will work with your setup. I had used it before and was working correctly with a RX580