cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

YourLocalCow
Journeyman III

Adrenaline 22.10.3 cant run specific game

Recently I installed AMD Software: Adrenaline edition as a way to hopefully increase my performance in a specific game. From the instant a downloaded the software, my fps went from multiple hundreds at all times, to around 40-50. The game that I'm having problems with is Geometry Dash, I am able to run much more performance heavy games at max graphics and maintain good fps. I've tried many changes to hopefully increase my frames back to what they were before I installed, but nothing has worked. Here is an example of a relatively frame consuming game compared to the 2d low performance game.Screenshot (5).png

Any tips or solves on how I can fix this are appreciated, thank you.

My Specs:

GPU: AMD Radeon RX 6800 XT

CPU: 12th Gen Intel(R) Core(TM) i7-12700K

Motherboard: MSI Z690-A PRO WiFi DDR5 Intel LGA 1700 ATX Motherboard

Memory: Corsair Vengeance 32GB (2 x 16GB) DDR5-5200 PC5-41600 CL40 Dual Channel Desktop Memory Kit 32GX5M2B5200C40





 

0 Likes
1 Solution

Well I finally figured out what it was, turns out I had the "optional" version of AMD Software: Adrenaline Edition downloaded instead of the recommended. Can't believe that did that much honestly but I'm glad

View solution in original post

12 Replies
DimkaTsv
Miniboss

Hmm... Had you tried setting minimal frequency to around from [2000 Mhz] up to [Max frequency -100 mHz] in Adrenalin software? 
If this one won't work, i know another solution, but it is third party one and you may not like it.

MorePowerTool (MPT), Feature Control, remove checkmark from DS_GFXCLK (Deep Sleep GFX Clock). You will need to capture GPU bios into file before using MPT. For this you can use GPU-Z. In addition, if you want to do same even for VERY low loads, you can also remove checkmark from GFXOFF (Well... GFX OFF). These checkmarks affect power saving features.

Better read instruction how to use this tool. If you mess something up - safe boot (can be done also via 2 hard reset during windows loading) and MPT Delete SPPT.

DimkaTsv_0-1667257522654.png

 

This one change will force limit your minimal frequency under load to one you set in driver as minimal for any in-game load.

0 Likes

I've set the minimum frequency to around max yes. 

As for the other solution, I've downloaded MPT and GPU-Z, but honestly have no clue on how to capture GPU bios into file, so any help on that would be appreciated.

0 Likes

It is quite easy, actually.

DimkaTsv_0-1667260205260.png

 

0 Likes

Sorry this is a second account because I hit post limit.

Yeah I had to watch a tutorial on how to do it in German, thank you though.

As for the changes, I removed the checkmark, wrote the SPPT and restarted my computer, but it didn't seem to work. I then tried the second option and once again no luck.

Did I miss a step or did It simply not work?

0 Likes

Hmm... it should've worked (Feature control, uncheck DS_GFXCLK + GFXOFF, Write SPPT). This change forcefully limits minimal GPU frequency under absolutely any sort of load.

You can check is your SPPT change actually working via HWINFO. But maybe problem lies actually within game and not within power management. 

That is default idle frequency management

DimkaTsv_5-1667300306308.png

 

 

This is with MPT DS_GFXCLK and GFXOFF being disabled, on 500/2850 (min/max)

DimkaTsv_2-1667300092387.png

 

And this is with MPT DS_GFXCLK and GFXOFF being disabled 2750/2850 min/max. 

DimkaTsv_3-1667300141818.png

 

There is actually no need to set minimum up to 100 less then max. But there is some value that is default idle for all GPU (for mine it is around 2250-2260 mHz)
Anyways, this change usually helps fix people load transition stutters and bad FPS in some really undemanding games that just aren't able to manage GPU work more and it thinks it still idleing. 

Maybe you hadn't linked changes to your main GPU in top line of MPT? 

0 Likes

Here's my problem. I have both DS_GFXCLK and GFXOFF disabled, and my minimum and maximum clock speed is set to a value much higher than what its sitting at.

YourLocalCow2_0-1667332608305.png

 

0 Likes

Okay this is a more accurate screenshot of while I'm running the game, but I'm starting to realize that GFX isn't that same as GPU, in which case I cant find.

YourLocalCow2_0-1667333272635.png

EDIT: I've changed the maximum yet my minimum remains 500

 

0 Likes

 

GFX is part of GPU directly related to image rendering (graphics). Basically it is what HWINFO referres to as GPU clock
500 mHz looks like minimal possible frequency with disabled deep sleep states for RX 6000 series.

Also, you don't need to edit minimal frequency in MPT, that is a bad move. There is limited stuff you are able to change without breaking anything.

(if you go out of BIOS spec for some settings, GPU will enter lockdown "safe" mode with minimal frequencies only, until you return everything back to normal. That is used currently to prevent ability to set GPU and VRAM clock to more than possible with stock BIOS settings)


So return everything back to normal (load ROM again, write SPPT, then you can disable DS_GFXCLK and GFXOFF again). And change min/max frequency ONLY from Adrenaline. 


DimkaTsv_0-1667334089038.png

 

0 Likes

Alright cool, I got the min max frequency working and everything but sadly it doesn't seem to affect the game.
Meaning that it's probably an issue with that game, thank you for all of your help though, I now have a lot more control over my pc and at least know how to use it more. Of course if you have any tips they would still be appreciated but thank you.

0 Likes

Well I finally figured out what it was, turns out I had the "optional" version of AMD Software: Adrenaline Edition downloaded instead of the recommended. Can't believe that did that much honestly but I'm glad

Hmm... it was one of possibilities, but then you may want to report issue to AMD. 
@Matt_AMD , @Ray_AMD. Again, sorry for calling you out, but this issue probably should get some attention from driver side of things, as optional driver broke compatability for this game losing a lot of performance.

0 Likes
goosethesecond
Adept III

This driver broke BF2042 and Forza 5 for me. 2042 would crash as soon as it began loading a map and Forza 5 crashed after about 8 minutes every time. 

I reverted back to 22.9.1 as it is the most stable for me.

0 Likes