cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

MoverMarcus
Journeyman III

6900xt Weird graphical glitches in Assassins Creed Odyssey

Hi All,

After building a new PC and installing Assassins Creed Odyssey I am seeing some weird graphical glitches at night when looking at fire, smoke and dust:

Glitches AC Odyssey at night 2.jpgGlitches AC Odyssey at night.jpg

I tried every ingame setting from lowest to highest, but nothing seems to work, I tried both the latest GPU drivers (regular and optional). Anyone know what could be the issue?

My specs are:

CPU: AMD Ryzen 9 5950X
GPU: AMD RX 6900xt
GPU Driver Version: 21.40.11.03-211201a-374383E-RadeonSoftware
Windows OS: Windows 10 64bit

0 Likes
3 Replies
Geforsikus_2021
Challenger

Re: 6900xt Weird graphical glitches in Assassins Creed Odyssey

Try to check the integrity of the game files.

0 Likes
ThreeDee
Elite

Re: 6900xt Weird graphical glitches in Assassins Creed Odyssey

Make sure your motherboards BIOS is up to date

Make sure you have the latest AM4 Chipset drivers installed from AMD.com

Make sure you are running separate power cables to each power input on your GPU

Make sure you have latest GPU drivers installed from AMD.com 

Make sure your Windows install is up to date

What speed is your system RAM running at? (Task Manager>Performance>Memory)

IF your RAM is running faster than 3200 speeds .. is your fclk (infinity fabric) set to 1:1? 

Make sure Surface Format Optimization is unchecked in Radeon settings .. you might want to play with other settings in your Radeon settings as well 

Are you overclocking anything?

How are your CPU/GPU temps?

How is the airflow in your case? You have to keep your VRM's and memory cool too

 

|5900x w/Noctua NH-D15 2x140mm Fans|x570 Taichi|2x16GB RGB HyperX Predator 3200@3800 w/1:1 FCLK|MSI 6700XT|Seasonic FOCUS PX-850 850W 80+ Plat|Nighthawk Z-RGB Case|8x120mm RGB Fans|
MoverMarcus
Journeyman III

Re: 6900xt Weird graphical glitches in Assassins Creed Odyssey

I should mention that:

I checked the integrity of the game files

Did a full re-install and deleted the %USERPROFILE%\Documents\Assassin's Creed Odyssey\ folder

I did a run where I disabled background applications and performed a clean reboot

Did a AMD cleanup of the drivers and re-installed the drivers

I also based on ThreeDee did:

Installed the latest AM4 chipset drivers

I have seperate power cables for each input

I have the latest GPU drivers

RAM is running at 2133 Mhz

Surface optimization is unchecked

I am not overclocking

CPU and GPU temperature are about 50 degrees and 55 degrees celcius

While I am encountering this issue

0 Likes