cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

rmb0187
Adept I

6900 XT serious issues.

Jump to solution

I just purchased a 6900 XT from AMD, and it was delivered Tuesday.  I put it in my PC and did a fresh install by using DDU.

Went to load up my favorite game (Apex) and noticed my framerate at 1440p was sitting at 40-50fps.  I also noticed that the gpu was bouncing around like crazy.  In the drop ship my gpu usage was pretty much always at 100% but was seen going from over 2.5ghz to under 500mhz while still displaying 100% usage.  Figuring maybe it was my riser cable, I tried it directly in the motherboard (B550-i) and it didn't change.  I have it set to Gen3 mode in my bios because I use a riser cable.  

While looking through the AMD software, I noticed the "current bus settings was PCIe 3.0 x1"  Remounted the GPU and it switched to X2, then X1, then X4, then X8, then X1.  It kept changing every time I mounted the GPU.  But never got to X16 after trying over 10 times.  

Figuring maybe it was a motherboard issue, I tried it on a different PC.  The same issue was happening.  X1, X4, X2, X1 etc.

My specs are 5600x, Strix b550-i (lastest bios), freshly installed windows 10, 16gb ddr4 4000(tried with and without XMP), 750w Gold rated PSU (using 2 separate PSU cables)

I am assuming there is an issue with the card, but does anyone have any suggestions for what I could try?  I submitted a warranty request via AMD's form on the site yesterday and am still waiting for a response.

 

Thanks.

 

0 Likes
1 Solution

Accepted Solutions
rmb0187
Adept I

Re: 6900 XT serious issues.

Jump to solution

AMD ruled it was DOA.

 

It took a month, but I got a replacement.

View solution in original post

Tags (1)
8 Replies
delevero
Adept III

Re: 6900 XT serious issues.

Jump to solution

If you only connected one cable from your power supply to your graphics card then try to connect two cables instead of one.

You did not write anything about how big your power supply is, but personaly i can run the 6900xt and 5900x cpu with a 750w power supply ( but i have a 1000w installed now )   the graphics card use about 260watt and the cpu "guess" 100watt and then your harddrives and usb and other stuff uses some power too.

Also you can try to connect two power cables to your moterboards 12v connetors.. Dont worry it wont hurt your computer if you connect both 12v 4 and 8 pin power connectors to the top corner of your motherboard.. The 4 pin is only used to give a little extra boost if you overclock it is actual enough to only connect the 8pin connector.. But you can try.

Els try to reinstall the drivers for the 6900xt and during install you can select to "factory reset" the drivers/program.. its a little test you click and then it popup a menu..  alternative you can do the same inside of the radeon software.

Also check that the fans on the graphics cards is spinning ( also check cpu and other stuff, it can be you pulled out a cable while you installed your graphics card and when a computer get hot then it slow down to protect itself.

Also you can try to remove your graphics card and insert it again.. put your hand on the back of your motherboard when you push in the graphics card typical you can hear a click when its in 100%.. 
( turn off power to your pc when you do this, or disconnect the cable to the computer. )

And use a HDMI cable in the back of your pc  rather than a display cable. ( as a test )

ps.. I dont know how well the game Apex run, but i can tell you in hitman 3 i get 133fps when i set the radeon software to "standard profile"  ( about 1 year ago radon software had issues if you selected gaming or esport profiles.. dont know if it still apply )   ( i think that there is some kind of fps cap at 133fps in the radeon software, no matter what game i play it stop at 133 )

pps.. super pro tip... If you by any chance have bought a new power supply THEN NEVER REUSE THE OLD CABLES FROM THE OTHER POWER SUPPLY WITH YOUR NEW POWER SUPPLY..  the cables inside might be connected different and bad things can happen  😉   AND never use any cpu metal paste in your pc... it can short out your pc and destroy your hardware..
i tried that in the past ;-(

0 Likes
rmb0187
Adept I

Re: 6900 XT serious issues.

Jump to solution

It was 2 separate cables from the PSU, and its a 750w gold PSU.  The second PC I tried where the problem repeated itself is a 650w. 

I reinstalled drivers using DDU, and it didn't change so then I reinstalled windows yesterday, didn't change.

My motherboard only has 1 8 pin connection for the CPU.  

GPU fans spin no problem, CPU fan spinning no problem (cpu doesnt go over 60c, under load)

Tried both HDMI and Displayport.

For reference, I came from a 3070 and it was pretty much always over 144fps.  Was hoping to make the jump shortly to ultrawide 144 hence the upgrade.

0 Likes
Bas_Bass
Journeyman III

Re: 6900 XT serious issues.

Jump to solution

Set V sync off in games, iI had the same problem 

0 Likes
shayron12
Adept I

Re: 6900 XT serious issues.

Jump to solution

 

 They will tell you that you did not know how to install the software...

EFermi
Challenger

Re: 6900 XT serious issues.

Jump to solution

You might want to try the following: 

a) Disable all types of synchronization (VSync, freesync, adaptive/enhanced sync etc.) both in-driver and in-game;

b) Tutn off all overlays (steam/epic/whatever overlay, driver overlay, Afterburner/other, etc.) and try to monitor framerate through in-game means; if impossible, leave only one overlay instance for framerate monitoring (I would recommend Afterburner);

c) Go to control panel and turn off all disablable stuff in "Gaming" section; 

d) In the game shortcut or .exe properties check "run as administrator" and "disable fullscreen optimizations"; 

e) Force minimum core clock in driver control panel to 2000MHz. 

As for PCI-E width issue, I've no idea what may cause it. It might just actually be a faulty GPU by itself, but what's strange that it's capable of handling proper 3D loads without outright hanging and crashing every second. 

0 Likes
rmb0187
Adept I

Re: 6900 XT serious issues.

Jump to solution

AMD ruled it was DOA.

 

It took a month, but I got a replacement.

View solution in original post

Tags (1)
Pedrito0906
Adept II

Re: 6900 XT serious issues.

Jump to solution

Ao did it help? I'm having the same issue with my PowerColor Red Dragon 6800xt.

0 Likes
rmb0187
Adept I

Re: 6900 XT serious issues.

Jump to solution

replacement worked no problem.  You may need to contact PowerColor 

0 Likes