cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

pengko
Journeyman III

6800xt cannot change resolution when using "fullscreen" games, defaults to 4k 60hz

Have a 6800xt sapphire nitro

current drivers is 21.4.1.  Tried everything GPU scaling, scaling modes, vsr, integer scaling,  adding custom res.  On or off. Nothing works.

I have a 4k 60hz samsung tv that can display natively 4k 60 and 1440p 120hz.

Games like kingdom hearts 3 and rdr2 gives me issues.   Also control game.  

When I change the game to "fullscreen" it would automatically change my resolution displayed to 4k 60hz even though the game setting is set to 1440p 120hz.  Changing it to any resolution that my tv supports in game doesnt change anything, still displays 4k60.   It seems like in fullscreen something is causing amd drivers or whatever to scale up to 4k instead of displaying the selected game resolution, only in "fullscreen".   It is very annoying as some games require that you run full screen in order to use HDR but i hate running at 4k 60hz because it just isnt as buttery smooth as the 1440p 120hz. 

This leaves me with no other choice but to run my games in borderless windowed mode for most my games just to play at 1440p 120hz.

Anyone have this issue?  any fixes?

0 Likes
5 Replies
fsadough
Staff
Staff

Re: 6800xt cannot change resolution when using "fullscreen" games, defaults to 4k 60hz

  1. what is the exact make and model of your TV?
  2. Which HDMI input of your TV is being used?
  3. What is the HDMI version of your cable?
0 Likes
pengko
Journeyman III

Re: 6800xt cannot change resolution when using "fullscreen" games, defaults to 4k 60hz

Q6fn 65 inch samsung qled. 

Hdmi is regular for all ports since thia tv doesnt have hdmi 2.1 yet.  

Hdmi cable i use does support 4k 60. 

Tv has freesync ultimate on hdmi 2.0. 

I can output and run games at 4k 60 no issues so it isnt the ports or hdmi cables.  

Any other thoughts or resolutions?

0 Likes
pengko
Journeyman III

Re: 6800xt cannot change resolution when using "fullscreen" games, defaults to 4k 60hz

tested a few more games...

dragonquest 11, cyberpunk 2077, it takes two,  has to be in borderless to get 1440p 120hz.   Selecting fullscreen ignores my settings and forces 4k 60.

Games that actually work in fullscreen 120hz 1440p 

       - shadow of the tomb raider, the resident evil remakes 2 and 3, death stranding

Never had this issue with any of my games when I had the 1080ti.

 

0 Likes
Thanny
Miniboss

Re: 6800xt cannot change resolution when using "fullscreen" games, defaults to 4k 60hz

Shadow of the Tomb Raider is a borderless windows unless you check the box that says "Exclusive Fullscreen" in the launcher options.

Do you have GPU scaling enabled?  Have you tried setting your desktop to 2560x1440 @120Hz before launching the games, to see if it makes a difference?

 

0 Likes
pengko
Journeyman III

Re: 6800xt cannot change resolution when using "fullscreen" games, defaults to 4k 60hz

Yeh i set my desktop to 1440p 120hz.   Shadow of the tomb raider is in the list of games thats works for me.   Others dont work. 

0 Likes