cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

exactly99
Adept I

6800 XT HDMI connection Audiodrops

I have been using Vega 64 since day 1 and never had any single audio issue with my Denon AVR plugged via HDMI (5.1  24 Bit/192kHz). 

Upgraded my Vega 64 with a new XFX 6800 XT  (luckily day one again Smiley Happy ).  But audio dropouts started instantly on HDMI to AVR connections.  5-7 mins later  random audio drops. After searching I have found that 5700 XT was infected with this bug and never fixed. 

It is unacceptable that  newly released product has the same  well known problem from 5700 XT.

I have tried everything and got no fix yet.

__________________________

My setup: 

- Win 10 Latest 

- Latest (it is just the only ) Adrenalin driver

- x370 AM4 mainboard paired with AMD 3950X CPU

- 850W Seasonic Platinum PSU

- Denon AVR-X500

_____________________

What I have tried :

- Switching to audio driver to MSI Mode and adjusted to "High Priority" (used MSI Mode Utility v3) 

- Used other HDMI cables

- Using an a active  HDMI Switch between 6800 xt and AVR

- Disabled HDMI Assurance &  HDCP via Radeon Software

- Returned to older AMD HD Audio drivers from 2018-2019 era

- Disabled windows audio enchancements.

 

I am a long time AMD supporter but I am so confident to say If I knew this issue , it would be a dealbreaker instantly for me. 

4 Replies
technojunkey
Journeyman III

Re: 6800 XT HDMI connection Audiodrops

I have the same issue, seems to be virtual audio device disables and you get the sound notification from windows that a hardware change occurred.  Very frustrating, I opted to use a sound bar directly from PC instead of HDMI although it helps with the audio drop you still get the notification that a device change has occurred, also causes a drop in FPS.

The card is a beast however not sure how long I could tolerate this issue.

0 Likes
pokester
MVP

Re: 6800 XT HDMI connection Audiodrops

I can't possibly agree more. I can tell you this was and is a wide spread issue with Navi ie 5700 series. I tried one and returned it as it would not do audio correctly to my AV setup. While the prior RX 580 was fine. I ended up with a RTX 2070 super which has been great. I wanted to stay AMD but that was not an option. They have released drivers that have helped a little for some users but still tons of people complain that no it is not fixed. Some of the tech sites have said they believe it's bad in the silicon.

I was hoping RDNA2 would be better and was waiting to hear if this has been fixed but saw numerous other posts over the last several days saying the same as you that it is not fixed in RDNA2 either. Seeing as they didn't fix it in the drivers or Navi in over a year that doesn't look promising for RDNA2. I would not pass up the opportunity to return it in hopes of it being fixed eventually, but only you can decide that for you. 

Make sure to file a Bug Report in Radeon Settings.

I would let AMD know about the continued issue here too: https://www.amd.com/en/support/contact-email-form

Good Luck!

0 Likes
shodan
Journeyman III

Re: 6800 XT HDMI connection Audiodrops

it seems AMD sell defective product all over again, the sound is bugged since the NAVI... There are 3 pseudo-solution for this appart from going team green.

- Download and activate the dolby (the free version) : downsides sound still drop but muting, unmute kinda work.
- Put load on the card, like light benchmark as an old furmark : downsides > fan noise, power consumption.

- Try to go DP to HDMI, either directly with a cable or with an active adaptor : downsides > sometimes sound get distorted with noise, Often after a wake up from sleep. Just press mute and unmute. Also you may have good sound only in 1920x1080, 720 will be distorted, under 800x600 : no sound over 1080p can get some cut, over 1440 no sound again

THANK AMD FOR THIS! I wonder how you can still have the HDMI compliance... 

You may also try to remove the amd driver for the audio or a custom driver somewhere here :
https://community.amd.com/t5/graphics/rx5700-and-hdmi-sound-problem/td-p/308252

or here https://community.amd.com/t5/drivers-software/5700-xt-hdmi-sound-drops-cuts/td-p/218093
 

0 Likes
ryana
Journeyman III

Re: 6800 XT HDMI connection Audiodrops

My RX 580 worked perfectly fine with my Denon AVR.  When i upgraded to the RX 5700 hdmi audio became unstable and mostly would not work at all.  I had to replace it with an RTX 2070 instead.  I thought i'd give AMD another chance with an RX 6800 thinking this must certainly be resolved by now.  Same issue.  I will have to replace my RX 6800 with an RTX 3070 just like last time.  This is unacceptable that AMD is ignoring this problem that affects EVERY single navi card.

0 Likes