Showing results for 
Search instead for 
Did you mean: 


Journeyman III

5700XT Random Black Screen in Any Game

  • AMD Graphics Card
    • Gigabyte RX 5700XT
  • Operating System
    • Windows 10 64bit
  • Driver version installed
    • 20.4.2
  • Display Devices
    • Acer KG241Q 1920x1080 144Hz Freesync (Using HDMI but have not tried using displayport)
  • Motherboard + Bios Revision
    • ASUS ROG B450-F Gaming, BIOS 3003
  • CPU
    • Ryzen 5 3600X
  • Power Supply Unit  Make, Model & Wattage
    • EVGA SuperNova 550GA 550W 80+ Gold
  • RAM
    • Corsair Vengence LPX 2x8GB 3200

I've had a problem where I encounter a black screen every hour or so while playing anything. The screen cuts out for about 3 seconds then it comes back and evrything works fine until the issue happens again. I've tried using different HDMI cables, different ports, and the AMD cleanup utility to no avail. My GPU is connected to VGA 2 on my psu if that helps any.

2 Replies
Adept I

Hello dragonclaw

I have the exact same problem as yours.
Black screen problem on some games for 2-3 secs and came back like nothing happen, less frequently for me 1 or 2 black screen every days in average.

550w psu it's a bit limit but i have a 850w gold psu and i have this problem, so it's seems not to be the problem.

I have a vega 64 when this problem can happen to other architectures too. 

I try to have help on different forum like tom hardware, reddit and here but nothing. 

I have to do my own research and the problem seems to be fixed for me (I can't talk right now. It's only been two days, maybe it's on my head)

The problem seems to be linked to freesync and depth color i don't know it's kinda wierd.

What you can try is in your bios if you have a b450/x470 activate PCIe 3.0 or if you have a x570 activate PCIe 3.0 or 4.0 in default that setting is on ''auto'' i can't help more further for this.

A other thing is change your cable if you use a hdmi cable change it for a another one same if you use a display cable, you can try to plug the cable in a another hdmi/display port on your graphics card.

Try to disable hardware acceleration in chrome settings.

Try in the setting of your screen to disable freesync and re-enable or let it on disable.

The last thing you can try is in radeon setting:
click on setting(top right the cog thing), display, and the sixth option ''depth color'' i don't know the name in english sorry try to use 6 bcp.

I can't help you much further if this doesn't help you.

Sorry for my english.

Using the displayport instead of the HDMI has seemed to fix the problem. If it were to happen again hopefully the other suggestions will fix it. Thank you for the help.