cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

5700XT BSOD/Crashing with browser hardware decode + 75Hz bug

Hi guys,

I've been using my 5700XT for about a month now in an older PCI-E 3.0/AM3 system running Windows 10 on an FX-6300 processor. Everything was just fine. My R9 3900X finally came in after a month of waiting, and I put my new system together.

The result? Constant BSODs and crashes when browsing the internet. I finally narrowed it down to video content within Firefox (68.0.2) causing it. I disabled all hardware acceleration in Firefox, and my system has not BSOD'd since, when before it'd pretty reliably BSOD if I opened enough tabs with video content. Sometimes if someone sends me a video through steam, Steam Friends will crash and then reload with hardware decode disabled.

Playing video content through VLC does not seem to cause any issues (maybe It's VP9 decode?). I've also had some issues with the game MudRunner crashing, but I didn't have that game with the old system so I can't say if it's just the game or something else. No other game I've tried seems to have issues.

I also have severe bugs with refresh rates and my Pixio PX275h monitors. With both monitors enabled, the video memory is stuck at 875MHz. With one monitor enabled, only 60Hz works correctly. 75Hz is completely bugged and unustable, and the system will basically eventually crash. WattMan doesn't even function correctly at 75Hz. A single monitor enabled at 95Hz (monitor maximum) seems to work okay, but memory is once again stuck at 875Mhz like it is with dual monitors.

I don't know if it's PCI-E 4.0 causing these errors or what. I do have one WHEA error on every boot up, and that's with the latest 1.0.0.3ABB AGESA. I'm using an R9 3900x, ASUS TUF x570 WIFI, XFX Reference 5700 XT, 16GB GSKILL 3200 MHz RAM, Seasonic Titanium 750W PSU and a Samsung 970 EVO 1TB connected to the first M.2 slot. Using fresh install of Windows 10. It's not the RAM - it passed 3-4 hours of Memtest86. I've tried running it at both 2400 and 3200 MHz speeds with the same results.

Disabling hardware acceleration in Firefox stopped the BSODs. Most of the BSODs were IRQ_NOT_LESS_OR_EQUAL, or SYSTEM_SERVICE_EXCEPTION. I did have one crash that was a straight up reboot, no BSOD or anything.

27 Replies
redteam6
Elite

Re: 5700XT BSOD/Crashing with browser hardware decode + 75Hz bug

I can confirm i also have this problem with video in fire fox. 3600x b450m steel legend same agesa and 5700xt

redteam6
Elite

Re: 5700XT BSOD/Crashing with browser hardware decode + 75Hz bug

i dont think this problem happens in chrome for me

0 Likes
shinkojiro
Miniboss

Re: 5700XT BSOD/Crashing with browser hardware decode + 75Hz bug

In my experience, these BSOD's will be resolved if you fix your ram, timings and all. AUTO timings in the sub timings actually leads to unstable timings even if XMP timings, or even non-oc ram, appears to work.

How to Manually Tune Your DDR4 Memory For Ryzen - YouTube 

Do what is in this guide since you have a 3900x now.

shinkojiro
Miniboss

Re: 5700XT BSOD/Crashing with browser hardware decode + 75Hz bug

If not, I guess the problem really does lie elsewhere, but this is what resolved any BSOD for me.

0 Likes
rkt
Adept I

Re: 5700XT BSOD/Crashing with browser hardware decode + 75Hz bug

Hello, I am Spanish and I don't know too much English, but I will try to write the best I can, I have the same problem as you, when I am browsing Twitter on YouTube or other platforms, the screen locks and gives me a blue screen and I do not know why, I have the rx 5700 xt that has been brought to me today and I can not navigate quietly through websites, to play I have no problem for now, it is more, it is a graphic charm, hardly any temperature rises or anything, I hope That understand me and can help me.

Thank you.

0 Likes
pokester
MVP

Re: 5700XT BSOD/Crashing with browser hardware decode + 75Hz bug

There are other threads where they are talking about similar issues. Many are having some luck disabling hardware acceleration for the time being in the browsers. I will mention the mod, maybe he can get you all communicating in the same thread. I know they will want the full systems specs of each person having problems. amdmatt

0 Likes
pokester
MVP

Re: 5700XT BSOD/Crashing with browser hardware decode + 75Hz bug

I should add that you all really should be reporting this issue to AMD support directly. The forums are user to user. AMD Support: Online Service Request | AMD 

0 Likes

Re: 5700XT BSOD/Crashing with browser hardware decode + 75Hz bug

The issue only happens while browsing videos on the internet. Not during game play or normal desktop use. I have not had a single crash since I disabled hardware acceleration in Firefox. It's been almost 3-4 days without a crash, when before it would crash 3-4 times a day.

0 Likes
shinkojiro
Miniboss

Re: 5700XT BSOD/Crashing with browser hardware decode + 75Hz bug

It wasnt limited to gameplay for me either. I would BSOD from the desktop at times after installing 19.7.3.

0 Likes