cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

theflumpdoctor
Journeyman III

5700 XT low performance and frequent stutters

Hi all!

As per the title, I got a PowerColor 5700 XT to replace my three-year-old RX 480 Nitro Plus, which is paired with a Ryzen 5 2600X. I install the card and boot up the Witcher 3. I used to get comfortably above 60FPS, with it hovering in the 70-80 area but now I'm lucky to be hitting around 65 with frequent stutters into the forties which renders the game unplayable. I have had similar issues in Final Fantasy XV and Dishonored 2 (although for the latter, not to the same extent). I have the latest driver (19.7.1) and I am running Windows 10. 

EDIT: I tried to open Blender only for the screen to go to black for a few seconds, the audio cut out and I got a notification about WattMan being restored to default settings. This has happened a few times now.

0 Likes
13 Replies
m1adam
Adept II

im having black screen also seems like its a driver issue AMD has yet to release a new driver update, i cant game peacefully as crashing is just random and happens anytime

xdazzla
Journeyman III

me too, im getting constant fps dips and stuttering with exact same set up as you, did you find a fix yet?

0 Likes
pavelsergeev
Journeyman III

I have a similar problem with DOOM, The Divison 2, according to tests on the Internet, the FPS should be very high, but in fact constant friezes. Overwatch, World of Wacraft also have problems, albeit to a lesser extent.

2700 @ 3.8 / 16gb @ 2866 / nvme SSD
0 Likes
trixarian
Journeyman III

Have you tried rolling back to 19.6.3? I was having similar stuttering issues on the latest driver :/

0 Likes
osirismelb
Adept III

Gentlement upgrade your driver version to latest which is 19.7.2.

Use DDU to uninstall 19.7.1 first in Windows safe mode then install 10.7.2 clean.

0 Likes

This still happens even after doing that.

0 Likes

the new drivers you listed doesnt do any good what so ever. starting to think weve all got bad cards. i go on youtube asking around only every once in a great while do i find someone with similar issues. weird how some ppls cards works and some dont. personally im over it. had my card for two weeks as of the day after tomorrow and mine has been sitting in the box for the last 3 days, its a fkin paperweight essentially. a very expensive $400 paperweight and this is unacceptable AMD, WTF.. i also find it odd that i see AMD ppl posting on reddit yet after a week or longer of posting my issues on here i have yet to get a reply from any of AMD's ppl so i dont think they even monitor these forums or worse guys they dont care about our problems because it doesnt seem to be the majority's issue. when i ask around on you tube it doesnt seem like they even know about these issues over thereand ojnly once talked to someone that was actually experience similar problems so idk..... o and currently i have my display drivers updated to the newest windows version with no AMD display drivers installed at all, i did a clean unisntall with DDU in safe mode and yet MSI Afterburner is blank just like my wattman software was blank before. so honestly this may not be a software/driver problem after all.

jevgeje
Journeyman III

Did you find a solution for your problem?

0 Likes
putuish
Journeyman III

Same. I am playing Overwatch (medium quality) with 50-70 fps, and running fire strike ultra benchmark test at 2.6(?!) fps. Tried the latest and the second latest driver for 5700xt, doesn't make any difference. 

0 Likes
vandreal
Adept I

Yeah, I got a Gigabyte Gaming OC 5700 XT, I'm about to consider going back to team Green at this point. They are at least giving better product support than this! My Timespy score with my Vega 64 was triple what I got with this thing!!! (Same exact system except for the GPU).

0 Likes
cvearl
Adept II

I bought a 5700 non xt from MSI. Had some issues but they are resolved now. For me. it seemed to require some driver cleaning. First completely removed MSI Afterburner which I always use. Then removed video drivers for my RX 580 using DDU Display Driver Uninstaller Download version 18.0.1.9 

Once I cleaned the drivers off completely and rebooted, installed latets chipset drivers and set Power plan to High Performance. Then I reinstalled the video card drivers and THEN I reinstalled the latest MSI afterburner. Been good since. Stutters gone. Firestrike and Timespy off the charts.

C.

0 Likes
vandreal
Adept I

So, I just finished my reinstall of Windows 10 and setting everything back up. That fixed it. So, it turns out AMD was not really to blame here. It was Microsoft's fault. My entire system was running slow and acting up. Frickin' Microsoft! I really hope that Linux with Proton built in works well! I'm looking forward to running a system that isn't ask heavily dependent on  Win/MS.

0 Likes
trazzdi
Journeyman III

I had the same problem. Complete windows reinstall (format disk and reinstall) fixed it.

0 Likes