cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

jdetnerski
Adept II

19.2.1 Driver update and HDMI scaling on LG 4k TV's

I had been having scaling issues with my vega 64 and my LG 4k tv but a few updates ago resolved the issue and allowed my screen to properly scale but that gold age ended with driver 19.2.1. I am not losing 1/4 in (6-7mm) all the way around my desktop with no scale adjustment to be found. Why, oh why, does AMD fix a problem only to give it back?. 

32 Replies
jdetnerski
Adept II

Update 19.2.2 with clean install failed to resolve overscaling issue. 

Yes, I confirm ! I also have a LG 4K TV and I still have overscaling issues when I use my Radeon 580 on it !

According to other posts, it seems AMD has decided to remove the manual scaling option so it's likely we're doomed !

I do hope not, this problem is a pure software issue caused by a design choice somewhere in their driver to scale by 4% as I have no issue with an intel based device using the exact same display chain including my DP->HDMI2.0 adaptor. If the driver just left the damn image alone we wouldn't be having this problem at all.

lalaland
Adept I

Yup I have this too, why this isn't simply a global "disable overscan" toggle? AMD auto anything has never worked, from DDC on down these drivers have been terrible at "intelligently" setting anything to do with displays

lalaland
Adept I

Tried a clean 19.2.2 last night also - still no HDMI-Scaling control

0 Likes
lalaland
Adept I

And still we wait for someone to acknowledge whether this is by design or a bug that has been identified

jdetnerski
Adept II

Just tried a clean install of 19.2.3... No changes

0 Likes
lalaland
Adept I

Express upgrade 12.2.3 did nothing either, still no HDMI scaling control, still no HDR

0 Likes

I don't have any issue with HDR I'm just losing a small lip around the outside that makes it so I can't maximize any browser window or office app without it being a pain closing them. I figure it'll be another 2 updates before they get it working again. 

0 Likes
nolife
Adept I

I've found a solution to my problem : Not sure it will work for you but I tried to plug my hdmi cable in another hdmi plug on my LG 4K and it worked : The screen fits perfectly without any need to use overscale or anything !

So I guess my very recent (bought at last christmas) LG 4K tv has some bugs or malfunction on one of his hdmi port... but hopefully only one so if you use another one it's fine !

Figured I'd give your idea a shot but went a little further with it. I made sure the TV's software was up to date and it did need an OS update. Performed the update on the TV with no change then switched HDMI ports on the TV and still had no change. Unfortunately I believe this issue firmly falls into the laps of the people responsible for writing the code for stable drivers. I know they just brought out a new line of GPU's but come on, don't break what's already working to make new stuff work. 

I was beating my head with the same issue, in all LG OLED 2020 TV models (mine is OLED65GXPVA) you must specify the type of input in order for the screen to display correctly.

hold the input button, then on the Home dashboard click on the upper right corner settings icon, then edit. It will show you the HDMI inputs and you select PC from the drop-down menu. You can also edit the name of the device. I stumbled across this info from the User Guide in all settings, then troubleshoot menu. I hope this resolves the issue for everyone with an LG OLED TV. Have a great one.

Regards,

Mohammed

#LG#OLED#LG #AMD #rx580 8gb #adrenalin 2020 edition 20.4.2

0 Likes
lalaland
Adept I

Tried this from another direction and plugged the HDMI lead from my PC into my Xbox 1S for which 4K and HDR worked fine, plugged it back into my PC and it had the same problem as before (zoomed image @4K60, no HDMI scaling, no HDR). I use an A/V amp so all my sources go via the same HDMI lead from my amp to the TV and every other HDR capable source has no issue. To be clear prior to updating my drivers a few weeks ago my PC didn't either.

0 Likes

I tried playing around like that when I first upgraded to my Vega 64 and had this issue. I tried different cables, ports and different active adapters and it all points to the driver. I was running driver version 18.something with my R9 Fury Nitro and had no issues with my scaling, everything adjusted as it should until I upgraded to the VEGA 64 and the scaling problems began. I even went so far as to perform a clean install of Windows 10 Pro and start completely from scratch without any changes to the scaling issue. Right now I've just come to the conclusion that I'll have to do a regular driver update check and hope eventually it'll get resolved like last time; figure another 3-4 updates and they'll get it figured out. 

lalaland
Adept I

jdetnerski‌ Check your Settings-> Display-> Aspect Ratio, my B7 model appears to have grown a new setting in Just Scan, "Auto". When I set this to ON the zoom went away, not sure which TV f/w update introduced this and it causes issue with no other source but my PC. However the other issues such as not detecting HDR10 remain

I had checked the TV settings for different scaling and aspect ratio options, both before and after TV update, and it does not have the auto option. 16:9, 4:3 multiple zoom settings; quite frankly a nice selection of options when dealing with upscaling issues from 1080P devices but nothing to zoom it out any. Unfortunately this issue falls directly upon AMD's shoulders to fix; I with I knew what their logic was behind removing the HDMI scaling from their newer cards. I'm running an old legacy card for my media PC and the HDMI scaling option is still in the legacy version of their drivers.

0 Likes
jdetnerski
Adept II

19.3.1 installed with no change to scaling issue. Yet another report sent to AMD.  **Sigh**

0 Likes

Same issue here. Just bought Radeon VII and found overscaling problem.

0 Likes

Seems like a common theme. I wish I understand their decision to remove the HMDI scaling option from their driver software. I'm running a couple older machines for multimedia purposes and they use the legacy driver that still has the HDMI scaling option in it and works great. Throw in the fact that the scaling actually worked as it should for a few driver versions but then they screwed it up again a few updates later.  Sad thing is that I always avoided Nvidia because, working in IT, I had run into more driver issues with them than AMD/ATI drivers. Unfortunately, over the last year I'm running into more AMD/ATI driver issues but more DOA or defective nvidia cards so I'm telling people the truth. ATI cards, expect driver headaches, especially with new games and 4k tv's... Nvidia cards, you are rolling the dice with any of the 2000 series cards until new stock gets made because the first batch had a lot of cards being DOA or failing after a couple months (reports had numbers as high as 20% of the first run chips having issues). I blame the bit currency boom, created a flash in the pan of demand then went away. 

0 Likes
jdetnerski
Adept II

I don't know if this will help any of you following this thread because it did not help me but according to this article a recent windows update is affecting GPU and mouse performance. I removed the update and performed a clean install of 19.3.1 with no change in scaling issue. Just thought I'd share in case anyone was having issues related to this update. 

Microsoft Issues Windows 10 Upgrade Warning 

I could solve my issue :

I couldnt find "just scan" from quick menu of my LG TV (uj6200) but

found that I should go to the menu

quick menu - setting - aspect ratio - just scan "on"

I just found this option and it worked to adjust things. Is this option part of the recent system update? I went through my owners manual 3 times and that option is not shown or mentioned. Hopefully this will help the others following this thread. Thank you for the find. 

0 Likes
halestormx3
Journeyman III

I'm sick of this. it doesn't matter what driver I update to, it doesn't matter what settings I mess with what aspect ratio I'm using, I still get the overlay off my screen. My question is why the heck would they take out something as needed like hdmi scaling. just dropped 700 on a new pc an wanted an amd specifically all just to find out that my shiz isn't going to work now. Thanks a lot. Been scouring the internet for days and there isn't a single solution to any of our problems. Great job amd, I think ill go back to using intel and nvidia products lmao.

0 Likes
lalaland
Adept I

https://support.microsoft.com/en-us/help/4482887/windows-10-update-kb4482887 

https://support.microsoft.com/en-us/help/4489899/windows-10-update-kb4489899 

So I discovered last night I was still on 1803 and updated to 1809, as I was doing this after both the problematic Win10 perf update  (KB4482887) and it's fix (KB4489899) were issued they came down in a blob together and even attempting a manual install would fail with a this is already installed style error message.

Did a clean install of 18.3.1 == No HDMI scaling control, No HDR10

The HDMI is still borked, I don't have the scaling problem because messing with "Just Scan" fixes that but the problem is still the blasted driver

0 Likes
halestormx3
Journeyman III

I've tried every driver from 18.1.1 and still does nothing. They took out HDMI scaling and gave us nothing compensate. were literally all screwed until they decide they wanna do something about it. my question: why would they take out such a necessary feature. its kinda obvious now that a lot of people use their tv's now as moniters or use multiple monitors. bye bye amd lmao.

0 Likes
ngurgone
Journeyman III

Thanks everyone for all the collaboration.

Not sure about why did AMD do these changes on adrenaline drivers.

I had the same issue... so I tried all drivers and I've just found out that AMD Adrenalin 18.3.4 is the only one that works with this HDMI under/over scaling. I have and old LG 24 inch. TV with JUST SCAN option and an RX 570 8GB. This just scan option in my screen is enable enable by default so I'm using it so I don't have to manually scalate in AMD radeon settings.

The only workaround  I found is changing the Pixel Format from studio to PC. After doing this the screen, got the right scale and definition, this makes like sort of "forcing re-scan" and you can switch back to de studio format pixel if you want to after it is ok.

By the way sorry if something is not well written my english got a littly rusty.

Hope it helps!

Regards!

0 Likes
mothertrucker19
Journeyman III

This is a really annoying issue.

I couldn't fix it either.

0 Likes
raduandreika
Journeyman III

Try this one. Workerd for me. 

Before this maje sure you have hdmi 2.0 cable, or display port 1.2 to hdmi 2.0

1. TV on

2. Press "input" on remote

3. Go to "all inputs"

4. Select the hdmi connected to PC

5. Click edit icon on the right. 

6. From the list that appears, select PC. 

Now it should scale corectly. 

I have an RX580 and an LG 8100PLA and this worked.

I don't know what the TV changes when you chose an other icon for the input, but it works.

0 Likes

GOD BLESS you man. I went crazy the last days, i tried everything, settings, registry, different cables and ports  and couldn't just fit the screen right. HDMI scaling slider was also missing. Now everything works fine. I also achieved 1:1 pixel mapping. Your solution to change the input type to "PC" was the best. Thank you again!

referring to:

Try this one. Workerd for me.  Before this maje sure you have hdmi 2.0 cable, or display port 1.2 to hdmi 2.0 1. TV on 2. Press "input" on remote 3. Go to "all inputs" 4. Select the hdmi connected to PC 5. Click edit icon on the right.  6. From the list that appears, select PC.  Now it should scale corectly. 
0 Likes
grimly_fiendish
Journeyman III

According to another webpage I found, click on "Just Scan" for LG. BTW HDMI 2.1 cable is BS. They are all 2.1 compliant for current use. I am an audio engineer and I have a very good idea what is required when setting up AV. Current cables can provide all the bandwidth you need without upgrading. Save your money and stop being taken in by the BS hype. 

C/NET article here on 2.1 cables.

0 Likes
alexpack
Journeyman III

Guys for all of you I have found a solution. It actually IS the just scan option but it is not available if you don't go to 
All settings -> Picture -> Aspect Ratio settings -> and the just scan option is there and its is turned off. Just turn it on and you are good to go!

0 Likes