Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Xenserver issue with MxGPU

I have been attempting to get a FirePro S7150x2 working in a Dell R730 with latest firmware (2.8) for several days now.

It is running Xenserver (tried 7.5 and 7.4) without success.

I can get the card installed, and then install the mxgpu gim driver, the modprobe/info/lspci

commands show the correct entries. The card also shows up in the host correct in


I then install a Win10 VM and after installing XenTools and such, I reboot, then shutdown and add the GPU,

on XS7.5 sometimes the VM will not boot from that point on, just hangs, quite often the server needs to be reboot to be

able to attempt to boot again as well as remove the gpu resource.

One time I was able to get the VM to boot, add the Radeon Pro driver, but on reboot of the VM

it paused on black screen for quite a while, then blue screened with TDR failure

with atikmag.sys error.

I then tried to go back to Xenserver 7.4, again I can install VM and such, and add the GPU, I can also add the client driver, and

reboot, the first attempt will normally boot up then crash with blue screen after 30-40secs.

After it crashes, the VM will no longer see the AMD GPU, it still shows up fine in XenServer, but the VM won't see it, I must reboot

XenServer then the VM will see it.

Any ideas?

I have read there may be firmware specific to server brand, HP, Dell, or Retail, can anyone tell me how to find the

type of card and the firmware installed?

Can anyone provide what version it should be running?

Can I get the VBIOS for the Dell and a flash utility?

Been using the 18.Q1 drivers and the 1.0.5 GIM driver for XenServer.

I have submitted the above via email to global support, but so far they have been slow to respond and have not really gotten past basic info so far.

0 Replies