Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

windows 10 update stops rx570 driver

So on July 26/18 my Windows 10 64bit computer automatically installed an update from Microsoft. Just did it behind my back while at dinner.

Ever since then the rx570 drivers no longer work - device manager says:

"Windows has stopped this device because it has reported problems. (Code 43)"

I have a dual monitor setup and windows no longer can see the second display.

This happened originally about a week before when an alert from AMD about new drivers made me allow the install of the new diriver. Same problem. I was able to fix the problem by going back to the previous windows restore paint and everything was working fine again.

However, this time, after the windows update, there are no more restore points. It's like the update deleted them.

I've tried every single new driver from AMD up to 18.7.1 and still nothing. I even uninstalled the previous driver and reinstalled 18.7.1 and still no luck.

I am not a gamer. I use this computer for work and going back to a single monitor s severely hampering my productivity. Not such a good think with my employer.

The card is a MSI 5x 570 Gaming X 4G card, so I contacted MSI. They tried some things and gave up. Said to call AMD.

Turns out you can't call AMD you have to submit a form. But the form is for AMD cards only, not MSI cards. Nice catch 22.

Any help appreciated. I'm desperate.


27 Replies


MSI made your card and yes they should support this and yes this has been a very common problem. As black zion said you need to block the update. To get you rolling correctly again you can run DDU from wagnardsoft_com from safe mode, have the new AMD on hand before doing this. Unplug from the internet boot up Windows and install the correct driver. Reboot and verify all is working. You can plug back in have Windows check for updates and if it lists that it wants to update the driver you can choose to block it per instructions black_zion provided.

I uses a little utility winaerotweaker from winaero_com and it has a check box option to disable Windows 10 from updating drivers. I choose to update my own drivers as you have seen, Microsoft gets it wrong.

Good Luck!

Journeyman III

I can't believe it. I did fix the problem above a month ago, and today while I was at dinner Windows re-installed the dam update and again I'm broken.

I downloaded the latest drivers for the rx-570 as a month had gone by ans surely AMD have fixed this issue by now.... but no... still broken even after uninstalling the old driver before reinstalling the new one.

Somebody tell me please why AMD won't fix this? I am not the only one broken and they've had a ton of time to get a driver ready. Are they just too lazy  or they just don't care.

I've been an AMD fan for decades cut their losing me now.


I'm confused, why exactly is AMD to blame when Windows is the one updating and screwing up your computer? I get it's messing up the AMD product but AMD doesn't control what MS does with their driver repositories. MS screws up drivers on tons of stuff not just AMD's. They mess up sound and network controllers all the time too! Did you block Windows for updating drivers as I had suggested above and it still did this? I ask because typically once you have done this, the problem is gone. All driver updates are manual then. I do feel your frustration. Just do what you did again the first time and make sure to block Windows driver updates.


I know this is an old thread, but I just went through this with a "new" RX570.

Here's the deal..

When you build a system and do a clean install of Windows 10, one of the first things that happens is Windows installs a WQL driver for the video card.  This driver interferes with the installation of Radeon later on.

To get around this you need to download the Radeon software but do not install it.

Next you need to disconnect from the internet.

Next you go to Device Manager and uninstall the video card AND the driver software.

Now you can run the Radeon install. Radeon will  do its thing and you're good to go.

You can reconnect to the internet.

Adept I

So it seems this has not been repaired by either win nor amd, bought a RX570 (saphire Pulse) off a guy that was going to mine but the bubble burst before he could start. needless he was left with 12 cards.

My rig is a fx 8370, R9 270x, 32gb, win 10.

Took the R9 out (which had the latest drivers installed) put in the RX570 and I keep getting an error "AMD graphics driver is not installed, or is faulty. please install correct graphics driver for hardware"

I have uninstalled and installed both relive and adrenaline but keep getting the same message.

Put the R9 back in same message, installed adrenaline and all working  fine????

Could this be the same windows update issue?


No, if you did as you just said you did it, in not the most foolproof way. When removing a card you should uninstall the driver. Restart then go to device manager and remove the device. Then shut down and remove the card. Put the new one in then restart. Then reinstall the AMD driver of choice. If you have any issues from there, run DDU from safe mode, disconnect from the internet reboot and reinstall the driver again with the clean install choice.


Thanks for the reply. Yes I was fully uninstalling and installing drivers at each reiteration of the process.

On further investigation I have discovered that the card bios has been moded. This was not told to me at the time of purchase.

I have spent the last 4 hours and only now have I discovered a work around. To anyone that has this issue leave a message and I will list the way that worked for me. It is a lengthy process and don't want to type it out if no one will use it.

I am now running amd Radeon adrenalin latest patch smoothly.

In my opinion the money saved buying this card compared to the mental anguish and the insufferable mood I have exposed my family to over the last 4 days wasn't worth it.

Must of gotten a miners card I'm guessing. We have seen that here a lot. Unfortunately some folks are not honest. Even with miners most are cool enough to flash them and tell you it was a miner card. If you bought on ebay and they didn't disclose this you might have grounds for a refund. GPUz has a big repository of original bios, even the card makers will typically be happy to give the cards bios again. Sounds like you got it sorted though. Good Luck!


Can you please tell me what you ended up doing to get it to work? I'm so close to just sending this card back and buying a 1060.


May I ask what error message you are getting?

Right click windows button – device manager – display adaptors – Is windows picking up the rx 570? If it is right click – properties should have the error code in the device properties text box?


code 43.


Code 43 means he has changed the bios of the card. There is a work around.


Flashing with the original bios does not fix this?


I’m unable to find the Correct version to flash to it on gigabytes site. It’s a F20 bios version and they don’t have that in their site.


Ok so here is what worked for me.

1. Uninstall drivers using DDU

2. Download and run a program called ATI-KMDAG-patcher it will give you a pop up click patch or yes

3. Use Radeon Software Crimson ReLive Edition Beta for Blockchain Compute Release Notes | AMD  this is a minning driver that doesn't care about the bios.

4. This is crimson I updated through it to get to adrenalin. Got another code 43 ran the patcher again and all works 100%


I’ll give it a try.


We need to know some history, like where did you buy the card?  Is the card brand new in a factory sealed box or is it "open box" (possibly a return, or a "mining card" )?  Is this going in a fresh build or is this card an upgrade to an existing build?


Card was used off of ebay. Seller did mine with it. It does have the stock bios.

It's going into a dell prebuilt and replacing a 1050 ti that worked perfectly. I upgraded the psu in the prebuilt to get an 8-pin for the 570.


OK, try this...

Download but do not install the latest Radeon software.

Disconnect from the internet...  This part is important.  You must not have any access to the internet.

Go into Device Manager and UNINSTALL the video card AND all of the software.

Install the latest Radeon software and reboot the machine.

If this does not work you need to talk to dorwock..


Thanks for the suggestions. However, I've tried that a few times so far with the same result.


Roger that.  Hope you can get this squared away..

Journeyman III

hey i got the solution

watch this

How to Patch AMD ReLive Drivers and Get Your GPU with Modded BIOS Working in Windows - YouTube

ive being tricked by a seller too who said he use it only for gaming

but yeah in the end i found it was used for mining

my rx570 gigabyte solved at first try by following this video

damn, also got tricked, what did you do with your card? did you try to return factory bios? can't decide what should i do


i just following every step on this video

i cant reset bios because gigabyte said it was the same bios

Adept I

I just purchased from  New Egg last week it is Asrock RX 5704GB all sorts of prob;ems. New EGG refused return, Asrock said go to AMD, AMD said go to supplier. I think Radeon should step up and recall these cards, as i have tried the usual updates etc even reinstalled Win 7 Pro 64. Fed up now


This is why I stopped buying from newegg. Restocking fees and refusing returns. I pretty much stick with Amazon or more frequently Micro Center. Never an issue with returns.