Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

Warzone stuttering with 6900 XT

Hey everyone!

I've got this problem (which I can see in this forum that a lot of others are also dealing with) with stuttering in COD Warzone.
These are my specs:

Ryzen 9 5900x
MSI x570 Tomahawk
XFX Speedster Merc 6900 XT 16GB Black V2
32GB 3600mhz CL 14 ram
2x1TB m.2 drives
850W Corsair power supply.

I'm playing on 1440p 240hz monitor.

When I got the card I wasn't experiencing as much stuttering as I am now. This only happens when I play the big map Caldera. It's especially noticeable in the beginnings of every match.
I usually get above 200-230 FPS in most areas of the map, but some I get 170 (Fields). The stuttering really kills the enjoyment of the game. I've read and heard from several other people that they are experiencing the same issues. Is this just an AMD problem or is it the games fault. I've played other games that doesn't have this issue.

I've tried both overclocking and underclocking. Underclocking helped a little bit, but didn't get rid of the issue.
I've done a fresh install of windows and tried older GPU drivers (using DDU)
I've tried disabling SAM to see if that was the cause, but no.
I've tried changing the values in the game files like the Renderworkercount and the Videomemoryscale. That does help boost my general FPS, but it doesn't get rid of the stuttering. Currently I am using: Renderworkercount = 6 and Videomemoryscale = 1.2. I've tried lowering the VMS, but that only made the stuttering worse in some cases.
I've tried increasing the render resolution in-game from 100 to 110, 120, 130, 140, 150 and so on to see if that helped. I've read that it has solved it for others, but in my case I only get a lower FPS and keep stuttering.
I can't even list all the things I've tried changing to get this solved...

Please AMD, get this sorted. This might be the last AMD card I'm ever going to buy. I've never spent this much time trying to solve such a stupid issue with any other GPU.

458 Replies
Adept I

I set max FPS to 250 and I lower the clock of my 6800 XT a little bit (2720MHz>>2690MHz).
With both things my average, 0.1% and 0.02% low goes up and stable.


Can you share the rest of your settings?

Adrenalin and ingame?

Did u have stutterts before?


could you post specific benchmark results with 1% and 0.1% lows pls. Also general pc specs


Adept III


not sure if this have been tried - disable the High precision timer (HPET). For me I was sick and tired of stutter in BF 5 when running with dx 12 and now - nothing at all. Disabled it in both bios and device manager and have no issues at all - other than perfect fluid gameplay !

If not - then give it a try !


yes tried

Adept III

Did someone try the new driver Adrenalin 22.8.2 Optional if it improves the stutters?

Adept III

@Matt_AMD Was wondering if you could upload a vid of gameplay on caldera with a system without stutter but include 1% and 0.1% lows and framerate graph? Noticed on your yt that all your vids exclude 1% and 0.1% lows and only have a hard to see frametime graph. After all this time im still perplexed why some systems have the issue and others dont, the most frustrating part is not knowing the real reason other than that it is probably driver related.


@Mushbeck Here you go. 

I capture the benchmark results as I leave the plane at the start of the match.

thanks for the speedy reply. So your 1% lows are pretty much the same as mine and based on that 0.1%lows must be sim to mine aswell. You dont notice and stutter ? really strange.

Also the dude naded himself at 18.50 is hilarious. 

Hmm... my experience is mostly unstable framerate. No NOTICABLE stutters, but framedrops can REALLY be feeled sometimes. They don't affect gameplay heavily for me, but more of a comfort side. But i am also just really bad at shooters.

Don't mind my awful play there as i played Warzone first time in months. I don't play shooters often, so my PVP environmental awareness is close to 0, as well as aim. It was more of a recording of AVG 1% and 0.1% FPS. In first battle they somehow were more consistent than in second one though. 

I used not benchmark settings for RivaTuner, but circle buffer for 1 and 0.1%. So it show better feeling of flow that i get in specific situations.
1920*1080, bit more than medium settings.





Thanks for the upload. Based on your numbers id say it is in line with mine. Do you feel noticeable stutters?


@Dimka One thing to consider with 1%/0.1% lows in Warzone, connection can affect it too. If you have a player with a higher ping or latency on your team, it can cause worse 1% lows etc. If you want to minimise the effect of other players on your stats, play singles only. Quads will always have the worst 1% lows. 


I was able to use 'moreclocktool' from igorslab and lock my minimum gpu clock 100mhz below my max gpu clock. 


Stutters are gone. Without moreclocktool my gpu clock was boosting and going back to base clock every so often. Setting gpu frequency in amd radeon software wasn't working properly. 


@Mushbeck More like noticable framedrops. Not sutters as i use to know them (and i play BDO)

@Matt_AMD Ok, i will try to run single player match. It's just this mode was auto 4 player


I recorded today also 1 gameplay.

in the video i can not notice the stutters like i am playing live.

overall it doesnt feel like i am playing with 200fps and 144hz, it feels like 60hz.

if interested i can upload it on youtube. I dont know why afterburner doesnt showed 0,1% FPS.


you need to enable in osd and then start a benchmark (look at msi benchmark tab to find hotkey).0.1% and 1% lows only show during a benchmark (it just means a record of metrics will be saved).


That's because recording is always 30 or 60 fps. So if you drop 200 to 60 for example it won't be noticed in recording. But it will be feeled in game. 


also using a framerate graph not just frametime graph makes it much easier to see when stutters happen even tho playback is at 60 fps. 

Adept III

i recorded again 1 round caldera solos.

my framerate 1% and 0.1% seems very low.

Also the GPU is not on 99% usage?

3:48min in video









Good upload man, you seem to be experiencing the same kind of stutters we all are. Btw if anyone wants to try this setup and report back id be curious to see the results. 


Yes i tried to set the minimum clock 100mhz less then Maximum. But it doesnt Help.

Can someone explain why the gpu load is not 99%?

My gpu load is between 65-90% only.

If I am playing vanguard m multiplayer the gpu load is in 98-99%



if GPU is well below 99% - like you state 65-90 - then it could be that your CPU is not up for it / cannot keep up with that speed. If ULPS is disabled and you have min clock 100-200 below max clock and your GPU is still running low - I would say it is a CPU problem. 

Do you have HPET disabled ? That + the bcdedit commands made my computer like a dream !



Did you watch the video?, His frametime line is straight al the way. That mean the game runs smooth as butter. I think his low min are affected from the game startup and "warm up" time. And thats normal to have stutters because the people are get loaded in. (server side)

Adept III

i tried to disable HPET as shown at xbitlabs, it didnt change anything.

started bench mid game.

Amd 5900x should be bottleneck? i do not belive this


Does it help to change to Windows 11?


Off chance , what is your renderworkercount set too? and vidscale? id tried either the same as physical core count or half physical core count and vidscale set to 0.7 (make sure the game is acctually adhereing to it) 

Also if you use msi afterburner but set min clock in adrenaline software you need to re open adrenaline and reapply min clock profile becuase msi afterburner resets card min clock to 500 in adrenaline on luanch. I can see on the osd that gpu clock is 514 so its being reset when you opened afterburner. Just alt tab while in game and open adrenaline and reapply. In addition mess around with power managment in windows, soemtimes ultimate isnt best. 

Adept III

i tested renderworkercount from 4-12 everything. the best for me is 6 or 8.

VideoMemoryScale = 0.85
RendererWorkerCount = 6

to set the clock i use moreclocktool.


This time i set the min clock over the adrenalin software: min 2280 / max 2380

render worker count 6

some of my cpu core jump to 100%?







Although I don't believe this to have any effect on the issue, the optimal setting in my testing has been to set the renderworkercount to 1 below your physical CPU core count. So for a 5800X3D, that would be 7. For my 5950X, I used 15. 

Although setting it to half your core count can give small increases to FPS in certain scenarios such as in the practice area when CPU bound (eg running at 720P low settings), it can also result in lower FPS when jumping out of the plane and parachuting down on the map. 

Overall, 1 below the physical CPU count provides the best overall FPS and experience for me. 

As you questioned party desyncs affecting FPS.
Played solo... Same result. Huge dips in FPS, which are noticable as they go below Freesync range. Not as stutter, but as dips. And definitely not avg 150-180 FPS gameplay. Not even close.

That is common FPS graph i meet. I am either CPU limited, or there is definitely some framepacing issue. Also i noticed that it takes up not 85% VRAM (as should be by config), but basically WHOLE 12GB instead




Set the VRAM to 80% or lower. No need for it to be 85%. I too have noticed the game seems to use more than it should so 80% would be the maximum I would use. 


Well. I finally decided to try this one out.
MPT disable DS_GFXCLK. I really didn't want to do this. But actually i hadn't saw negatives yet. To be honest, even Superposition results went from 7760-7780 to 7860-7880 (got my new PB - 7892). Just from this one checkbox being disabled. 
And about ULPS... For me ULPS doesn't affect active games (at least for RX 6000 series) and only causes stutter after long pause in alt-tabbing from game and in it. Also disabling it causes GPU to pull 30W instead of 10-15 when BDO in hidden in tray. So i still have it enabled as by default. 

So... Here is result.
I clearly see MUCH more consistent frametime and less dips. There are still frame "stutters", but they happen really rarely compared to what was before. Imo, but AMD was bit too heavy on speed of GFX cores switching to deep sleep state. It really happens too fast and can affect consistency. 

If i change render worker count to 11 because i have 12 cores with my 5900x, the Feeling getting really worse.

The crazy thing is. If i Check the renderworker count of vanguard which were automatic set from the game, it is set to 13 and the game runs smooth without problems. The gpu is always At 98% load.

I dont know what i should try, just hopping that the problem is fixed with warzone2. 

All of u who has the problem is playing in Windows 10? Or someone also here on Windows 11 with stutters?


Maybe try 9 then.

changed it to 8, 9 was not good and laggy.

-> does this work? MPT disable DS_GFXCLK.


here my cpu usage  highest cores are around 70-80%





Adept III

Task manger doesnt report usage correctly (usage can be higher than 100% but task manager tops out at 100, use hwinfo or resource monitor)  but its still concerning to be hitting such high usage on a given thread. Next thing id suggest is in rivatuner set a fps count of 180 and report back how that feels. Apart from that this is the exact issue we've all being dealing with for months. No clear reason why one system is effected while another is not. 

I know you have probably posted before but what are your system specs in full.


Prozessor: AMD 5900X
Grafik: AMD Gigabyte 6800XT
RAM: G.Skill Trident Z RGB DDR4-3200 DIMM CL16 4x8GB
Netzteil: be quite straight power 11 - 1000w

if i limit it to 180fps -> fps drops to 150 and stutters the hole time

Journeyman III

Task manager doesn’t report the correct usage (usage can be higher than 100% but task manager tops out at 100, use hwinfo or resource monitor). But it is still concerning to be hitting such high usage on a given thread. I would suggest that you lower the framerate of the recording and see how that feels. Well, apart from that, this is the exact problem I've been having for months. I didn't really know what that meant either. But I asked my friends and they helped me find out what they meant. It means system specs, I'm not sure if it is specific to computers or not but I'm just going to assume it is.


I didn't really know what that meant either. But I asked my friends and they helped me find out what they meant. It means system specs, I'm not sure if it is specific to computers or not but I'm just going to assume it is.

Adept III

Can someone explain me

why gpu clock is lower then default clock?



Default clock ist just on 144mhz?


Journeyman III

hey everyone

finally no stutter,  i disable POB and set the card 100mhz less than normal.

i tried everything for the last 9 month, with this 6900xt card.

msi afterburner, morepowertool and so on....all the YouTube videos!!!! 

is the first time i have no stutter in caldera, in rebirth and fortunes no problem this gpu is a monster. 

in the past, the 100mhz less clock on the 6900xt don't really help, just a bit.

today i saw a old video of verdanks were somebody was comparing POB off and on, and default and 200mhz oc, and he achieves the best result (FPS) with POB off. 

so i tried an boom no stutters!!!!

everything is default, i think POB make problems in combination with this 6900xt cards.

what i notice in the last 9 months is, that all the win 10/11 optimization makes the problem worse.

VideoMemoryScale = default
RendererWorkerCount = default 

Mainboard: X570 AORUS MASTER
Prozessor: AMD 5600X
Grafik: AMD Gigabyte 6900XT OC
RAM:  DDR4-3200 DIMM CL16 4x8GB
Kühlung: arctic liquid freezer ii 240
Netzteil: Corsair RM850


What is POB???
PBO? - It is CPU related boost behaviour.

But if it is something different, you better explain. Especially as you wrote it as "POB" many times without explanation.