Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

Warzone stuttering with 6900 XT

Hey everyone!

I've got this problem (which I can see in this forum that a lot of others are also dealing with) with stuttering in COD Warzone.
These are my specs:

Ryzen 9 5900x
MSI x570 Tomahawk
XFX Speedster Merc 6900 XT 16GB Black V2
32GB 3600mhz CL 14 ram
2x1TB m.2 drives
850W Corsair power supply.

I'm playing on 1440p 240hz monitor.

When I got the card I wasn't experiencing as much stuttering as I am now. This only happens when I play the big map Caldera. It's especially noticeable in the beginnings of every match.
I usually get above 200-230 FPS in most areas of the map, but some I get 170 (Fields). The stuttering really kills the enjoyment of the game. I've read and heard from several other people that they are experiencing the same issues. Is this just an AMD problem or is it the games fault. I've played other games that doesn't have this issue.

I've tried both overclocking and underclocking. Underclocking helped a little bit, but didn't get rid of the issue.
I've done a fresh install of windows and tried older GPU drivers (using DDU)
I've tried disabling SAM to see if that was the cause, but no.
I've tried changing the values in the game files like the Renderworkercount and the Videomemoryscale. That does help boost my general FPS, but it doesn't get rid of the stuttering. Currently I am using: Renderworkercount = 6 and Videomemoryscale = 1.2. I've tried lowering the VMS, but that only made the stuttering worse in some cases.
I've tried increasing the render resolution in-game from 100 to 110, 120, 130, 140, 150 and so on to see if that helped. I've read that it has solved it for others, but in my case I only get a lower FPS and keep stuttering.
I can't even list all the things I've tried changing to get this solved...

Please AMD, get this sorted. This might be the last AMD card I'm ever going to buy. I've never spent this much time trying to solve such a stupid issue with any other GPU.

458 Replies

rumor is that there is a new map replacing rebirth island in the new season... lets hope it won't be a stutteri mess like caldera


I have good news, I overcame all my stuttering in Fortnite by changing Windows Gaming Mode to off, then I followed the steps in this video:

You may think it is not worth the time, that it is unnecessary, but I mean it, I have zero stuttering in Fortnite now playing on Epic settings.

I am not sure what did it, but I guess disabling Windows 10 Gaming Mode may have done it, since he did say it can cause problem to have it on for AMD users.


Guys, please stop posting about Fortnite in this thread. If you want to discuss Fortnite then create a thread about it - this thread is for COD Warzone.

In the first minutes, the game stutter with the 6900xt below to 100fps (mines and peak) . Is my 16GB (2x8GB) RAM with 3200MHz CL16 too slow for that ? I think my CPU 5600X  is bottelnecking the 6900XT?

Adept I

I just bought 6900 xt, 5600x. And I got the same problem. Every other game is working fine. Only Warzone Caldera stutters. On graphs I can see frame times peaks, also heavy GPU load drops. 
I saw suggestions: create profile for warzone, where you decrease GPU frequency -100mhz. I made -200mhz, it definitely helped, but stutters still present. They are just smaller and rarer.
Any advice how to fix it?


@Vad1us Not at the moment no.

All we can do right now is to wait for the next driver update. They already addressed the problem in the latest driver update, so it is on their to-do list. Hopefully we'll see a fix in the next update.



Ich habe mein Pc ein Upgrade spendiert vor 2 Tagen. hatte bis jetzt die selben Probleme.

Mein Sys

* Moba: Asus Strix Z690 A Wifi D4 mit Intel I7 12700k @ 4.8 Ghz Win 11 neuste Version alle Driver aktuell 

*Speicher: GSkill 4000 Mhz cl 16 XMP Profile 

*Graka: XFX RX6900XT Speedstar Zero EKWB Edition, neuster Driver Software von AMD

*PSU: 1200 Bequiet Dark Pro 12 Generation

*Monitor: 2 x 240 Hz 1440P, Asus 

*Custom Wasserkühlung 2x 360 er Radi etc


Hatte diese Stutter auch, was mir geholfen hat war das ich den Spiele Modus deaktiviert habe...

Rezisebar ist aktiviert, vlt hilf es den ein oder anderen.

Ich muss trotzdem sagen das ich mir etwas mehr erwartet habe, komme von einer 2080 super und hab nie solche Probleme gehabt.

Was immer noch ab und zu ist dass der Sound erschreckend laut wir oder rauscht extrem..



Could you please try and run the game a 1080p and report back. Thank you.

Adept I

Hi ;

even with the last Update of the game still stutter on caledra Map the new map work fine


here is my video to show stuttering problem AMD fixed it pls


Ryzen 5600X


1080P 144Hz

win 11






this could be driver issue of course - but I think this is related to amount of frames being created cpu vs gpu vs monitor. 6900 xt is very fast gpu - so if cpu cannot catch up - like if render ahead is just 1 - then gpu could be idle and waiting. Could be monitor being a G-sync only monitor - like I had as problem. Even if you disable v-sync it could lead to problems. So now with freesync monitor no problems at all.

So what monitor do you have - Freesync / G-sync ?

1080p is not much so not hard for gpu / cpu - with that cpu you should hit high fps - no stutter. I guess that Warzone is a dx12 game - have you enabled future frame rendering (if that is even possible). With those speeds and this cpu - I guess you should have a render ahead of 2 and not just 1 as is default - that alone could lead to stuttering..

Are you able to open a console and issue command to graph cpu and gpu - like in Battlefield 5 and 2042 ? That would give away if this is cpu or gpu problem.

In adrenalin - what is settings for this game - vsync always off and to the right Freesync: Amd optimized or on / off (depending if you have Freesync monitor). If g-sync - should be off - if Freesync - then on. I have bad experience with the amd optimized.

To have butter smooth gameplay - you need to eliminate hick-ups - that is cpu and gpu should both run at constant pace - no waits !

Edit: Remember to disable anti-lag in adrenalin !!



Screen from new 22.6.1. driver. AMD confirmed the issue. Same line in patchnote 22.5.2.
I think im gonna sell my 6900xt, because this, to put it politely, is completely unacceptable to me.

With you, tired of trying different fixes, Intel/Nvidia will be my next path for upgrading. Never have I had to tinker, mess and change so many settings just to get it to run ~subpar and still barely playable….


strange - I have amd 3800x cpu and 6900 xt gpu - and a freesync monitor. Currently running 22.5.2 and now played warzone.

Butter smooth and not stuttering at all.

But I follow you - you get tired of messing with settings all the time. 

Hope you will get out of problems with change to intel / nvidia.

Try to google problems in that direction. Think no matter combination you will find problems on all combinations around the globe no matter what !


@Thomasdk1405 idk what res you play on but it seems if you play on resolutions higher than 1440p the stutter is very minimal to almost unnoticeable


Hi - I play 1440p all high / ultra and with hdr. No issues at all.

Journeyman III

i played 1440p last night with the lowest settings (2 caches on)

Renderworkercount = 6

Videomemoryscale = 0.55

underclock to 1700 MHz (low 1500 MHz) with lowest voltage

i didn't see / feel stutters


Here is my question.

1700 MHz is WAY WAY WAY lower than default. would it be harmful to the card / system?


Please verify using msi overlay frame graphs. "feel" is to subjective. Using 150% render it can "feel" stutter free but graphs are still obviously showing frame drops.


Thanks @4orumid for this suggestion. 

I tested it out on a system that was able to reproduce the minor stuttering seen in this thread. Lowering the max clock frequency of the 6950 XT from 2.6Ghz to 2Ghz completely eliminated the stuttering at 1080P low settings, as seen in the Caldera map.

Whilst this is not a long term solution and the issue is still under investigation, this is a workaround that other users can try as a possible temporary solution when running this map.

@Matt_AMD the other workaround is playing at a higher resolution for me, could you also update the fortnite thread matt, I’ve struggled with both caldera and fortnite stutters since owning this card. No matter what dx engine I play on on cod or fortnite. Amd really needs to try and tackle this! I like my system being all amd when it works as it’s intended to because the performance is great!!


@Trickle2x2 I don't have any further update on Fortnite other than its still under investigation. When that changes I'll be sure to update the thread to let everyone know. 

Further investigation today. Possible fix mentioned in my previous post seem to be short lived. However, manipulating paging file does seem to influence how consistent stuttering is. My stuttering is still reproducable at the exact moment i pull parachute withj frame rate dropping from 200+ to 130 in  short waves until the animation is complete. I have also noticed that i experience stutter when the game is loading in complex assets such as a new built up area. Once the stuttering is over (area rendered/loaded) the performance stabilizes to be consistent with rebirth smoothness. I have a therory that rebirth has no issue as the assets for the entire map can be dealt with by vram or system memory for an entire game. However, caldera being much larger must deal with assets in a tiered manner thus each area is loaded to 100% or loaded into vram from paging as the player moves around. This is why when moving quickly by air with large draw distance i see stutter but almost none while traversing the map by foot. I was able to reduce stuttering by completely disabling paging file. 

This is just a theory and i dont have enough technical knowledge to know if this is plausible but it is what im experiencing and after literal months of testing (PROCESS OF ELIMINATION) it makes the most sense. look at top right frame graph when pulling parachute 


@Mushbeck i get what your saying but I don’t understand how Nvidia has it figured out to be stutter free but amd can’t seem to do it. Having to change all these windows settings to get it somewhat playable is daunting and not what I was expecting to have to do with a $1,000 dollar gpu.


I would suggest trying the workaround I posted earlier for now, since there is no risk at all trying it.

@Matt_AMD same stutter playing at that mhz, doesn’t matter. Amd needs to tackle this.

video i posted is with max boost limited to 2000mhz. No change.


Tried all the solutions, nothing helps.
Caldera map remains a problem, my hardware is.
AMD Ryzen 9 5950X 16-Core Processor
AMD Radeon RX 6800 XT


@Matt_AMD what are your specs, each component brand timings oc settings monitor etc, im wondering if this could be a component issue amd drivers aren’t agreeing with. Cause I do not understand why some have this issue and some do not.

Super curious about this aswell. Very strange that not all builds have an issue when each build is borderline identical. Although its possible that way more people have an issue they just dont notice due to lower refresh rate monitors, no testing etc. Browsing the net i do find a ton of people with this issue. Alot more threads than at the beginning of the year. most people just return the cards and switch to nv.

Adept III


have a look at this one

disable ULPS

Raise min clock freq 100-200 mhz below boost clock or max clock.

Save it and load this on game profiles or make it the global setting !


@Thomasdk1405 I always have my ULPS disabled and min clock 100mhz below boost clock. Hasn’t helped me. Game still hitches, feels like 30fps when I’m sitting capped at 140fps. New map is completely smooth tho. Caldera still just the issue for me.


then I only have this one left for you - the inteligent standby list cleaner !

Hope this one helps !



tried again no change.


Could it be that this game has a problem ?

Non amd gpu here but 3080 ti and stutters. 

He shows the fix !


@Thomasdk1405 exactly why I think certain hardware might not work well with other hardware. I did try my buddy’s 3080 and it was a fluid experience!! So if amd can’t solve this issue before I can get a rtx 4xxx card I will probably be selling mine..

Yeah ive already got my cable mod 3x8 pcie cable so i can pull the trigger on team green again.


Curious question - is it only this game with stutter or other games also ? If all games then you could have bad card. If not and only this game it could be in the game - favoring nvidia cards. BF2042 was really bad and people did all kinds of tricks to get it running. Here it was both nvidia and amd. 

Btw did you come from nvidia before. Did you wipe all nvidia drivers as in no conflicts ?

I have had my share of issues but was solved with the ulps thing and raise low clock up to 2000 ish

Hope you will succeed with team green again !


@Thomasdk1405 i have completely wiped my pc, partitioned my drive, ddu’d any drivers windows may have installed, updated bios and chipset drivers still to have this issue. My pc does stutter some in fortnite in dx11, dx12 and performance mode, dx12 seems most stable with some hitching and low fps stutter even in comp settings. The only other game that gave me issues was forza 5 horizon life when online, I had to disable a setting “not graphical” was some issue with loading custom player designs. All other games are butter smooth for the most part with some minor stuttering here and there but the normal amount nothing bad.


Came from green but completely new build. played pubg, halo infinite other call of duty mps all perfect. 

Just fresh installed windows only dl the game and let windows update all drivers (it grabbed 2.5.1 amd driver) no change. Even used the most defualt bios settings downclocked ram to 3200 mhz. One thing i tried which had some success (still stuttering but not in waves ) was using the pro driver instead of the game adrenaline driver. 


sold my 6800xt got used 1080 ti and runs flawless 0 stutters less fps but 0 stutters amd should be ashemed one of the biggest game on the market runs like a pup it is just not accaptable 

Hi which AMD card do you have in your build ? 6900 xt or some other ?