Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

Warzone stuttering with 6900 XT

Hey everyone!

I've got this problem (which I can see in this forum that a lot of others are also dealing with) with stuttering in COD Warzone.
These are my specs:

Ryzen 9 5900x
MSI x570 Tomahawk
XFX Speedster Merc 6900 XT 16GB Black V2
32GB 3600mhz CL 14 ram
2x1TB m.2 drives
850W Corsair power supply.

I'm playing on 1440p 240hz monitor.

When I got the card I wasn't experiencing as much stuttering as I am now. This only happens when I play the big map Caldera. It's especially noticeable in the beginnings of every match.
I usually get above 200-230 FPS in most areas of the map, but some I get 170 (Fields). The stuttering really kills the enjoyment of the game. I've read and heard from several other people that they are experiencing the same issues. Is this just an AMD problem or is it the games fault. I've played other games that doesn't have this issue.

I've tried both overclocking and underclocking. Underclocking helped a little bit, but didn't get rid of the issue.
I've done a fresh install of windows and tried older GPU drivers (using DDU)
I've tried disabling SAM to see if that was the cause, but no.
I've tried changing the values in the game files like the Renderworkercount and the Videomemoryscale. That does help boost my general FPS, but it doesn't get rid of the stuttering. Currently I am using: Renderworkercount = 6 and Videomemoryscale = 1.2. I've tried lowering the VMS, but that only made the stuttering worse in some cases.
I've tried increasing the render resolution in-game from 100 to 110, 120, 130, 140, 150 and so on to see if that helped. I've read that it has solved it for others, but in my case I only get a lower FPS and keep stuttering.
I can't even list all the things I've tried changing to get this solved...

Please AMD, get this sorted. This might be the last AMD card I'm ever going to buy. I've never spent this much time trying to solve such a stupid issue with any other GPU.

458 Replies

Ive been dealing with this issue also except I play mw 2019 which is on the same engine. 5950x asrock 6900xt. I've come to a conclusion ftpm is causing mine on windows 10 so i disabled it. Also make sure smart access memory is disabled. Also what gets rid of the stuttering is playing on full screen border less.


this will never be fixed amd radeon group never again for sure

At least they are acknowledging the problem in the new driver patch notes..

Known Issues

  • Stuttering may be experienced while playing Call of Duty®: Warzone™ on the Caldera map with some AMD Graphics Products such as the Radeon® RX 6900 XT Graphics.

They should probably note also that changing cod vram usage to .55 instead of the default .85 is beneficial across the board for all the cods besides just warzone. Some maps on vanguard I had slight bit of stutter, but changing that setting in the advanced options seemed to have fixed it. Again wish for the money that we paid for these cards we wouldn’t have to trouble shoot like this and change these things around. Coming from nvidia side which was pretty much just plug and go this can be a bit frustrating and I can see how it could possibly driver customers away.


I understand you, i'm really tired, frustrated. I even had a 10900K / RTX 3070 in my hands, returned it after seeing the benchmarks and I switched to a 5900X + 6900XT. Worst decision i made. Today an RTX 3080 will arrive that i bought because i can't take it anymore. If i could i would love to have my money back, i'm Brazilian and it's not as easy for us as it is for you. It was supposed to be a dream come true for me. The RTX 3080 will fix my problem in Caldera, I tested with a GTX1660 Super + 5900X and all problems are gone. GTA IV worked much better, CS:GO improved, Call of Duty 2 now works in DX9. It simply loses image in DX9 and you are forced to use DX7 on 6900XT. Call of duty 1 was unplayable when turning on dynamic light. PUBG much more fluid, these are the games i've been tested. The only thing missing now that i got the 3080 is to fix the stuttering on Windows, i'm considering getting at least a 11600k until these issues are resolved. Sorry for the text but i needed to share my experience with you guys. I really want to cry.



Adept I

I have the same with my 6800xt, even tried everything. No solution to be found. It played better on my 1080. Hope for a fix soon.


dont get ur hopes becouse this is since caldera has come out im early owner of 6800xt and the problem never got fixed on my system it was all fine in old map verdansk but caldera no go


Rebirth works fine, caldera map is a disaster. My ps5 plays better on caldera with less fps.


@aditrex well at least now they've acknowledged it and is actively working on a fix/solution. I imagine it won't be long since it was put in the driver notes.


Off topic but fortnite is unplayable for me also. Like severely. Just noticed this now when my buddy’s got me to download it again. I’m about to pull all my hair out owning this gpu lol. Max fps is like 140 with constant drops to the 30s….


I'm pretty sure they solved fortnite issue in the latest drivers. So make sure your bios and graphics card has the latest version. 


@Byytet Have updated both bios and gpu drivers, game is still actually unplayable for me. Worse than caldera. I will sadly probably be posting my gpu for sale and buying a nvidia counter part. Two games now that are very popular and my friends love to play that my 6900xt simply cannot. A shame for a $1,000 dollar gpu….


fortnite for me to is unplayable on 6800xt in dx11 mode.. in dx12 its ok..


@igor989 in dx12 it’s “alright” for me also. MAJOR stutter in pre game lobby, to the point I can barely move whether in dx11 or dx12. Sorry off topic on warzone but just another main stream game I cannot play with my buddy’s….


I'm having sound/video stutters in just about every game right now. Running a Toxic 6900xt and a 5950x. Read an article in the forums that was saying if you turn off fTPM in BIOS it should fix it. I'm going to be testing this right now.

Ryzen 7800X3D - RTX 4090 FE - ROG Strix B650E iGaming - 64gb 6000mhz G-Skill Neo - Noctua NH D15 - ROG Loki Platinum 1000w SFXL - 4TB Samsung Gen. 5 NVMe - Fractal Torrent Case - ROG PG48UQ OLED

@mengelag my sound will just go away sometimes in cod for about 1-4 seconds and then come back. It’s very annoying also but not as detrimental as the stuttering.

Adept III

hi @Tricczyy 

 I have a problem like yours with:

  • RX 6900XT average temperature 70c in games (2000RPM)
  • CPU: i9 9900kf Average temperature in 60c games
  • Motherboard: ASUS TUF Z390 game with WIFI
  • 2t SSD NVMe (all games are installed)
  • 480 g SSD (for windows)
  • 16x2 ram 3000mhz cl 16
  • Windows 11 64 bit
  • PSU 800w Radeon Software Adrenaline 22.5.2
  • 2k monitor (2560x1440p) 165Hz DP port  

bro you have to turn on Above 4G decoding in bios maybe that can fix your issue you can follow this link :

and if you has low GPU use follow :
After a few checks, I realized that older games do not use all the power of a graphics card, for example, I use only 30% of my graphics card in left4Dead 2.
New generation graphics cards seem to achieve 90% performance only with the DX12 and Vulkan.
For example, in Cyberpunk 2077 and my graphics card control is used up to 99%.
There is also the problem of disconnecting and reconnecting the sound in DX11
To fix: Try to increase the resolution scale in the game ( for low GPU use )
Turn off Free Sync and turn on V-sync in games
and turn off any overlay in game



I've already got Smart Access Memory (4G decoding) enabled. No difference with it being turned on or off.

Turning up the render resolution or enabling v-sync is not an option. I will not settle for lower FPS and worse input lag when I bought the best GPU AMD had (At that time). This should not be necessary. I bought this specific GPU since the performance on warzone "WAS" great. Now somehow, it's not.

All overlays are turned off. 


First make sure you use AMD chipset drivers - you could use their cleanup tool. Then go for only the WHQL drivers (recom. ones and not beta).

Update your bios to most recent one and make sure xmp or whatever its called is in use.

Find your way to fTPM and disable that (made the trick for me !). Disable CSM also (think that is obvious as this prevents the 4g high mem / SAM).

In driver - go for std. settings - so no anti lag and no enhanced sync. I have gsync monitor so I had to turn all off - if you have freesync perhaps you can use some of this. I've had 6900 xt since January and got problems since then !

Also followed someones tip to disable HPET - but that turned out to be bad idea. The fTPM and clean install of chipset / gfx driver from amd did the trick. Had chipset driver in the mix from Gigabyt (motherboard). Again use the AMD cleanup tool - found on drivers page.

Now I fly - no lag and no stuttering + also with SAM enabled (thought that was reason to problems before so had it disabled for months). 

Hope you will manage !


at what fps are u playing man? if its up to 144fps then u will not notice those stuttering issues as much as we do at 200fps 


@aditrex the stutter I get doesn’t always seem to correlate with a fps drop, I’ll fluctuate between like 200-160 but still see visible stutter/hitching on caldera. Fortnite is the only game rn where my stutter correlates to a actual fps drop. It’ll be fluctuate between 170 and like 10 lol.


never said bro becouse fps drops i have exact same problem regardless of fps but i noticed if i cap fps to 144fps those heavy stutter are way less noticable thats why i pointed out at 200fps stutters are so heavy it makes really unplayable for me 


For me it was different, when I capped my FPS to 144 in Fortnite, it caused more stuttering, when changing it to unlimited, it stuttered less.

Also, updating my bios fixed the stuttering for me even more.

Adept I

My 6900xt will crash on warezone now after most recent suggested update. I’ve tried default settings and also if I run the Game in multiplayer with rsr My mb  after reset will display vga light. Light goes away after a reset but have to reset rsr every time. It was nice getting around 250-300 fps in gunfight maps and around 200 in warezone but now it’s warezone it’s not playable cause I never know when it will crash. I’ve tried toggling the sam feature in bios. I’ve tried resetting the gpu. I only have this problem with call of duty and sometimes god of war would crash after about 2 hours of play. 


@FNronswanson Can you list your PC specs? Like CPU, Power supply and so on?


@Tricczyy Specs are red devil 6900xt; 5800 x watercooled with 240 aio; aorus pro ac b550 motherboard; 850 gold psu, and 2 16gb 3600 gskill ripjaw memory. Xmp enabled. Auto oc with 5800x I’ve tried default with this but it still has problems. Also, just tried to get back into ac odyssey and it’s also crashing. Thinking that maybe I’m having higher than before spikes in wattage with new drivers and thinking of upgrading to 1000 or 1200 platinum. What do you guys think?


Red Devil 6900 XT requires at least a 900w power supply so it is possible this is the reason for the crashes. Your PSU may be too weak and the spikes may go over 850w.


Will update in a few days to let everyone know if the new power supply does the trick…


it wont help.. dont waste any money on new power supply.. 

Journeyman III

I just registered to help you guys out!

I was having the same shuttering with 6900 XT and found the solution for these!

All you need to do is go to your BIOS and in my case it was an MSI Z390M Gaming Edge motherboard, then navigate to Settings/Security/Trusted Computing and switch from PTT to DTPM mode, or just completely disable the TPM, it is no problem to disable it once you have installed windows 11 or updated windows 10.

This TPM which does nothing is actually making all of these shutters and more specifically the PTT - the software version of the TPM.

I hope I have helped you guys out since I was struggling alot with this issue too.

I hope that AMD will release a driver version which is working with PTT also, but for now just move on to DTPM or completely turn it off!


@bl00dm0n3y89 glad that worked for you, that was mentioned early in the thread as a possible fix, for me and a few other people in this thread it didn’t change anything for them sadly.


I upgraded from a 5700XT to a 6800XT and also getting stuttering and poor performance altogether. 

Tried different drivers cant seem to find any that improves? Any suggestions?


AMD Software -- settings--video card --additionally--Tessilation mode  switch frome AMD optimized to Use application settings


So I got a temporary fix I guess guys… I thought before buying a power supply maybe try some tinkering… I used an older driver for Radeon software and I also under locked the power to -10% with that and an under volt I limit my fps to just 200 fps in game and it’s now butter smooth and no crashes also tested on ac odyssey and it ran perfectly. Hopefully it works for you guys. 

What Driver did you use? I've tried alot still same issue.


@kevymatts At work will update specific driver in 12 hrs

That's interesting.

What are your GPU hotspot temps?

Sounds like you're throttling if that's  the case

14900k • Z790 Apex Encore • 4090 • 2x24Gb-8000 • 1200 Corsair Shift • 420mm Arctic II Push-Pull • Noctua • Fractal Torrent •
Journeyman III

I set my renderworkercount to 12 and I turned off the streaming textures setting and it seemed to stop all of the stutters. I hope this helps.




I used the 22.3.1 released 3/9


@BrockFraley what cpu do you have?