Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

Video Stability Issues on X570 3900X Platform

I'm experiencing stability problems on my new build I did where both my old R290 and the new 5700 XT will result in errors "Display driver stopped responding and has recovered.". The only difference is that the 5700 XT will crash  more often with "video scheduler internal error" or sometimes VIDEO_TDR_FAILURE if PCI-E was on Gen4/Auto. Whereas the R290 will just flicker black much more and recover. Suffice to say neither card is stable on the new build.

I've also started testing my 5700 XT in my old build that is Intel based which is where my R290 comes from and it is stable on the old board without any flickers or BSODs. I can actually open any app so far and not get any errors.

My new build consists of:

  • X570 AORUS PRO WIFI - Running F6b BIOS (AGESA ABB) 
  • Sapphire Pulse 5700 XT - Adrenalin 19.9.2(latest)
  • Intel 660p 1TB M2 NVME
  • 3900X With X62 Kraken - So it hardly goes over 70 degrees celsius.
  • HX750W Corsair PSU
  • HyperX Predator Black 32GB hx432c16pb3k2/32 - Stock Speeds of 2400Mhz

I've managed to test the system in the following way without achieving success

  • Swapped PSUs - Not the PSU
  • Changed memory to a friends's memory - Not the memory. Memtest was fine anyway,
  • Installed Windows on a SATA SSD while removing the M2 drive completely - Not the drive
  • Reinstalled windows in many different configurations of drivers. Tried the all drivers from 19.7.5 to latest - All drivers crash.
  • Installed the latest AMD Chipset Drivers or installed the MB drivers. - Same results.
  • Set the Power Profiles to performance and disabled the PCI Power Saving mode - Set to Off.
  • Moved the GPU to the x8 lanes slot
  • Set the x16 slot to x8
  • Set my PCI-E to Gen3 or Gen 4 neither makes a difference. I only seem to see more VIDEO_TDR_FAILURE errors if it's not Gen 3.
  • Checked GPU Temps and GPUs are fine these errors are happening in idle.
  • Disabled all features like enhanced sync, free sync etc.

This seems to leave the Motherboard or the CPU that is faulty or it's some configuration setting or just bad drivers?? I'm really not sure anymore and it's really starting to eat way too much time to troubleshoot. The system is fine if I don't install the display drivers and nothing crashes but all hell starts after installing any GPU drivers.

Any ideas?

1 Solution
Adept I

Replaced motherboard and it seems like all problems have disappeared.

View solution in original post

6 Replies
Adept I

I'm having similar issues with a X570 Gigabyte Aorus Elite on BIOS F5b, Ryzen 3700X and a Sapphire Pulse 5700XT

Disabling XMP and setting PCI-E to gen3 helped with stability but not solved the issue

Tried different drivers version and other TS suggestions but no change


F6b version BIOS new released for the mobo.
Also, do not change display driver settings with Radeon Settings software.
Also, do not use Radeon Settings software. This software sometimes may affect GPU working properly.

Commands for killing Radeon Settings software: (Command Prompt should run as an administrator.)

taskkill /f /im RadeonSettings.exe
taskkill /f /im amdow.exe
taskkill /f /im AMDRSServ.exe

Do not use "Turn off the display" setting with Windows Power Options.
Do not use Windows FastBoot feature.
So some Windows settings affect the proper functioning of AMD GPUs.

So you're probably having driver-induced problems like you wrote. Produce solutions to reduce the likelihood of errors. 
If you haven't yet sent an email to AMD, follow the link above. Good luck.

Adept I

I'm facing similar issues as well. I have a ryzen 7 3800X, Aorus Elite WiFi mobo, Gigabyte RX 5700 XT Gaming OC. My games play for 3-5 minutes before black screening (usually quits to desktop with DXGI device hung error). I have all the latest drivers, BIOS, etc. Killed Radeon settings, disabled fast boot. Issues persist. My GPU works fine on a x399 platform.


I saw someone with a similar problem on this forum site. (S)he has reduced core clock speed by 100Mhz and core voltage by 50mV with WattMan, and the problem is solved. Maybe your problem is the same. Because OP is having a different driver-induced problem.


aah gotcha. Will try that out, thanks

Adept I

Replaced motherboard and it seems like all problems have disappeared.