Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Video output stops working

I play mainly Monster Hunter World on my pc, and about 2 months ago, after 5minutes on the game, the video output stops working, i use the Display port, but the problem is also true while using HDMI. With sound set to be on my headphones, it still works, the pc is still on, the screen as well, but the video signal has stopped working. I have a radeon RX 560 series and my CPU is an AMD Ryzen 5 2600 6 core. 

I have no clue why this is happening, i have yet to test an other screen to make shure the issue doesn't come from my monitor, but it probably comes from the video card. 

Note that this only ever happens when playing games as Monster Hunter World or Apex Legends, this never happens when doing graphic tasks or browsings. There is only one monitor involved. Does anyone else have this problem ?

Please help me !

2 Replies

Set your GPU fans to maximum and set the Power Slider to max as well. 
See if that helps.
Other than that, leave all GPU settings to normal. I.e. do not overclock it at all. 

Are you able to use the Power on/off button on the PC or do you have to press PC reset button to reboot the PC? 


I'll try that. I have already tried putting the fans to maximum, with no significant change other than my pc crashing a bit later than last time (i guess). I checked if the fans where functionning, gladly they were (it could have not been the case). What is this Power slider ? Are you talking about the acoustic limit ?


I do have my GPU settings set in a different way, i'll try turning them back to normal.


When the video stops functionning, i have to press the power button to forcefully turn it off (i hate it), but now that i check a bit more i'll use the reset button, it's probably safer. I'll edit if there is any significant change to my problem after changer the GPUY settings. 

Thanks for the advices! 


EDIT: the problem is still here, but it seems my pc was able to handle the game for longer, like 19minutes I believe, by only turning of the advanced GPU settings. But the problem is still here.