Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

VEGA 64 - not recognized fans not spinning!


Can you please give me some advice, I'm heaving trouble with new Sapphire RX VEGA 64 Cards.

I had two cards running before on my motherboard:

1. slot PCIe 16x - GTX760 (working)

2. slot PCIe 16x - RX470 (working)

Changed to 2x VEGA 64 cards:

1. slot PCIe 16x - VEGA 64 (working)

2. slot PCIe 16x - VEGA 64 (not detected fans not spinning - overheating)

Tested and plugged old cards back as it was and 2. slot does not work anymore:

1. slot PCIe 16x - GTX760 (working)

2. slot PCIe 16x - RX470 (not detected fans not spinning)

Tested only one card on 2.slot:

1. slot PCIe 16x - Removed no card

2. slot PCIe 16x - VEGA 64 (1 long beep and 3 short beeps)

Tested only one card on 3.slot:

1. slot PCIe 16x - Removed no card

2. slot PCIe 16x - Removed no card

3. slot PCIe 16x - VEGA 64 (1 long beep and 3 short beeps)


1. PCIe 16x slots are not the problem (not broken or dusty)

2. All cards are working but only in 1. PCIe 16x slot

So far:

1. Uninstalled drivers with DDU about 4 times

2. Installed and tested with different AMD drivers 17.xx - 18.2.1

3. Updated Motherboard BIOS

Still does not work! Please help!

Motherboard: ASUS P9X79


36 Replies

Sorry a little confused still. So are you saying that all cards work in slot 1 by themselves, but don't work in slot 2 or 3 by themselves?

If that is the case maybe it is a motherboard issue? That or something really messed up with chipset driver. You could try and boot from a ubuntu usb drive or dvd with one card and see if that works. If so you rule out hardware and at least know it is something in Windows or the drivers. Have you also run this issue by Asus support?


Thanks for advice! Will try to install Ubuntu on my second SSD to check that out.

Not yet, but will contact Asus as soon as possible also.

Yes all card are only recognized and working on 1. PCIe.

But before I first time plugged in Vega 64 cards 2. PCIe was working for my RX470 with no problem.

I tried to install and repair Intel chipset driver together with asus motherboard bios update ,but it didn't helped also.

Maybe it is problem of PSU? hmm.. but I don't think so because my old cards received power fine on 2. slot, before Vega 64 upgrade.


To clear out I want run two rx Vega 64 cards on motherboard one on 1. slot and second on 2. slot.

Friend gave me 2 PCIe external risers and I tested all PCIe slots available, cards does not work on PCIe 1x and 8x slots also.

So yes only slot 1. PCIe 16x is working. 

So sounds like if the ubuntu is working on slot 2 and or 3 then it's software, if it's not recognized on there either, hardware issue. Definitely get Asus involved. Maybe it's under a warranty still?


If you have that second drive available you could always do a fresh install of Windows to it too and see what you get.


Fresh windows install also does not help.

0. Installed fresh Windows 10 on my second SSD.

1. In 1. slot plugged one VEGA card first and Installed AMD driver 18.2.1 (After did shutdown)

2. In 2. slot plugged second VEGA card (same 2. slot issue not recognized fans not spinning)

3. Uninstalled drivers with DDU

4. Plugged both cards in 1. and 2. slot and installed drivers 18.2.1 again (same 2. slot issue not recognized fans not spinning)

5. Tested only 2. PCIe 16x slot with only one card and same (1 long and 3 short beeps)

Will try Ubuntu a bit later also

I'm still don't understand, can someone explain how Motherboard can be damaged?

2. PCIe slot worked fine before I took out old cards and plugged in VEGA 64.

I don't think that ASUS Motherboard guarantee will work because I have it a bit more than 3. years now.

At last I want to know if it is broken. Should I have to buy new one?


Sure sounds like bad hardware than. I have had many motherboards go bad in the past with no real physical signs. There is actually a lot that can go bad without ever seeing anything. As far as possible damage goes. Look at your slots with a magnifier and see if anything down in the slot maybe got damaged inserting a card, I doubt it since you have 2 not working but worth making sure.

I think ASUS would be best to have this conversation with. Maybe you could link them to this thread without having to re-type it all. They may be able to direct you to a good resource, like maybe a downloadable utility they have to test the board?

Good Luck!

Thank you for reply!

It recently checked out out Drivertoolkit and Driver Booster.

Is it possible that my Intel chipset drivers are just too old?

It looks like I have to pay if i want to make driver update using these softwares, but I think I already installed newest Intel chipset drivers on my own from official ASUS and Intel website, are these Driver Tool softs scam?

Asus support are a bit slow did not recived any reply to my ticket yet...

UPDATE: I installed newest 2017 Intel drivers with Driver Booster but it did not fixed the problem.




Hey not to try to scare you or further complicate things but I have had near zero luck with any of these driver programs. In the past at a minimum they install PUPs and at worst flat out malware. Be careful! You don't need these programs just go to company website for each device and get the latest driver yourself. I highly suggest uninstalling that utility and doing a scan from safe mode with malwarebytes, is a great site for downloading reputable software and getting malware advice. Can you tell I hate these driver update utilities. I have however been using a very nice utility for patching apps, keeping them up to date.  Download the free patch app. Great utility, fantastic time saver!

It's unlikely you have a driver issue unless a windows update screwed a driver up. If it was working and now isn't working and no drivers changed, unlikely a newer driver will fix this. It sure sounds like a hardware issue. I am sure hoping Asus can help you to verify that. It's never fun to have to start throwing dollars at problems without knowing for sure.

Thanks for help! I really appreciate it.

But I'm totally shocked!! My old motherboard p9x79 is more expensive second-hand (used) about $500 than new ASUS z370, z270 DDR4 gaming Boards about $200.

And I had 32gb DDR3 witch is useless now. To buy 32 DDR4 it is about $400. Basically this mean I have to change my all PC.

Feel sad don't have money for it.


You could get a different MB but still use old ram and cpu. Saw some reasonable prices.

Still no reply from asus

But I found something interesting on user manual.

It looks like slot 2. and 3. does not support single GPU VGA. That is why I'm having beeps when testing only 2. and 3. slot I'm I right?

2. slot only when in 1. slot is plugged GPU?

Can it be 850w power supply issue? but it still does not explain why two of my old card setup is not working anymore.



I have never run a vega myself. I know the power supply requirement are pretty high. I know I have seen as high as 750 for 1 watercooled card. So is all this you have been going through a symptom of power. Sure it's absolutely possible, in fact when all else is eliminated, likely. You just found your own answer in your manual, on the slots. I know someone already had said that you didn't have enough power for 2, I certainly thought it could be an issue under load myself, but thought it should still post as the power requirements of 2d would be much less.

I have to ask though, since we have been talking a while now. Why do you need 2 running anyway? Gaming or some other work? I tried SLI long ago then crossfire on the hd4870s and was way more of a pain than it was worth. I vowed to never do that again! If that were my card with the price those things are going for "assuming you didn't pay that high price" I'd be tempted to sell one!

Anyway back to the power issue. Do you have a local store you could buy a power supply from to try? Maybe return if that doesn't fix it. Micro Center maybe? If not maybe even a local pc repair shop might be willing to try one. The tough thing is that 1200 watt power supplies are not a standard stock item at many places. One things for sure more power only adds stability. I sounds like from what you had in the past and now that the future would indicate you would make good use of a new power supply regardless. Let me know what you figure out. I am about as interested in this one as you are!

Your power supply is insufficient for cards which can pull over 350w each, so be glad they're not working. If it's not detected in slot 2, then it's a problem with your motherboard.


Maybe VEGA draw too much power and broke the Motherboard??

At the beginning first I plugged only one card used it only for about 15 minutes benchmark stress test and after plugged second VEGA card in 2. slot and it was not working anymore.


I passed this along to Amd Matt here is what he had to say,



Sounds like a Motherboard compatibility issue with a new GPU such as Vega. Not much we can do, customer should report it to Asus to see if they can help. However, X79 is a very old chipset so they are unlikely to release an updated bios.

Thanks for your effort! I researched this idea.

And I think OLD Motherboard is not the problem.

In some forums I found that people even had success to run VEGA 64 on more older sabretooth x58.

On older MB people had some problems with non UEFI bios and they flashed beta UEFI bios to solve the issue. Some didn't  and had success with windows 7.

(I don't know what actually does UEFI means)

p9x79 is rated 10 out of 10 compatible for RX VEGA series. and I think it have UEFI bios as standart, because I have it as option in my bios to read PCIE as Legacy or UEFI. Also PCIE slot version is 3.0 same as new Motherboards. Tweaked and tested a lot things in my bios but no success so far.

Basically I choose RX VEGA for my workstation 3D rendering in MAYA and some gaming.

For the same price I had an option between new VEGA FRONTIER LC or a bit cheaper two VEGA 64 for good price from my friend purchased at 22. December and used for only one month. So I decided to better take two VEGA 64 because I can also leave them to mine at night when electricity in our country is cheaper and get at last partial money back. But no luck so far.

I'm really confused now, don't know if I have to buy new x79 MB or completely new PC.

There is still some options - will try Ubuntu and Windows 7 and better PSU.

Will let you know how it goes.

Asus support still did not made any reply to my ticket....

edit: I forgot to mention that I had win 8.1 before with my two old cards working, 2 weeks ago updated to win 10 still old cards was in running.

All I did was changed to one Vega 64 first and did the stress test for 15 minutes as I told. And now slot 2. is not working for old cards also.


But were they running 2  Vega cards on older MB? Just because one works doesn't mean 2 will.

UEFI is just what replace the old BIOS method of controlling the hardware. I took this description from Wikipedia for  you.

The Unified Extensible Firmware Interface is a specification that defines a software interface between an operating system and platform firmware. UEFI replaces the Basic Input/Output System firmware interface originally present in all IBM PC-compatible personal computers, with most UEFI firmware implementations providing legacy support for BIOS services.

I hope you get it figured out without spending more money if you can. I get the need to save the cash!


Check you PSU is rated to run the vega as you need alot of juice to run the vegas. To me sounds lack of power to not spin up the new card its not the motherboard. I had issues with 10 creators update for a bit till now sorted running stable. My advise is test your PSU As you want something that's way over recommended wattage for a buffer for any OC. A leason learnt ruuning AMD cards need a decent PSU & make sure your wattage is way over your recommended wattage.

Are these crosair PCIE (8pin to 2x 6+2pin) cables good? For one VEGA 64 card working fine so far.



Sorry I know you didn't reply this to me. Does the power supply not have the dedicated SLI/VIDEO 6+2. Usually they will have at least one pair, on 600 watt ones or better often 2 sets. If it's modular they may still be in the box. But using the PCI-E cable is fine as long as it is not sharing with anything else. There shouldn't be an issue with the cable itself.

Yes I have 3 pairs of the cables included with modular PSU same as in picture.


Done use driver tools like the tool you were using as it loads up alot of junk. Your better off to do a fresh 10 Boot on ssd using the media creation tool & update your drivers threw device manager as you will get the correct & best drivers run you system till its updated, power down try again tho i say could be PSU not giving you card enough juice to spin up.


I had a simular issue running my H61 motherboard build with my i5 2400 ran stable for the first month the creators update screwd my hard drive. Got it running on ssd for about 3 days stable on latest driver then after shut down wouldn't boot past post screen tho i had alot tell me it was hardware. Funny enough tho i had a power run before it went down proving my point it wasn't hardware. I sent a heap of picks to my old IT tech to show the results before it went down & run a hard ware checking tool which showed my build was running prety good for its age. After another week being down i threw a bigger PSU with a down graded driver sorted my issue atm with a stable run time of 4 days with a few shutdowns fank god on that. An idea which i did was i ended up running on cpu videocard for a few days with !0 creators update running with cc cleaner for registry cleaning & dumping old windows & driver installs off my ssd. I ran with my videocard still in powered up till i i thought why not give it a shot & found that 10 was throttling the power down from the PSU so my videocard wouldn't fire up. 600w with  rx560 OC 4G atm is running smooth, considering i was told was a faulty videocard faulty hardware. Advise is even buy a PSU as you will need 1 if you are forced to build a new build as PSU dont last & loose effecientcy as they get older. Switch ram PSU is the easiest way to eliminate a few issues on the spot i had 2 builds go down 1 on a nvidia based build & my build. Any help i can give i will as new to AMD tho a few things i have found or learnt has helped so far. & i havnt done a bios update either that shouldn't matter some builds it does but not always the case tho with you build i would advise to do a bios update but not the lastest go for the 1 before the lastest


how many watts is the psu & how old is it should be but a good idea is check on the side of the psu for recommended power draw volts & amps that's as important from what i have learnt with AMD cards


still advise to go bigger to a 750w psu + better chance as it degrades over time to get a constant 600w its how i buy my psu's as the older they get they lose efficientcy & degrade over time as well learnt & found with AMD cards they need a decent psu to fire up properly to run stable. I am on a Antec psu atm 600w without problems should have been using it when i first booted my build.

Oh no he has a 850 and that is still underrated for 2 vegas. He needs more like 1200.


yeah 1200w be more than ample. Its a lesson learnt running AMD cards atm run way over the wattage. He needs to find a good brand PSU & try again. It should run happy thinkning his issues is hes running out of power to run the vega properly.


Before going crazy on super expensive PS. You still want to make sure that is the issue. If you have another power supply or can get one, a smaller one just to test with. You could use it to just power the second card to make sure it is a power issue.

yes you are right. at first better to borrow and try second PSU for test before buying 1000-1200W ,don't have lots of money at the moment.

I spent all my savings on VEGAS.

edit: true looks like I need at last 1200W and it is not cheap. also it is very possible that my old Motherboard actually is not compatible for 2 rx vegas...


test the card in a m8s pc with a simular build to elimate the problems to. I ended up doing that with my stepsons build to eliminate hardware. tho i build a few PCs from time to time i was lucky i was rebuilding my stepsons that went down so had a 2nd clean build to work with. Mine had been down for a week or so before i found my issue which i found was driver related. I found in the MS 10 creators update the power settings have been trottled back so i ended up opening up my power settings to full power made a huge diffrence got my rx 560 OC 4G idling properly. Even on older drivers stable atm tho i am waiting a week or 2 before i re update my drivers so i know i have eleimated my issues. Tho i am going to solve my problem more buy buying a better Bigger & better PSU as running an Antec 600w PSU that's 18months old. PSU's dont last like they use to & degrade over time the older they get i updgrade PSU in a cycle of 2-3 years now as a lot are made in china with less superior products & they are cheap enough to replace in a 2-3 year cycle gives a good buff as well for an older build especially with the hit of miss updates around to atm. Just a lesson learnt & i run ssds now of good quality & only run the OS on to eliminate bugged driver or OS updates which has been a current issue i have found lately. I found hit or miss with creators update. I have run & hardware scan over mine last night i live in NZ & for my age of my build & my build everything is registering really well or better than systems for it age. But i am monitoring it for a while to maek sure i got rid tho pesky gremlins around atm. Tho i have an identical build just next gen processor on ssd with fresh creators update ready to go to make sure, as i found driver wise between Nvidia & AMD are both iffy coz of the creators update atm. Tho i dont bother with power saving modes as i pay my power bill & on unlimited internet & buy bigger than needed psu's to elimante downtime & to allow for deteriation of age of power supplys i rather go over the watts saves rebuilding in 6months or running into issues just i keep an eye on age of my psu's & if i notice that they are not running as good run a hardware check & switch out before they die. I had a simular PSu to mines that's running another Antec die in 18months bought at the same time, its why i say buy a good brand & why i rather shell out on a new psu earlier than i got to can alkways sell the older psu 2nd hand to some1 building a cheap rig.

Windows 10 treats all computers like they are laptops. It nerfs the power. i always have recommended running as High Performance. I have however found that this setting is not equivalent under Win 10 to what it was under Win 7. I have found a free utility called park control free which does a great job of giving you the most powerful settings. ParkControl Free – Tweak CPU Core Parking w/o Reboots

Thanks for info! Yes my crossair 850W PSU is very old about 4 years now.

I'm checking out prices for good new 1200W PSU right now looks like I will need it anyway!


Here is my current PSU details. it is rated as gold ,but used about 6-12h daily (not 24/7 for mining) 4 years old now.

How much power can it loose with time?



hmm its 50/50 you got anything else to test the psu on most motherboards should be vega capible end of the day its videocard. Test you vega with psu in a m8s build might be best way to eliminate a issue or 2

Adept II

1. Flashed MB bios to more stable version from 4801 beta to 4701 as recommended.

2. Did bios reset and cleaned CSMO manually on MB switch and Disabled power saving in bios.

3. Tried to fully update fresh installed Windows 10 x64 on my SSD

PROBLEM: Windows 10 update does not install x79 Intel chipset drivers

ERROR: Failed to install on ‎10.‎02.‎2018. - 0x80240034 - (it means OS does not read downloaded files. Used suggested Microsoft tool to fix this ,but it does not install drivers)

Device Manager: also does not work it show I already have newest drivers, but drivers are clearly old.

ERROR: When installing drivers from official ASUS website with P9X79 Intel chipset setup.


Only way I was able to get newest Intel chipset drivers was with DRIVER BOOSTER Software. (free version)


4. Changed balanced mode in ParkControl software to power.

5. Plugged VEGA 64 card in second PCIE 16x slot also plugged HDMI cable in both cards for each monitor

6. Booted Fresh Updated Windows 10

7. Installed newest AMD  drivers

8. Even swapped 1. GPU to 2. slot and 2. GPU to 1. slot.



Have you re tried your older videocards again to eleiminate its your motherboard. The best way i do to elimininate an issue i use is to fire up without a card. Run off motherboard integrated cpu for a day or 2 just so windows 10 stabilises. I found 10 runs prety unstable after a fresh install on the creators update so i try run without videocard for a day or 2 before i try with videocards. I had this issue with mine so i left it out for a day or 2, same as my stepsons Ivy bridge i5 build i just redone just got his running stable for 1 day + before i refired up his videocard. Took about 24hrs b4 running properly i found between bother builds to eventually stablise with out the OS hang which the creators update has a tendancy to do. I prety much built 2 H61 builds mine is a i5 2400 on 8gig ram with 600w psu & Sapphire pulse rx560 OC 4G & was told my hardware was an issue that i had a dud card. Funny thing was its running silky smooth & stable nearly 5 days on older AMD drivers from early Dec with 10Pro upto date, & was having issues trying post past bios to first windows login. I dont use those driver tools for drivers & software as half the time you end up loading up the wrong drivers. I use the device manger & when i check my drivers use the 2nd option where drivers are stored to your system as windows installs a few sets of drivers & doesn't always install the proper chipset drivers why i manually check in device manager as i have google or edge or another computer or phone in the background with the codes so i know which drivers are meant to be installed. I had this problem with my build & my 2nd ivy bridge i5 i re fired up took me about an hr or 2 but both builds are running stable now & thats on a 660gtx 2G & Nvidia drivers are more ugly than AMD drivers atm. The only way i can think may work is try the card in some1 elses build to make sure its not the card or any of your hardware or do a fresh boot with card powered in place & see if it posts if it does try boot to safe mode might be an idea & run DDU. As if the card is working should still post without drivers installed to basic video settings mine did which how i eleimanted was hardware. Any videocard installed with other drivers on a fresh build getting enough power still should post. Otherwise its hardware or may be card or Motherboard fault. I would suggest tho test your card in another build & retest any cards you got lying round in your again. Even drop back a bios revision might be throwing issues. Tho if your running uefi it SHOULD automatically reconise any cards added. Depends where in the world you are to i am from NZ so avaliblity to good pc parts it not as good tho for the first time in many years we have been getting some decnt stuff come in which you pay big $ for.