cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

scandr
Adept I

Stuttering, fps drop and freesync not working

Hello excuse my English but I am having many problems with my PC. In Games like CoD MW, Battlefront 2, League of legends, Killing Floor 2
they are presenting many jerks and fps drop when playing either online or single player also shows loss of fluidity especially in League of legends,
I have tried activating FreeSync but apparently this does not work since problems are still noticed or even in games like CoD MW they get worse.
I am using driver 20.4.2
My PC: -TUF B450M Gaming plus motherboard
-Amd ryzen 5 2600 3.8 ghz
-16GB ram 3200mhz
-Rx 5700 xt sapphire pulse
-750W bronze Coolermaster power supply
-1Tb m.2 XPG
-MSI monitor optix g27c2 144 hz connected with displayport 1.4
I really need help I just want to play smoothly.
0 Likes
10 Replies
voidburn
Journeyman III

Following this suggestion (https://www.reddit.com/r/Amd/comments/ev9wml/5700xt_mouse_cursor_hardware_acceleration_is_one/) fixed all the stutter I had in opengl and dx9/10/11 applications.

You might try it and report your experience.

Ok thank you very much for the answer, check the link and I'll see what happens

0 Likes

Sorry I misspelled the answer, I wanted to say that I will look at the link and see if it works for me

0 Likes
Anonymous33
Adept I

Hi! What kind of framerate drops are you experiencing? How much exactly FPS are you getting in average? Also, a bit of advise: go to Radeon Settings, on a Games tab, click tab called "Generic graphics" (I'm not sure how it's called in english version, it should be here,2020-05-01_LI.jpg

and make sure everything is disabled, like that.2020-05-01 (2)_LI.jpg

Theese are fine features, but sometimes they might cause a stuttering in some games. And see if it's any better.

Thanks for the answer, I have everything disabled and in CoD MW and Battlefront 2 games wich are the most demanding i have installed, they average between 120-110 fps with the high-ultra graphic settings.

The fps drops i suffer are between 20 to 30 in CoD Warzone and sometimes in games like league of legends i have notices that lowering 1 or 3 fps (blocked at 144) loses a lot of fluidity as if the game were running at 40 fps or less.

It should be noted that before i had an RTX 2060 and had the same fluid problem. 

0 Likes

Have you tried a diagnostic startup? If you had the same issue before with a different GPU, perhaps the problem is related to your OS. Might also be worth trying a clean installation of Windows Build 1909, installing nothing but Windows updates, AMD Chipset and display drivers and some games and then see if that helps. 

I already did a clean install of windows 1909 but the problem still persists.

I have everything updated Bios, chipset, gpu, audio drivers, windows. I am thinking of changing motherboard or processor just for testing.

0 Likes
morelock
Adept II

A few things that helped me out (if you've tried the above already, good suggestions)
- If you are monitoring with anything... stop and close it. (Afterburner, GPU-z, etc) Also, it seemed like just closing the Radeon Software window helped.

- If you've tuned your card at all, try going back to one of the "stock" profiles and see if that helps. Seems like a custom fan curve still caused issues for me in the newest drivers... even a flat "custom" profile. (reset in the performance tab, then use automatic)

- If you are gaming with a wireless controller, try plugging it in

- If you are using pigtail connector, try using two separate cables to the psu.

- DDU in safe mode, under the options tab remove the entire AMD folder (will probably remove your chipset drivers as well) and fresh install (no internet when you boot back up) 

I was having terrible issues with RE2/3, Jedi Fallen Order, RotTR and others. This (plus the stuff from the posts above) helped smooth it out. 


Seems like it is sort of a roll of the dice what (might) work for these cards currently.

I would only have to try to leave the fan curve at default, I was also investigating and a possible solution was that in the Bios you had to configure an option of the Pci express that by default was in car and had to be changed to Gen 3 or something like that but in me Bios does not seem that option. Has anyone read about it?

0 Likes

I do not think your motherboard has pcie4.0 so you don't have to worry about that.

perhaps give this a try
HOW TO FIX AMD RADEON SOFTWARE ADRENALIN 2020 FPS DROP, BLACK SCREEN, TEARING, LAG, STUTTER ? - YouT...  (starting at roughly 3:30)