Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Smart Access Memory Black Screen


I have recently build a new PC with Amd Ryzen 5600x and Radeon 6800xt. I managed to install Windows, install the newest BIOS and after trying to allow Smart Access Memory from BIOS according to the official AMD website, I restarted and now the VGA Led stays white on the motherboard and I don't have any signal in my monitors. I tried moving the GPU slot, changing the monitor, the cables, reinstalling the BIOS, trying with HDMI and Display Port and no success. My motherboard is Asus ROG Strix b550-e gaming and I managed to replicated the problem by just trying to enable Smart Access Memory. The same issue occurred with the black screen and no signal out of my graphics card. The solution was not really a solution. I had to refresh the BIOS settings by updating it with BIOS Flashback, but, of course, I do not have SMA active and I woul really like to benefit from this feature.

I have to mention that I have already sent an email to the motherboard manufacturer and is still to be responded.

Is there any solution for this?

27 Replies
Journeyman III

I'm having the exact same issue, have you gotten any answers yet?

I'm running a 5900, 6800xt & rpg strix b550-f

This is a new feature that requires a lot of coordination between the components. Not surprising it is having some problems. 

I would report the issue to your motherboard makers support department.

In Radeon Settings there is a Bug Report tool too you can submit the issue or

You can contact AMD support here:

Good Luck!


I have the same problem.I've enabled above 4g decoding and Resizable BAR and now when i start the PC, the screen goes black or in sleep mode.I can't acces Windows nor BIOS.Please help, what can I do...


Reinstall windows 10 before it-disable csm support in bios.Good luck


no need to reinstall you can just use mbr2gpt.exe to convert your install. Although probably easier to reinstall


I am experiencing the same issue with a 5800X & XFX 6800XT on an ASUS TUFGAMING B550-Plus. The BIOS mode is UEFI and the OS drive is GPT. I am running build 19042 of Windows 10. Given the BIOS error was a GPU related error (white GPU LED on the indicator group and 1 long tone followed by 3 short) I am going to go down the XFX path and check if there is a bios update required on that front.


As an FYI I have raised support tickets with AMD, ASUS and XFX. I will let you know if I get any useful information.


@delsplurge was your card working before you enabled resizable bar?

Have you tried reseting your CMOS?


The card was working fine before the SMA changes and everything is working fine now after resetting the BIOS. To ASUS' credit they actually made that a reasonably easy process.

I raised the tickets to get an answer as to why one of AMD's headline features is not working. I bought all the requisite parts!

@delsplurge when you boot Windows do you get a blue screen and a white Windows symbol with a bunch of white spinning dots in a circle below it, or do you get a black screen with an ASUS TUF symbol and a bunch of white spinning dots in a circle below it?

Also is CSM Compatibility enabled or disabled in your BIOS?


@Cmdr-ZiN When I toggled on the two SAM settings it was just a blank screen and the bios gpu error tones, nothing more. Re CSM, it is disabled. 


@delsplurge What does your Windows boot screen look like, is it a black TUF screen or a blue Windows screen as mentioned above?

If it's the blue screen with the white Windows symbol you don't have your UEFI OS setup right.


@Cmdr-ZiN it is the logo that was used by the retailer to replace the Asus one with the Asus MyLogo2 tool, not a Windows one.


Hmm I guess that means it's more likely setup right than not, but it should be working for you then.

New built machines from retailers shouldn't really encounter a black screen, it's usually from old OS ports or someone in the habbit of turning on legacy support.

All I can think of is if you had more than one OS drive or you drive partitions are messed up.

Also have you tried it again since reseting your CMOS? Because if CSM was enabled before you would of gotten a black screen, resetting CMOS would disable CSM. Worst that will happen is it won't work and you'll need to reset CMOS again.

If you PC was built by a retailer I'd ask them why it's not working because it should be.


@Cmdr-ZiN I built the OS clean, I didn’t get it setup by the retailer. The partitions look right but I’ll have a look again in diskpart and make sure there isn’t something rogue in there. I am going to give SAM another whirl today in case CSM was enabled. I have the tickets still open with ASUS & AMD (XFX just said speak to the other two) and I’ll contact the retailer once those tickets are closed. 

So stopping short of completely rebuilding the system I thought I would give it one more try. I reset the bios, removed all the drives, it started up and complained about no boot volume, but I knew that would happen.

I added the M.2 OS drive and I started it again. I jumped into the UEFI and did all the vcpu. multithreading, OC settings, and finally turned on SAM. I hit F10 and waited....

Fixed! Started and loaded into windows and I have the "Large Memory Range" resource in the device manager entry for the display adapter. Windows needed to reinstall the PCI bus when I rebooted and it complained a bit because of how I have my data carved up across my M.2's and SSD but it is all operating as expected. Not sure it truly pushes the needle performance wise, but it is nice to be able to turn on the feature.

Thanks @Cmdr-ZiN & good luck everyone. Hope at least some of my saga is informative.

@delsplurge I'm glad you got it sorted


Same problem here... Did you find a fix?


@AgentF yes we sorted it, have a read of the thread, let us know if you get stuck.


In addition to these solutions. I kept getting Black screen on my Msi motherboard. While stubbornly staying on the boot screen. I have solved this problem by turning off the Memory Fast boot feature.

Journeyman III

Me too, same problem with a RX6900XT, Ryzen 9 5900x and a Aorus x570 Pro mainboard


Nvme, ssd, or hdd, whatever media you boot from must be gpt format to boot in uefi mode, it won’t detect the gpu on post with resizable bar enabled unless the boot media is uefi.

I had the same issue with my system last month, 5600x msi x570 board and rx6800 gpu 

I used the Samsung migration tool to move the OS from a legacy boot ssd to a uefi boot nvme.2 drive and it fixed the issue, note you can only use the Samsung tool if the destination drive is Samsung 


I'm also having the same issue.

I have ASUS B550 plus WiFi BIOS v1216 not the latest.
I have a 5800X and a XFX Radeon RX 6900 XT Speedster Merc 319, stock bios.

I set Above 4G Decoding” and “Re-Size BAR Support” to enabled and I got black screens, both display port and HDMI on multiple monitors.

Windows booted, I could tell because my AIDA 64 software running on my keyboard.
Everything was fine except no GFX card detected.

Very similar to how it's crashed before during RDR2 when set to non Vulkan API, it has crash a handful of times and rebooted since I got it.
Upon reboot I got the same results as above, however I just shutdown windows with the power button and turned back on and it was working again.

With enabling “Re-Size BAR Support” I had to pull my entire PC apart to get to the CLRTC BIOS reset pins under the massive GFX card.

This is not a smooth experience at all and I don't know who's at fault AMD, ASUS or XFX. I'm not sure where to start next, I think I'll update my BIOS but I'm not looking forward to this happening again.

If I find a solution I'll let you know.

Edit: I didn't notice the above comment about the UEFI boot drive. I Also don't have UEFI boot, I'm using a legacy boot I've ported over multiple times, it should be GPT. It's a Force MP600 NVME.

I can't believe this is related to UEFI I can't think of a reason why this would be, but I'll definitely try it.


What FPS boost do you get though...

It is all a joke.


Yeah switching to UEFI Boot loader instead of legacy CSM fixed the issue, crazy this wasn't mentioned as a requirement.

I used MBR2GPT.exe after having to clean up my BOOT folder of invalid entries. I was able to convert my OS drive without any data loss.

Journeyman III

I had to remove my motherboard battery to reset the bios because after following the official instructions from AMD to enable this smart access memory both my monitors went black and I couldn't even access the bios anymore.

Yeah same, I didn't have to remove the battery but I did have to remove my massive RX 6900 XT to get to the 2 pins under the card. I have a small form factor build it's so very difficult to remove that card.

There really needs to be a caution for people stuck in the past

I since bought a reset switch for my BIOS if I ever have to do it again it will be the last time I have to remove the card. You can use a standard case reset switch but be careful it's not accidently pressed.