Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Sapphire RX 570 Pulse 8gb original bios?


I recently purchased the Sapphire RX570 not realizing the card was used in mining with modded vbios. I am now relentlessly looking for the original factory bios this card came with to flash it. Does anyone happen to have a copy? I don't know what memory vendor was used for this card if that's critical info? Thanks in advance.....

Win10 64bit

Asus x99

Intel i7 5930k

25 Replies

You could search through techpowerup vbios database or contact Sapphire tech support and get the Vbios based on your specific model/sku.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

Thank you, I appreciate the suggestions. I had already tried Techpowerup but the vbios they had apparently was not compatible with my card as when I tried to flash it it gave me some kind of "id mismatch" error and did not program. I tried reaching Sapphire using their online contact method but there seems to be something wrong with their site as it keeps showing a 404 error whenever I click to create a support ticket. Finding original vbios is a lot more challenging than I would have thought......


Run GPU-Z. It is possible you have a fake Sapphire GPU Card if you got that error.

Get the Device ID number and compare it at this website. It should show the RX570 if it shows something else than you have a fake GPU card.

PCI Lookup: PCI Lookup 

Here is my GPU-Z on my GPU Card:

This is what shows when I input above Device ID at PCI Lookup:


As mentioned in previous comment. Here is the RX-570 Specs from TechPowerUP website: AMD Radeon RX 570 Specs | TechPowerUp GPU Database 

Download GPU-Z and compare it to the Specs from above link. It should match.

Here is where you can download Sapphire RX570 vBIOS from TechPowerUp: VGA Bios Collection | TechPowerUp 

Compare the vBIOS from GPU-Z and see if it matches any of the five vBIOSes above.

I would recommend getting the vBIOS from Sapphire Support first. If you can't then you can download the vBIOS from TechPowerUp website above.


Thanks for your response. I downloaded and scanned with GPU-Z showing the current vbios on the card as being the same as what's on TechPowerUp. I noticed all of the listed Sapphire cards have the same bios version. Are they really compatible with each other?


Seems like it is. But I would still recommend to download the vBIOS for the Sapphire RX570 - 8 Gbyte to be on the safe side.

Does GPU-Z Device ID the same as the one shown on PCI LOOKUP for the RX570?




Sorry for not having the greatest images but I hope this is useful......


Yes, very helpful.

EDIT: Needed to change some wrong information in this comment.

Your GPU Card Device ID is legitimate:

If you believe your GPU card vBIOS was modified for mining. Then download the vBIOS from previous link for the 8 gbyte vBIOS and flash you GPU card again. The Website also has the ATI Flash tool you can download.

BUT, if your GPU card is still under Warranty, I would first asked them what you should do in getting your original vBIOS installed. From previous Users with Sapphire Warranty, you need to go to the Retailer where you purchased the GPU Card and have them take a look at it and see if they will flash the original vBIOS if they sold you the GPU card with a mining vBIOS and not the original vBIOS.

Okay, I compared your GPU-Z specs:

If you noticed under GPU Clock it is showing "0" and Memory "0". In my GPU-Z both are showing the correct Specs for GPU Clock and Memory.

Here seems to be the correct vBIOS for your GPU card. With the correct DEVICE ID: VGA Bios Collection: Sapphire RX 570 8 GB | TechPowerUp 

This matches the best with your GPU-Z Spec.


The only other reason could be that GPU-Z is reading the GPU card incorrectly. But It seems that it is reading correctly .

Did you post the correct GPU card Specs? Are you sure it is a 8 gbyte GPU card and not a 4 gbyte GPU Card?


It was sold to me as the 8gb version. It is definitely a desktop card.Thank you for being so helpful and thorough.... I really appreciate your efforts! I will take a photo of the card model/sn on the actual card itself.


I gave you the wrong information in the previous comment. I corrected it.

Take that Model number and especially the S/N and have Sapphire confirm it to see what GPU Card they say it is supposed to be.




Okay the SKU# does come out to a Sapphire RX570 Pulse 8 gbyte GPU Card: (googled it).

Well, it seems like your card is legitimate GPU card. I don't know why it is shows ELLESMERE and not POLARIS 20 for GPU Processor. Even in the above link it shows having a Polaris 20 GPU Processor unless the entire GPU card is labeled as ELLESMERE with a POLARIS 20 GPU Processor???.

I corrected my previous comment again a second time. I saw a vBIOS that seems to correspond to your GPU Card with the correct DEVICE ID according to GPU-Z.

But I would still contact Sapphire Support and post your S/N to be absolutely sure you have a legitimate GPU Card plus ask them why the vBIOS has that error unless you had the wrong vBIOS.

Try the vBIOS that I posted in my previous comment and see if that installs and works.

Sorry to get you unnecessarily upset saying your had a fake card. But doing more checking found out your card is legitimate.


I suspect that the card I received may have had the cover swapped out. It may very well be a 4gb version masquerading as an 8.


Ah, I didn't think of that. Excellent point. The cover would have the previous SKU# and S/N.

Okay check the actual PCB (Printed Circuit Board) and see if you can spot a S/N on it or some other ID number. They can't change those.

BUT GPU-Z has the correct DEVICE ID for that type of GPU Card. But then again, that Device ID could refer to either a 4 gbyte or 8 gbyte GPU Card.

Was this card purchased new or used?

If new, it still should be under Warranty. IF you know it is a miner card with a modified vBIOS and the Retailer didn't mention that, I would try to RMA it and get a normal GPU card where the vBIOS wasn't modified.

Where did you purchase this card from?


I'll pull it out and pop the cover off later tonight and post up the pics. Hopefully there will be something underneath that's an obvious contrast between the two models without having to remove the heatsinks.....


Ah, I see, Look if the GPU card works correctly and without any noticeable problems. Just leave it as it is. It would be nice to verify the actual amount of RAM your card has. But according to Sapphire link for your GPU card, GPU-Z seems to correlate the same specs except for the amount of RAM the GPU card has.

Most likely the Shroud or cover is the original one with the correct S/N and SKU# for your GPU card. That particular GPU card may be an older previous version of the one in the Sapphire Link. Which may explain why your GPU card may not look like the one shown at

I would highly recommend to open a Sapphire Support ticket and have them verify the SKU# with the S/N on the Shroud's cover. They can tell your exactly what type of GPU card your have.

Don't remove the cover.

See if you can see any ID numbers tags on the GPU card itself so that Sapphire Support can use to verify your GPU card.

Normally the Cover or Shroud has the heat sink attached. Removing it you will need to reapply thermal paste and also possibly need to replace thermal pads on another part of the GPU.

So best not to remove the Shroud or cover. 

Yes, if the card is bought second hand Sapphire Warranty is voided.


I'm not 100% on whether it was a miner card but the company I bought it from said they  had acquired about 24 of these cards from a corporate account. They were used but very briefly and did not know the specific history or whether they were mined or not. So I'm afraid I'm likely warranty exempt here.


From Sapphire Support on how to locate S/N on GPU Card:

I got the same 404 Page error as you did.

Send them an email to Tech support then. Slower but just as good. Contact Us 

Once you open a ticket via email, let me know what they say. Be sure to link this thread for them to read and explain why you need to verify the GPU card.

it getting late and my mind is burnt out.

Good night.


I took your advice and contacted Sapphire through the link you illustrated. They were able to confirm the card was indeed the 8gb version. They provided me with the correct vbios for me to flash and the card is now working properly.

Thanks for all your efforts and for taking interests in my dilemma....... You were a great help!

Thanks again



Great, Glad you contacted Sapphire and they sent you the correct vBIOS. Was the vBIOS the same as the one at TechPowerUP or different?

Doesn't really matter but I am relieved that you got your GPU card fixed finally.

By any chance did you mention that their Online Support Contact page wasn't working? Hopefully they will get it fixed for other Sapphire Customers.

Til next time,

Take care.

EDIT: One more favor, run GPU-Z and see if this time it shows the RAM Memory and everything else that is shown in my own GPU-Z. Just wondering if your modified previous vBIOS was the reason why it wasn't showing any RAM Memory and other data. Thanks!

Hi there , how long you wait for the bios? I have one identical card like yours and i need that bios to


Bro pls pass me that .rom please i need it

Journeyman III


i got the exact same card and the exact same Problem. I cant find the stock BIOS for the card. Would you please be so kind and send me the bios you got from sapphire?

thank you in advance