Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

RX 7900 XTX crashes randomly to blackscreen


I recently upgraded to a Sapphire RX 7900 XTX Gaming 24GB GDDR and been having a few issues. Since the upgrade, I've been having computer crashes in the first 20 minutes of gaming, but sometimes later, it really depends on the game. In some games I had no crashes at all, in other it almost guaranteed to crash.

The crash behaves as following: The computer loses display output, the CPU DEBUG LED turns ON (meaning NO CPU or CPU ISSUE), the GPU loses LEDs, and all the fans (CPU, GPU, CASE) keep spinning. To reboot the PC, I must use the reset button, given that the computer does no answer to the power button.

Unfortunately this type of crashing leaves no log in both Event Viewer and Reliability History.

The crash frequency depends on the game. Games that always crash on the first 20 minutes:

  • New World
  • Deep Rock Galactic
  • Apex Legends

Games that made the computer crash with lower frequency, but still happen:

  • EDF 5
  • Table Top Simulator
  • Magic Arena

Games that never crashed:

  • Metro Exodus
  • Against the Storm
  • League of Legends
  • Hell Let Loose
  • Any stress test that I throw at it


PC specs:

OS: Windows 11 x64

Motherboard: MSI B450 TOMAHAWK MAX (MS-7C02)

CPU: AMD Ryzen 7 3800X (factory clocks)

PSU: Fractal Design Ion Gold 850w

GPU: Sapphire RX 7900 XTX Gaming 24GB GDDR (mounted with 2 separate 8pin power cables)

RAM: 2x G.Skill F4-3000C16-8GISB NOTE: AMD SmartAccess Memory is on


I'll list the things I've tried to diagnose this problem:


  • Disabled Freesync (still crashes)
  • Reinstalled Windows (still crashes)
  • Disabled every option on AMD ADRENALINE (still crashes)
  • Reinstalled Windows (still crashes)
  • Bios update (still crashes)
  • Driver ver 22.12.2 (still crashes)
  • Driver ver 23.1.1 (still crashes)


  • Two other GPU's on this setup (Nvidia RTX 3080 and GTX970), with no crashes, isolating the RX 7900 XTX as the problem;
  • Other RAM sticks (still crashes)
  • Other PSU cables and PSU slots (still crashes)
  • Other monitors (still crashes) Only one monitor (still crashes)
  • HDMI, display port (still crashes)

I'll add that the reported junction temperature is at max 90ºc, crossing out thermal shutdown.

Thank you!

1 Solution
Journeyman III

Hey, I have a similar build as you and experienced a the same issue.

The games I was having this problem in were Battlefield 2042 and Dead Space. As you mentioned, I would watch my GPU LED's shut off, the CPU debug light turns on, yet all fans continued to spin until I used the power reset switch on my PSU to reboot.

I was so certain that it was a driver issue or a GPU defect, but I discovered one thing that I didn't consider before: I disabled core performance boost in the BIOS of my motherboard.

After that, I no longer had this issue! Hope this helps.


For reference, my build:

OS: Windows 11 x64

cpu: AMD Ryzen 9 5900X

gpu: AMD Radeon RX 7900 XTX

memory: x4 Corsair Vengeance RGB Pro, 3600Mhz (XMP 2)

psu: Corsair RM1000e

motherboard: MSI B450 Tomahawk Max (7C02)

View solution in original post

60 Replies

Ensure that your pcie cables are not drawing from the same 12v rail.


My PSU is single rail


..."NO CPU or CPU ISSUE"... that is strange ...

did you check temps ?

the fact that crash occurs with 7900xtx doesn't mean it is the cause , you can have forgotten to "load setup default" in bios when you change from one gpu to another , or if you don't do DDU when uninstalling drivers ...

did you check ram ? trying to set them with no xmp for example



It is indeed strange. Makes me wonder if it is a GPU-CPU incompatibility of some sort.

Temps are fine across the system when it happens.

I've reinstalled windows and did BIOS reset when trying GPUs, so I don't believe that is the issue.

I checked RAM, xmp on or off, and even tried other sticks from other manufacturer, with the same issues.


have no idea for the moment,...

to be sure, do you have 2 separate cables going from psu to gpu (not 1 separating in 2 plugs)

maybe if you are able to test you gpu in another pc or friend pc ?

Adept I

Hey man, got the exact same issue here. And the fact that I have also have the same mainboard (MSI B450 Tomahawk Max) makes me kinda curious right now. Please let me know if you find a solution for this problem.

What CPU so you have?

Unfortunately I don't have a solution at the moment. I've been trying this GPU on another PC and had no issues, so I'm starting to suspect other components

My CPU is a Ryzen 9 5900X and I have a 1200W PSU. at this point I might suspect the motherboard to be the origin of this problem. Somehow when I first installed the new GPU, everything worked fine and I also had no crashes or anything, but after a while it just started crashing constantly as I tried to play the games. Didn't change anything on the hardware or in the game settings....

Check @neonpurrs reply and see if It helps. So far It has worked for me

Adept III

I see you say you've tried other psu cables and slots but have you tried a completely different psu? I had crash issues with my 7900XTX as well and it turned out that a brand new 1250w Inwin psu was the issue all along. I even had it stable for a time when I changed monitor so it was really hard to solve the issue.


I'm in the same spot as you, my PSU is brand new, and I'm starting to suspect that it is the culprit. I haven't tested another CPU on mu machine but for the last 2 weeks I've tested this GPU on another machine, and had no issues. Step by step I'm trying to test every hardware configuration to try to isolate the issue.


Journeyman III

I have similar issues, but my crash is only while browsing or on desktop and are random....never while gaming....i just change my connection from 1 cable split in two for 2 differents cables on separate rail.I will get back to you if the problem is solved...but i do think my psu is the problem since it start to coil wine just after i upgrade my gpu(was on 6700xt before whitout problem)


2 days since i plugged the gpu on 2 separate rails instead of one splitted in two.....finger crossed its solved the issue...for crash and better benchmark score whitout even overclocking....i really do feel that the problem is fully or partly solved....

Journeyman III

Hey, I have a similar build as you and experienced a the same issue.

The games I was having this problem in were Battlefield 2042 and Dead Space. As you mentioned, I would watch my GPU LED's shut off, the CPU debug light turns on, yet all fans continued to spin until I used the power reset switch on my PSU to reboot.

I was so certain that it was a driver issue or a GPU defect, but I discovered one thing that I didn't consider before: I disabled core performance boost in the BIOS of my motherboard.

After that, I no longer had this issue! Hope this helps.


For reference, my build:

OS: Windows 11 x64

cpu: AMD Ryzen 9 5900X

gpu: AMD Radeon RX 7900 XTX

memory: x4 Corsair Vengeance RGB Pro, 3600Mhz (XMP 2)

psu: Corsair RM1000e

motherboard: MSI B450 Tomahawk Max (7C02)

Thank you! I've disabled this and had no issues so far.  I'll do some more testing and If I'm unable to crash it, I'll accept this as a solution.

Either way, I hope AMD releases a fix for this, given that disabling core performance boost hurts CPU performance considerably. 

Good afternoon

By disabling CPB and PBO, you reduced the consumption and heating of components, but did not solve your problem. By all indications, this looks like an overheated chipset. Just don't say that the PCIe x16 bus and memory hang on the processor, I know that very well. But when the motherboard chipset overheats and it starts to fool around, then absolutely everything starts to work incorrectly. Therefore, I suggested adding additional airflow to the chipset by connecting any fan, even a desktop one.


so basically the motherboard is not capable of the load produced by the components? did i understand correctly?


Hey friend, how did you do it? write about please


Figured i'd follow up since my last response:

I think I must've gotten lucky, after a motherboard upgrade (I went from the B450 Tomahawk Max to an X570 ASUS ROG Crosshair VIII Hero), I was still experiencing the same issues. At some point while tweaking my system, I had to clear CMOS, and miraculously it restored my CPU to functioning within spec! Unfortunately that means that I don't consider my above response to be a proper solution (more like a temporary workaround). I would recommend taking a look and seeing if you can do a CMOS clear on your board, and maybe that'll work for you.

Prior to this, I also found that adjusting the PBO2 Curve optimizer curve offset by +5 for some reason seemed to give my CPU enough juice to return to relatively normal operations (so my issue wasn't thermal related, but possibly has to do with the voltage?). But now that the CMOS was cleared I no longer need to do this thankfully.

Hope this helps!


For reference, my build:

OS: Windows 11 x64

cpu: AMD Ryzen 9 5900X

gpu: AMD Radeon RX 7900 XTX

memory: x4 Corsair Vengeance RGB Pro, 3600Mhz (XMP enabled)

psu: Corsair RM1000e

motherboard: X570 ASUS ROG Crosshair VIII Hero



Thank you for taking the time to write your findings.

I was experiencing complete crashes to the degree where my computer totally shut down and I had to shut off my power supply completely and back on, to be able to start my computer again. But your solution of disabling core performance boost did the trick for me as well. I would never have found that on my own.

So thank you again!

Thanks mate, fixed it for me. I suspect that the issue was implemented when I imported a profile in Adrenaline (many of you guys mentioned not to have the problem in the beginning). By importing CPU and GPU and not only GPU it might have changed the BIOS setting.

However, I made an account to thank you which never happened so far


Oddly enough, this suggestion cleared up my problem.(I think) I was getting time outs every time I would open a browser and extremely sluggish behavior. Driver would get reset every time I opened browser. I disabled core performance boost and everything is working just fine now. Weirdly enough. Although I did change the settings in group policy editor to reduce the number of file transactions before it starts to use multiple threads for writing. Also, increased the number of threads it would use at max. No idea if that helped anything? I'm also running a decent overclock on my cpu and ram. Unsure what fixed it entirely. I also had never come across something mentioning to disable core performance boost before overclocking. Also, in msi click bios if you change any settings for cpu OC it blocks changing that setting. Anyways here's my specs.


Ryzen 5 2600: 4.10Ghz all cores.

Using 240mm AIO. Doesn't peak above 64C under load even. I believe it's a Corsair ih100 or something. 

Memory: 2X

Crucial 8GB DDR4-2133 CL15 Unbuffered NON-ECC 1.2V Desktop Memory Module


I used the memory try it feature and surprisingly they're running at 2933. I haven't done any intense stress testing on them. I did Lower them to rated values when trying to figure out the GPU issue though. Put them back up to boost last night and no issues or crashes. I'm pretty sure there's no way they're holding that level of over clock though. 


AMD Radeon RX 7600XT Stock values. 


Msi MPG Gaming Edge Wifi X570

CPU and soc switching frequency are both set to 800khz. Load line 2 for cpu and load line 4 for soc. I need to tune it a little more thoroughly as my blck is dropping some under load. From what I've ready that's basically the reference voltage everything runs off of, that matters anyways. I also have the voltages adjusted somewhat. If anyone is curious about those I can get some screen grabs when back at desk


Windows 11 canary build 26085( released March 20, 2024)


Couple of months a go someone mentioned that Apex Legends breaks AMD GPU drivers and the way to fix this is, uninstall Apex Legends, not install it again, use DDU to get rid of broken drivers properly and then install latest graphics drivers.

Don't know if this helps, but it had helped some people if I recall right.

Journeyman III

Hello guys!

Im getting the EXACTLY same problem related by @CyberPoliceOfficer . 

PC specs:

OS: Windows 11 x64

Motherboard: Asus Gaming TUF X670E Plus Wifi

CPU: AMD Ryzen 9 7950X (AI Overclock)

PSU: Corsair HX1000

GPU: PowerColor 7900 XTX MBA (mounted with 2 separate 8pin power cables)

RAM: 2x 16GB PNY XLR8 DDR5 6000mhz XMP II NOTE: AMD SmartAccess Memory is ON


This problem is making me very worried… 


Ryzen 7950X / Radeon 7900 XTX MBA / Asus TUF Gaming X670E-Plus Wifi / 2 x 32GB DDR5 PNY XLR8 6000Mhz CL16 / Corsair HX1000 / Corsair H150i Pro XT (Mod Push & Pull)

same consequence doesn't mean same source of problem, regarding your hardware you should could check first your ram settings by lowering frequencies maybe or test with xmp/docp/... disabled

and check if your bios is uptodate


The problem is very strange. Yesterday I tested all possible settings, reinstalled windows, BIOS, ran everything in default settings and even so the computer gave a black screen and disabled the video card (yes, it disabled so I restarted the computer and had to enable the video card in device manager) when trying to run any 3D application (MSFS, FurMark, Hogwarts...) .

This morning I went to try to run the same apps and, so far, everything is running normally...

Honestly, I don't know what it could be anymore.

PS.: I don't have other hardware to test, like: PSU, GPU, RAM...

Ryzen 7950X / Radeon 7900 XTX MBA / Asus TUF Gaming X670E-Plus Wifi / 2 x 32GB DDR5 PNY XLR8 6000Mhz CL16 / Corsair HX1000 / Corsair H150i Pro XT (Mod Push & Pull)

Good day!

Try the following workaround:
1. Reset BIOS settings to default values (in order to remove all related factors on incorrect BIOS settings).
2. Open the case cover of the system unit and install some kind of fan in front of the motherboard chipset.
3. Test in any game where the problem was previously noticed.


Did you actually read what it says in BIOS concerning AI Overclock? 

How about you do.


Are you overclocked??? My GPU crash as soon as im dropping MV under 1100....


I tried on my xfx 7900xtx  1093mv few days multiple games and benchmarks all went perfect then cyberpunk with path tracing pushed the cores to level where 1093mv failed and amd driver self rebooted gpu and game crashed.


Now testing 1097mv hope it will close the gap to keep it stable..if not will go to 1100mv and hope it will it....


Stock mv is 1150mv


Xfx merc310 7900xtx 

Fast bios 

+12 for power limit and 100% fans setup


P.s. I hope future drivers from amd maybe enhance stability with undervolt but for now that is what it is.

Journeyman III

Stupid question but....i assume none of you are overclocked???

Adept I

try to remove the driver from AMD, then play on the driver from Windous, it helped me. if you do too, then it's about the driver.


Possible Blackscreen Crash fix

(its likely the OS with your SSD(s), not your GFX card.)

I'd been dogged with a blackscreen crash on my current rig for the past couple of years using an RX 5700 XT.  I tried the motherboard settings, drivers, firmware and nothing fixed it.  It would always drop to a blackscreen like it gave up the ghost.

I assumed it was Graphical or Memory related because of the occasional graphics artifact like a flickering blackline would occasional occur on the run up to the crash happening. 

Well two years later, I actually worked out what the culprit was... It wasn't the RAM, Motherboard or GFX card.

It's actually down to the OS setting Write behind the Cache to ON with the internal SSD drive.  Apparently my SSDs just can't handle all the readwrites that high end gaming can produce, especially if it's increased through extra cache writes.  I'm not sure if it's down to some sort of internal bufferoverflow of the SSD's internal cache, drawing too much power for the drive to do the writes or just reaching a temperature the drives not comfortable with but having those extra writes occur from caching is what was causing the crash.

Turning it Write behind the Cache OFF has:

  • Increased FPS noticably in heavy data games
  • Stopped microstutters (Lag from the CPUs handling of the caches writes)
  • Reduced energy consumption (Through the drive writes reduction and CPU overhead reduction)

(For the above reasons, I'd suggest checking laptops and tablets to make sure it's turned off too as it will definitely be useful for gamers on those devices)

I'd definitely recommend turning off the setting on your SSD drive if you are having the blackscreen crash and seeing for yourself if it stabilising your gaming experience.  (If I'm wrong, you can always turn it back on should you desire, but I'm positive it's the solution for majority of these crashes)


Hello. Thank you for your reply.

I'm not able to get to that Write behind the Cache option in Windows 11.

I followed the steps from Disabling the Write-Behind Caching Setting Does Not Disable All Write-Behind Caching on the System -..., but that setting is nowhere to be found. I've also searched the web for some info of how to get there, but with no success. The only option I find is the "Enable write caching on this device".

How did you get to that option?

Honestly I think you're into something, because for the past weeks I've been gaming on Fedora 38 with no crashes whatsoever, making me believe Windows might be also a culprit.


To disable the write-behind the cache on an SSD (You'll need admin privileges to make the change):

  1. Open Device Manager  (Click the start window and start typing "Device" for it to show you a symlink for Device Manager)
  2. In Device Manager, view by "device type" and look for the "Disk Drives" branch, expand it and right click on the drive you want to change the Cache setting on and select "Properties".
  3. Look for the "Policies" tab, you should find the Write-behind the cache currently "enabled", disable it and click OK.

If you have any problems caused by this setting, you've got the method to switch it back.

If you still have problems, I'd also suggest looking in your BIOS for any mention of an ACPI S5/S5+S6 setting and see if it's enabled. (ACPI's handling from windows and linux is different, and some of the error logs are sometimes ACPI related.)

Anyway, I hope it aids you.

Thank you for the help.

Unfortunately disabling that seems to cap disk read at less than 2mb/s, which seems weird, I would expect some drop in performance, but not enough to render the OS unusable.

I've looked around in BIOS for settings, but nothing related to ACPI S5/S5+S6.



Have you tried doing a CMOS reset, then loading optimized defaults on your motherboard?

Journeyman III

I am having the same issue with my sapphire 7900 xtx and even had it replaced via RMA. 2nd one doing the same thing. I tried resetting my bios and turning off core performance boost. same results. I even used HWInfo to look at chipset temps and put new thermal pad on it. I've tried many of the solutions and nothing seems to be the fix all for this. 

I will mention checking the chipset temp and replacement of the thermal pad seems to have bought me more gameplay time but it varies from 1-2 hrs to 4hrs.

first game I found affected was Icarus (dx12)

and now Diablo 4 (dx12)

I suspect maybe it's dx12 titles having this issue but is feels strange that I did not encounter any issues with my 1080ti but that isn't a dx12 card. but older hardware seems to be just fine.

a hard black screen with VGA error light and same manual power cycle at the PSU is required to get the system to boot. upon reboot my system goes into a 800x600 resolution and shows an issue in device manager with my 7900 xtx then after another reboot it's completely fine back to 4k (which is what I run my system at) 


cpu: AMD Ryzen 5950x 

GPU: AMD reference sapphire 24gb 7900 xtx

displays:4k benq with display port and Yamaha 4k receiver HDMI to a 4k benq.

memory: g.skill 32gb 4x 8gb 3200mhz (amd kit)

psu: 1200w EVGA p2

motherboard: Asus crosshair viii formula

os: windows 11 x64 (current build as of writing)


Adept II

I'm extremely dissapointed with my 7900xtx


Ever since I upgraded to windows 11, I get black screens, have to reset my computer multiple times, then when I boot i get reset to 800x600 and have to resintall the drivers to fix the issue


This is driving me crazy. 


Please fix this issue, it's completely breaking my experience. the same issue has happened literally more than 10 times. Every single time while playing league of legends.


Windows 10 no issues.


Before that I had a 6800 xt and my entire system had been the same and same config for years, everything including the CPU and ram are the same as before, the overclock isn't the issue.



10700k 5.1ghz all core

XFX 7900xtx MERC

MSI z490 gaming edge wifi

64GB 3600mhz DDR4