Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

RX 7600 Usage drop and freeze make it totally unsusable


So I just bought a brand new computer with :

- AMD Ryzen 7 5800X (3.8 GHz)

- Asus RX 7600 DUAL 8G


- be quiet! Pure Rock 2

- DDR4 Crucial PRO - 32 Go (2 x 16 Go) 3200 MHz - CAS 22

- Crucial P3 1 To NVMe

- Aerocool Lux 750W - 750 W

- 3 display port monitors (2x60Hz and 1x144Hz)


But I can't play anything because my GPU got usage drop that make 2sec freeze's every 10sec while being 20~30% CPU and GPU usage even in light games like League of Legends, Rocket League, Counter-strike..


(Look for the GPU Utilization decrease peak)


Here's a short list of what I've tried so long :

- Every drivers up to date

- Windows update clear

- Game bar and every windows **bleep** feature disabled

- Tried like 10 different RX drivers version and the last ones are the worst

- Enable/Disable rebar in bios and SAM in adrenalin

- Start windows in debug/safe mode

- Kill every other process's

- Bios updates

- Windows factory reset

- Low graphics

- Single monitor play

If someone can says me **bleep** is wrong please. And after lookin on internet I shall not be the only one who get problems like this.








21 Replies

GPU utilization drop-outs would seem to indicate problems getting data back and forth between the CPU and GPU. Some things to check could be causing this.

This memory is really bottom of the barrel stuff - run CPUZ or similar to make sure memory is running at rated speed and timings. - DDR4 Crucial PRO - 32 Go (2 x 16 Go) 3200 MHz - CAS 22

Run a CPU monitor side-by-side with your GPU graphs - what does CPU utilization and temp look like during play?

Run GPUZ or similar to ensure GPU PCIE is running @ gen 4.0 and not gen 3.0 and getting all 8 lanes.


Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT

Hello, thank you I will try theses and make an update ! And why this memory that bad ? Seems to me that was pretty cool or at least enough ?


CAS22 is JEDEC spec timing for DDR4-3200 - it's really basic slow memory. A good set of 3200 would have an XMP of CAS14.

The sweet spot for 5000 series Ryzen would be DDR4-3600 CAS16. There are lower latency kits of 3600 but they are expensive.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT

Ok thanks for the explanation ! I've updated the post with screenshots like you suggest, if you can take a look that be great.


Thanks, you can see from the side-by-side graphs the CPU utilization is dropping out at the same time as the GPU. I don't think the problem is being caused by the GPU, the utilization dropping is a symptom.

In your CPU-Z Memory tab, Channel # indicates 1 x 64-bit as if the memory is running single channel instead of dual. Check where your memory is installed in the motherboard - it's supposed to be in the light grey slots marked A2 and B2. I suspect the memory is installed incorrectly.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT

Yes I figured that out and change it, I also enable XMP but it didn't solve the problem

There's an up to date benchmark :


Thanks, that shows 2 x 64-bit so looks like it is running dual-channel correctly now. Surprised that had no effect because that would be a significant performance hit. Did you try GPU-Z to check the graphics card is running PCIE 4.0 x8? The other question is which M.2 slot is the SSD installed in? The top slot runs off the CPU PCIE lanes whereas the bottom slot runs off chipset PCIE lanes.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT

Thanks, I checked and yes, the GPU is running on PCIE 4.0. The NVME is installed on a dedicated slot on the motherboard. I've just made a stress test only on CPU and only on GPU, there are the results :




There are two M.2 slots on the motherboard, which slot is the Crucial P3 installed to? Have you tried moving it to the other slot, or tried a different SSD? It looks as though something in the system is choking on bandwidth - it can't keep the CPU at 100% utilization.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT

I try to swap it to the other port but do not change anything and it's working just fine and when I ran a benchmark the disk isn't even used.   





Check BIOS version F4d and AMD Chipset driver - these should be the latest. UEFI enabled and CSM disabled in BIOS? Have any other DDR4 to swap in to eliminate that?

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT

Try Cinebench runs in single and multi core - can the CPU stay at 100% utilization? It may reduce frequency due to temperature or power throttling, but it should stay near 100%. If not, try with a single stick of memory in the A2 slot, first one and benchmark, then swap the other one and run again. Also, check the +12V CPU connector, try reseating and make sure both 4pins are fully inserted.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT

Hey, thanks for the advices ! I was talking to the retailer too that says me it could be an hardware issue, so I just sent back everything and wait for them. I'll keep you posted.

Same problem here.

In League of Legends, FPS drops when almost every kill/killing spree happen.

If you get a fix for it, share it with me, ty

Adept III

Hi, @Karkolose , @LetShowThemLove.

I mentioned you bot because maybe what I explain can you helping you both.

  1. Uninstall all the bloated software provided by the motherboard manufacturing like RGB controllers, Armoury Crate etc.
  2. Do a clean install of the driver uninstalling using the AMD Cleanup Utility, and reinstall the driver and the GPU software.
  3. Check if there is a Bottleneck, to do that please run at max a game without the benchmark (these are synthetic and are good to check temperatures) but just playing a game.

About the Bottleneck you can watch this video:

Check the compatibility of the components of CPU and RAM, using the motherboard QVL list, and check also the max reccomended speed wrote on the CPU spec page.

For instance the recommended max memory speed of the RAM which guarantee stability, can you go higher this spec? yes but every type of overclocking can cause instability and crashes or unexpected behaviour.


If the components are still in warranty I suggest after this tests to use the Warranty and changing with a new product of the same brand, of course to do that if it is possibile check the warranty policy of the seller and your country.
To do an example in Italy if I order on Amazon I have 2 years of warranty and if the product have an issue, the seller can refund me or send me a new components with the same specs.

If the issue still there with the new hardare try to change the PSU, maybe bad voltage cause freezing during the operation of the PC, you do not see that, but voltage issue can create strange behviour and in a long term damage sriously your components.

Anyway let me know,

Kind Regards



After trying every single possible fiz, I Just found a solution for my FPS drops issue in league of legends. I noticed that when i'm recording a vídeo on 720p by adrenalin software the problem disappear. It is pretty annoiyng recording a ALL games though. I Hope AMD fiz It as soon as possible. Cs2 random crashes remain though.

Hi, @LetShowThemLove.

Try a rollback of the driver, so instead of install the latest version try an oldest one.

You can search for that on the driver page.

Let me know.

Kind regards,



It didn't work. I tested all previous rx 7600 drivers.


Hi, @LetShowThemLove.

If all the tests you did, changes and other things at software level do not do any changes.

There is some hardware issue I think, at this point if you still have the warranty send the GPU back to get a new one, explaining all the tests you did, but be carefull to do not say you OC your GPU, OC can cause instability and damage based on the type of OC, and how long you use that, thats why usually is in a gray area and why producer and seller based on what you say void your warranty.

Some times, can be possible that FPS dropdown can be caused by faulty GPU.

If changing drivers and set all to the default settings still get you huge FPS drop, in every game you tested, that be possibile the issue is on hardware level, to exclude that the GPU is faulty and the guilty, use the warranty to change that.
If you still have issue you have to looking for the other components, maybe the motherboard or the PSU which is in charge of giving the power to handle tasks.

So, after you change the GPU get back here and let us know whats the results is.

@Karkolose do you still have issue? if yes try you also to use the warranty for the GPU and let us know too.

Kind regards



Hey, yes I just sent everything back to the retailer. Just waiting now


My first concern is according to specs of the rx 7600, Does it support more than dual monitors.  Based on what I have been reading even if it does support the 3 monitor display 1440 is questionable.

I'm satisfied that your GPU is not the problem.  The R7 5800X is a powerhouse.

However the RX 7600 GPU is at the bottom of the 7000 series cards, in everything.  It barely outperforms the RX 6650 in tests.  Being at the bottom it should still be show 55-60 FPS in the games mentioned without the issues you have shown.  This leads to other software running in the background and hogging the VRAM in the GPU.  The 8GB of VRAM is considered obsolete, even 12GB is frowned upon today.  So don't expect high performance from this card.  However, it should not be doing what it is showing.  

Try just 1 1080 display and see it the problem persists.

If it works, try 2 1080 displays.

work your way on up from there.

Motherboard:  I have always preferred the X570 chipset over the B550 for the price difference.  Don't expect Cadillac performance from a Chevy, there is a reason the B550 is cheaper.

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"