Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

RX 6800M graphical artifacts with Vulkan/OpenGL games

I recently got myself a new laptop, the Asus ROG Strix G15 Advantage Edition (QHD panel + 5980HX + RX 6800M). While it generally works fine, I'm getting these graphical artifacts when the screen's refresh rate is set to 60hz and running Vulkan or OpenGL based games. The artifacts are visible on both the laptop display and HDMI output, regardless of resolution or whether I'm running single monitor or duplicating to both screens.

Here are examples of the issue:

Detroit Become Human (Vulkan) : screenshot, video
DOOM 2016 (OpenGL): screenshot, video

The video/images were captured through HDMI, but I'll reiterate that the issue is visible when running the laptop's display by itself at 60hz. So this shouldn't be related to the monitors or cables. I believe this is likely a driver issue.

Games that natively use Direct3D don't appear to be affected. However, throwing DXVK into the game (which wraps the graphics calls to Vulkan) can cause the artifacts to show up. I've tested this with Control Ultimate Edition in DX11 mode and it does happen when DXVK is active.

There's one interesting "workaround" that I accidentally found while trying to figure things out: having Open Broadcaster Studio open and idling in the background. No need to start a stream or recording. This somehow seems to stop the artifacts from showing up, which you can observe in the Detroit video linked above.

Going further, this issue happens on both Windows 10 and 11 with the same hardware and games. I've tried a couple versions of Adrenalin including the latest 22.4.1 (April 2022) and 21.8.2 (August 2021) obtained from AMD's website, and using Adrenaline drivers from Asus. None of these were able to fix the issue.

Running the display at a high refresh rate like 120hz or more will help avoid this issue, but that isn't really an option if I want to use external monitors that can only do 60hz.

I've already submitted a report through AMD's issue report tool, but I'm also posting here in case anyone can provide solutions or insight into fixing this.

4 Replies
Journeyman III

I tried one more solution: plugging my external monitor through a USB-C to HDMI adapter. This seems to completely fix the artifacting issue in my games without needing any extra software. Games also feel smoother, with less juddering in motion at 60hz. (note: not using FreeSync)

With the adapter, the laptop's RX 6800M is now indicated as the primary GPU in Radeon Settings. Normally, the integrated graphics was always the primary even when using the laptop's onboard HDMI port. I suppose this is due to the lack of a mux switch on this laptop model.

With other gaming laptops I've owned in the past, I generally didn't mind it but this is the first time I've dealt with broken graphics from an iGPU + dGPU combo and had to intentionally bypass the iGPU. I still can't say for sure if the hardware or software is to blame, but I'm betting on software because of the factors I mentioned in my original post.

Journeyman III

Hi, did you managed to fix it while gaming on the laptop's screen? I´m having that same issue randomly with vulkan games (Doom Eternal & Rainbow Six Siege) on a Dell G5 SE (Rx 5600m - Ryzen 5 4600H).


Unfortunately, I haven't found any proper solutions to this issue. Still have to either keep OBS running in the background, or set my panel to 120hz and use a framerate limiter.


Found a working solution! Turning off multi-plane overlay in Windows seems to have fixed the issue. This can be done by setting the following registry entry. Reboot to apply it.