Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

RX 570 not detected by games

I currently bought a RX 570 from a friend. Due to it not having windows 8 support i had to upgrade to windows 10. once i upgraded to windows 10 most of my games no longer work as they have loading errors. These errors are mostly "Can no detect a 3D graphics adapter" Or "No directX 11 compatible GPU is detected" Or "Could not find any compatible Direct 3D device". Also some game will launch but never actually run such as Path of Exile. 

I have uninstalled drivers and reinstalled drivers. I have done fresh installs on all AMD programs as well as all the games. I installed fresh DX9,10,11 and 12 drivers and still have the same issue. I have also turned off my IGPU

--Windows 10

--Kingston HyperX Savage 32GB RAM

--Asus Z87A Motherboard

--intel core i5 4590 3.30GHz processor

6 Replies
Adept I

I would be inclined to post in the correct forum but with the information given I do not know what the issue is hence the post in general topic. Also, i have looked through the AMD forums for almost 2 days now and have found nothing similar to this. I do not know if this is a driver issue or a hardware issue. Im not sure if its related to the AMD software or the Microsoft software. If i knew this i would be more willing to move or post is those forums.


This post would be more appropriate at Graphics‌ or Drivers & Software‌. Both deals with Hardware and driver issues. Better chance of other Users giving you advice.

What does Device Manager show? Any errors or yellow exclamation marks?  If so either post an image of Device Manager or error showing like Error 43, etc.

Download and run GPU-Z, If your GPU card is recognized in Device Manager, to see exactly what GPU card you have.

Here is the latest RX 570 Driver from AMD Download page: 

Make sure your Windows is fully updated via Windows Update. The Latest Drivers depends on the latest Windows updates being installed.

Also make sure your motherboard has the latest BIOS/UEFI version installed and CHIP Set from your motherboard's Support site.

Also make sure that your Intel APU Graphics driver and all Motherboard Intel Drivers are the latest. 

Download and run DDU (Display Driver Uninstaller) in Safe Mode with the internet disconnected. After DDU finishes and reboots back into Windows Desktop delete C:\AMD folder in the Root Directory. Run the full set of AMD Driver package still with the internet disconnected. Once it installs correctly, connect the Internet and again delete the installation folder C:\AMD to save space and prevent future conflicts when updating with a new AMD driver.

Go back to Device Manager and see if Display and AMD Audio are all fine without any errors. Run GPU-Z again and make sure that at the bottom OpenCL, OpenGL, and DirectX are all checkmarked indicating they are all enabled on your GPU card.

Now you should be able to run your games.

I have done all of this already. It was my very first step to use GPU-z and DDU. I have also tried every driver amd has for this video card from 2017 to the most current release 4 or 5 days ago. Windows 10 is up to date as I have run the update check every day since I upgraded. 

As far as the device manager screen, it says it's working properly. I have also flashed the bios on the GPU using the amd bios flash file.

I'll post a screenshot when I get home from work if that helps. I'll also move the post when I get home from work as well

Okay, Sounds like you need to change some settings in Radeon settings. Maybe some other User or Gamer with experience can assist you on that.


Well after digging around more i found a thread on reddit. it was for the r9 series but it worked for me too. Apparently there is an issue with the AMD drivers and Adrenalin that when running in "Gaming" mode will not read above DX9 so by changing to "Standard" and doing so minor tweaks it reads DX12 so now all my games work. 

I want to say this "solves" the problem but it really does not. AMD needs to figure out why the "Gaming" mode locks out any version about DX9

Adept I

Photos if this may help. 

Screenshot (2).pngscreenshot.gifScreenshot (4).png