Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

Radeon VII stuck at maximum fan speed

Over the past couple of weeks (I think) I noticed that the fans go up to full speed and stay there. Here are the details for clarity:

- After booting, no previous load of any kind

- WattMan confirms 0% load, 28°C, ~3850 RPM fan speed

- Inconsistent, sometimes fans slow down, haven't found any correlations

- Tried both manual and automatic fan settings, fans don't respond

- Putting the GPU under full load with gaming and quitting sometimes (?) fixes it, I think

- Latest Drivers, fresh Windows installation in January (when I bought the full system)

This is mildly annoying when I'm not using my headphones, but I'm more concerned about unnecessary wear.

The system used to have a HD5850 in it while waiting for the release of Radeon VII, but the drivers/suite are different so I don't see how that might interfere.

Any ideas?

ps I searched the forums and only found the opposite issue where the fans are stuck at low speeds, let me know if I missed a thread somewhere

pps while finishing up this post I checked WattMan and the card is currently at 90% activity, 28°C, ~3850 fan speed with nothing but this Chrome open... any way to check what the GPU is working on?

13 Replies

I had a different problem with the Radeon VII my HBM memory clock goes full speed @ 1000mhz and stays there, this happens sometimes when i crash the card when undervolted to much.. i couldn't find anything to fix this not even a DDU and or a new Driver would fix it.

After trying to Reset wattman for a few times and some restarts i found out what i have to do.

Reset Wattman after that go to Radeon Settings --> Preferences--> Restore Factory Defaults.. after doing this screen goes black for a sec then i manually Restart the system. for me this fixes it and i can then use my wattman profile again without issue.

Maybe this method works as well for your  Fan problems ?


I just tried that with no luck. What's more, I shut down the system and when powering back up the fans rev up to full speed immediately, right at the start of booting up. I have no idea how that's possible.

Current WattMan stats are below:

Activity: 0%

GPU: 21 MHz

Memory: 1003 MHz

Temp: 28°C

Fan: 3850 RPM

Junc. Temp: 30°C

You mentioned the HBM @ 1000mhz, isn't that the default value then? I don't remember seeing this value too much below 1000.

Is it possible that the fan controls are faulty? As in, the wiring or whatever?



You mentioned the HBM @ 1000mhz, isn't that the default value then? I don't remember seeing this value too much below 1000.


When the Radeon VII is in idle the HBM goes to 350mhz, it bugged out sometimes when i undervolted the card to much and the above method worked for me to get it unstuck..

But to bad this doens't work for you fan problem, well it was worth a shot..

What it may be? i have no clue

Adept I

Status update: something is definitely wrong.

I'm here working from home, my main machine with the Radeon VII is idling/sleeping, and the GPU fans go to max every ~5 minutes for about 1 minute. Absolutely nothing is running on the machine and the numbers in WattMan are the same, ~30°C, no load.

This has to be a driver issue, right? I think I'll use CCleaner or something to do a fresh installation, although I haven't used any WattMan profiles or undervolting/overclocking to mess up the settings, so I don't understand why this is happening or why a driver re-installation would fix it.

edit: After not using the machine for 2 days, the fans went full speed right as I pressed the power button. I've attached the latest readings, applicable to the last ~20 minutes (PC was idling). This is after a full driver reinstallation, which initially seemed to have fixed it.

Any ideas? Google hasn't been helpful but I'll keep trying.


I can take a stab at your problem. But first, I need more information. What is the system configuration? CPU, PSU, RAM, OS and version or update level? And more specifically, does the system run any other overclocking software?

Another thing that would be a good test is to boot the system into safe mode. Doing this will take most other software out of the picture. Does this odd behavior persist in safe mode?


Thanks for taking the effort!


CPU: AMD Ryzen 7 2700x 3.70GHz AM4 BOX Wraith Prism RGB LED

RAM: 2 x G.SKILL 16GB Trident Z RGB DDR4 3200MHz CL16 KIT F4-3200C16D-16GTZR

SSD: SAMSUNG 250GB 970 EVO M.2 PCIe M.2 2280 MZ-V7E250BW


Case: Be Quiet! Pure Base 600

PSU: CORSAIR RMx Series 750W

OS: Windows 10 64-bit Home, build 17134

Radeon Settings Version 2019.0326.2353.42986

Driver Packaging Version

No overclocking software is installed, I'm not interested in it. I uninstalled GPU-Z yesterday but the issue persists.

GPU activitiy seems to randomly go to about 90% even with barely anything open/running - maybe it's related to the problem.

I think I see some pattern here. The GPU seems to need "calibration" after each boot-up. What I mean by this is that after booting up and maybe playing an extremely lightweight game for about 15 minutes the fans go on full blast and stay there. That is until I play a demanding game where the full blast is actually needed - after the demanding game is closed, the fans go back to just over idle (900RPM) speed.

I hope the above helps. I'll try and test scenarios/patterns.


Out of curiosity, it would be useful to know the history of the temperatures. In Adrenalin, go to Gaming, then Global Settings, then Global WattMan. There should be a graph to show what is happening. I would leave that run during a test period to see what the temperatures are, and how the GPU usage varies. If indeed the temperature never goes high and the fans act like the GPU is raging hot, you may need to RMA the board. It could be the logic components that handle controlling the fan have gone janky.

If possible, capture a screen snip of the WattMan output and post it here. Any information is useful for others that may encounter the same issue.


I must say WattMan isn't exactly informative or flexible, but I've attached the readings of the last ~30 minutes. The spike in performance was me launching Apex Legends... but apparently the fans didn't go down afterwards like they tend to.

The temp readings themselves seem fine, it's the logic controlling the fans that seems to be off, as you said.

I'm also wondering if this is enough for RMA (I'm in Hungary, the culture is different to what you're used to) or if having the fans wear down or waiting for a concrete failure to happen would be wiser. I'm well within warranty period of course.

Thanks for your continued support.


I agree regarding WattMan.  There is a free tool called GPU-Z that may be helpful. It also has a graph section that shows a running history of the various measurements. You can see temperature, voltages, fan speeds, GPU activity level, etc. That may also give you a piece to the puzzle.

In the end, if your temperatures truly are low (cool) and the fan continues to run high then I would suspect a hardware issue. Surely if the GPU activity is low and the temperatures are low but the fans continue to have high RPM, something is amiss. That would be grounds enough to RMA it back. I hope this helps.

Adept I

Problem solved without RMA, the cooling connector on the GPU was not connected fully.

While I do feel a bit silly for checking on the GPU so late, I wouldn't expect something on it not to be fully functional right out of the box. I would certainly expect me not installing the GPU correctly, but that was ruled out long ago.

So if anyone has similar issues, check the bottom-right corner of the GPU (while facing the fans) and push down on the wired connector. This is not supposed to move or be removed at any point in time but due to shipping it might dislodge slightly.

This thread can be closed.

Thank you so much. I got my card just under a month ago and was about to start the process of sending it back. I can't believe it was that easy.


Great to know, thanks for sharing


Oh my, my card is 2.5 years now and only now I've decided to properly look into this issue haha

Thank you for that!
Decided to capture my attempt on video, if anyone's interested, the fix took approx 2 minutes, and turns out it was the issue all along