Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Radeon VII no Video Signal

Hi I got my Radeon VII last February, but for the past four months, it has not been outputting video when I boot up my PC. 

I thought it was my Z97 motherboard, but I am experiencing the same issue on my new X570 motherboard. There is no BIOS display, it gives a no signal. I don't get such problems when I insert my old RX Vega 64 or RTX 2080ti from my other PC. It is not the HDMI or DisplayPort cables either, I have changed them multiple times and use high grade gold plated HDMI 2.0b cables.

I am not sure if it is a UEFI issue, though I never had this issue until the past four months. Not before the AMD rolled out the firmware update that fixed the lack of UEFI support in the Radeon VII and not for months afterwards until sometime in October 2019. I am using a 1000 Gold+ rated PSU and now running a Ryzen 9 3950X with a Gigabyte Aorus Master X570 motherboard. 

Could you advise please? 

4 Replies
Journeyman III

As a follow up, I have also tried to run the Radeon VII on two other PCs and get the same result of no video signal

Adept II

have you tried to use display port.. maybe try reflashing the bios also.. you said you updated bios right 


Thanks for your reply. Sadly it may be a more serious issue. I use Linux and the AMD drivers (AMDGPU) are part of the Linux kernel so the drivers are automatically updated and presumable the GPU BIOS flashed automatically with kernel driver updates. In fact I don't recall flashing the GPU BIOS. However, I know it was up-to-date when I last checked for it in June of last year.

The X570 motherboard (Gigabyte Aorus Master) is brand new just opened this past Saturday (January 18, 2020), and works perfectly fine. As I said have tried both the Nvidia RTX 2080ti on my other workstation PC and AMD Radeon RX Vega 64 I upgraded to the Radeon VII on the same X570 motherboard and both output signals.

I have also tried the Radeon VII in
  • my second workstation PC with an ASRock X99 Extreme6 ATX LGA2011-3 Motherboard,
  • an older Asus M2N-SLI, and
  • a 2006 Intel Xeon MacPro desktop.
In all four cases the AMD Radeon VII outputs no signal to the display.

I have tried the AMD Radeon VII in different PCIe slots and tried all 3 displayPorts and the HDMI port and with all of them the display returns a no signal found. So I can't even use the Radeon VII at all.


Yea if thats the case with installing on its own that s pretty sad as if

you didnt know it was flashing and powered down or lost power or something

it would corrupt the bios im sure if you could place a good card and your

non-working card in separate pci -e slots you could try a reflash of the

bios if it even still shows up through the dos app for flashing video

cards you would have to look it it a good place to start would be @ as they have tons of bios to download for our cards,

flashing software and diys otherwise just rma it while i think you should

be covered good luck