Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Radeon Vega 11 integrated graphics can't find enough resources (Code 12)

Okay so I just built my first rig, everything's running smoothly, but just one problem.

I can see the integrated graphics I have under Display Adapters in Device Manager, but there's this exclamation mark on it and it says

"This device cannot find enough free resources that it can use. (Code 12)

If you want to use this device, you will need to disable one of the other devices on this system."

Please help, I've been trying to find a solution for the whole day, I've reinstalled the AMD drivers multiple times but it's still not working.

My PC specs:

AMD Ryzen 5 2400g with Radeon Vega 11 Graphics

MSI B350 Tomahawk motherboard

Corsair Vengeance LPX 2666mhz 4 x 4GB ram

Samsung 850 Evo SSD 500GB

Toshiba 1TB HDD

Thermaltake Smart RGB 500W PSU

7 Replies

This would be something for AMD Tech. staff amdmatt

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..
Journeyman III

I'm experiencing a similar issue after installing a new m/board with this CPU. I've tried everything I can think of: flashed BIOS to most recent version, removed and reinstalled all related drivers/software. Even reinstalled windows. No luck...

Have you managed to resolve your issue?



Im the third one with this issue: not enough resources....

Board: Asrock: AB350M Pro4

Ram:   Corsair Vengeance LPX 3200mhz 2 x 4GB

CPU:    AMD Ryzen 5 2400g with Radeon Vega 11 Graphics

SSD:    Samsung 960 Evo M.2 NVMe 250GB

all drivers newer as new!

after it was the hell to setup this SSD in this system ( including a bios-update before from the vendor and a new SSD and a new board after several tries and a "check" from the vendor it was not working at all.........)  I am not really amused with this new bug!

Does someone has any idea, what problem windows may have detected?


I don't know if you have a fresh install but I found doing a clean boot and

installing all windows updates first before the amd driver the solution to

my code 12


Yes, erseii, I did a fresh installation - but from an old Iso (Win10  build10240).

Parallel to your answer I tried it with a newer one (ver. 1699 - I think). then the chipset driver and after that the graphics driver and last the SSD NVMe-driver - and it worked.

So the solution - the Windows ISO needs to be up to date before installing the driver(s). Im sure that the way you went will work too, because at least it does the same.

Thank you for your reply!

For all others with trouble with this new components: The UEFI-(Bios) had to be the Beta V.466 for this board - The newest stable one (V.450) did not recognize the above mentioned SSD Samsung EVO 960 M.2


Yeah I figured that installing the drivers for the display first was the

cause since windows wasn't up to date for that apu yet. Glad to help.


Glad you got this working. I thought I would share this link with you as your ISO is still not the latest. This where you can always download the most recent ISO. Download Windows 10 Disc Image (ISO File)

This is a Microsoft Page and 100% Legal. You can download ISO make boot DVD or USB Flash Drive.