Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Radeon RX 7900XTX artifacts at startup

Hello everyone,

I'm here to ask for support in solving the following issues.

Last week I upgraded my GPU, from NVIDIA 2080Ti to AMD RX 7900XTX, since then I'm experiencing two problems:

1. Sometimes the pc won't start and won't even load the BIOS, it will get stuck somewhere (MOBO Asus Rog crosshair VIII hero will show Q-code 42 and white led) with no signal to the monitor. When it happens I have to press power button to shut the pc down and then restart it, repeating it until it works. Again the issue happens randomly, sometimes it's 2 times in a row, other times it does not happen.

2. Other times the PC manages to load the bios but gets stuck for a longer than normal time on the ROG logo, then the monitor will display something like 4 smaller desktops in a line with black stripes crossing them. The PSU consumpion display shows 500+W, when normally it should be less than 150W during boot up; also the GPU seems to be working at full power with cooling fans at maximum, while normally the fans do not even move. The PC still boots into windows and I can log in, then I press Alt+F4 to shut it down again, when I restart it starts working as intended. 


My sistem is:

CPU: Ryzen 9 3900X

GPU: Raden RX 700XTX

OS: Windows 11 64Bit

PSU: Rog Thor 850W

MOBO: Rog Crosshair VIII Hero

RAM: 16GB Gskill trident 4400Mhz

Nothing is overclocked and all is automatically managed in the BIOS settings. AMD driver is the latest, MOBO Bios is the latest and windows 11 updated yesterday.


Additional info:

1. I thought it could be memory related, so I performed a memtest, but it found no problems.

2. I think it's driver related. After I removed NVDIA drivers with DDU I experienced some problems because windows installed its own display driver and sometimes it crashed with AMD one, loading one or the other randomly, showing AMD incompatibility messages and whatnot. So I downgraded windows' driver and manually selected the one from AMD, I had no more of those problems afterward.


That said, when the PC starts correctly I can play and do whatever I want without problems for hours. If I play LoL the GPU is not stressed at all, fans will work only a few seconds every x minutes and power consumption is 250 - 350W. If I play something more demanding, for example Godfall, with raytracing and maxed settings, the GPU will start working seriously, with the pc consuming more than 500W, but all remains stable.


Do you happen to have some suggestions I could try?

Thank you

5 Replies
Journeyman III

What drivers are you currently using. ever since I upgraded to 23.2.2, the very same thing has happened to me with my 7900xtx, so after seeing this, I'm convinced that it's either the drivers or a rare occurrence. 


I'm using 23.2.2. I upgraded it yesterday and today I can't have a normal startup at all. It will either not boot, or boot with multiple overlapped desktops.

I'm now back to my old 2080ti and the PC is running smoothly


Hey atleast you can boot with that 2080ti lol.. 


**bleep** what drivers am I currently using? The best none. I put in my 3080ti and all my issues have been fixed. And performing with 30-40 less fps.


bro I used ALL of the 4 avail drivers my computer started working when I went ahead and did a fresh os install, then the FIRST drivers avail. 
Then tried the newest drivers Everything went to **bleep** again.

Journeyman III

After contacting ASUS support it seems the issue has been solved (already started the PC 10 times without a single problem) by setting the PCIEX16 port of the GPU to use PCIE 3.0 instead of "Auto" settings. It probably tried to use PCIE 4.0 (both MOBO and GPU seem to support it) and that seems to not run well with something inside my system.

Luckly it seems that performance is not impacted too much by downgrading the PCIEX speed (watched some YouTube comparison videos), hope it's true.