Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept III

RADEON PRO WX 7100 at 10bpc & BENQ SW271

I am not able to connect a BENQ SW271 (UHD 3840x2160) keeping 10bpc of Color Depth at 60hz and RGB 4:4:4 Full. In the Screen Control Panel of the Driver the resolution is forced at 8bpc. I can obtain 10bpc only at 30hz (not 50, or 59).

I verified the number of colors managed with the usual ramp.psd file, open in Photoshop, obtaining the confirmation of the resolutions showed in the driver panel.

The display is connected with a DP 1.4 cable (Purelink PI5010-020 certified for 8K at 60hz or 4K at 120hz with a maximum band of 32.4 Gbps).

In the Advanced Panel of Driver the 10 bit check box is flagged

The previous monitor was an ASUS PA249Q (FHD 1920x1200) working at 10bpc/60hz and full RGB 4:4:4.

I opened a ticket with BENQ Support (CETS#2019030131000962).

EDID Obtained with Monitor Info View

00000000  00 FF FF FF FF FF FF 00 09 D1 5F 7F 45 54 00 00    .........._ET..
00000010  1D 1C 01 04 B5 3C 22 78 3E 22 15 AC 51 35 B6 26    .....<"x>"..Q5.&
00000020  0E 50 54 A5 6B 80 D1 C0 81 C0 81 00 81 80 A9 C0    .PT.k...........
00000030  B3 00 01 01 01 01 4D D0 00 A0 F0 70 3E 80 30 20    ......M....p>.0
00000040  35 00 55 50 21 00 00 1A 00 00 00 FF 00 4D 37 4A    5.UP!........M7J
00000050  30 31 36 37 38 53 4C 30 0A 20 00 00 00 FD 00 18    01678SL0. ......
00000060  4B 1B 8C 3C 00 0A 20 20 20 20 20 20 00 00 00 FC    K..<..      ....
00000070  00 42 65 6E 51 20 53 57 32 37 31 0A 20 20 01 89    .BenQ SW271.  ..

Other component of setup

  • Motherboard ASUS Prime X370-PRO
  • Bios 4207
  • CPU Ryzen 1700
  • Power Supply Enermax Platimax 750 Watt
  • RAM 32 GB (2x16)
  • Windows 10 pro 64 bit 1809
55 Replies

Indeed the 18.Q1.1 driver based on 17.50 (from last year) exhibits 10bpc on all BenQ monitors I received the EDID from. Although on the SW320 the refresh rate jumps to 59Hz (hence showing 8bpc) but once the refresh rate is changed to 60Hz the 10bpc is visible. I have filed an internal ticket for our display team to investigate the behaviour of 19.Q1.1 driver vs 18.Q1.1. That being said, it is yet to be investigated if it is an AMD bug or not. I will keep you posted. The screenshot below shows the 10bpc / 4K@60Hz / RGB 4:4:4 using 18.Q1.1 (17.50) driver on the emulated BenQ EDIDs.


Adept I


Hello. Then, I will wait until your team discover if it is a AMD issue and, in this case, for a new fixed-driver. I prefer don't dowgrade to 18.Q1.1...

I have a nooby question: I install the flash bios from 113-C9540101-103 to 113-C9540101-105 but I was reading the settings and I noticed this message: Video Memory System (Memoria de vídeo del sistema, in spanish): 0 MB. Is this normal? I dont remember if with old BIOS I had this message or not.

Really it is a nooby question but I want to be sure that flashing VBIOS dont broke nothing . I am a graphic & web designer and I am a little lost in this driver-setting-bios forest.

Anyway, thanks for your awesome support!!!!!


Wow! Now I see that is not only a nooby question, it is a wrong-stupid question! The dedicated video memory is from card and I dont need video system memory with this 8GB of "dedicated video memory". Sorry... was a long work day. I need a rest, lol. Thanks!


Video memory is set to 0 is because the WX7100 has its own dedicated memory. System Video Memory is for onboard Video or APUs. Therefore Windows is reporting  the correct memory size.

Yes. It was a ridiculous question .

A new imput in case may be useful for investigation: with new bios in advanced settting, the "activate 10 bit pixel format" check option is visible again (I lost this setting with a driver update in the end of last year -perhaps with 19.1Q, i don't remember-):10-bit-setting.png

I check the option but 10 bit color is still unavailable.

Thanks for support.


The fact that you see "10bit pixel format" again in Advanced Radeon Pro Settings has nothing to do with your Video BIOS. This bug was fixed in our latest 19.Q1.1 driver.

10bpc (bits per color) and 10bpp (bit per pixel) are different. The bpc represents the “Color Depth” and has nothing to do with 10bit Pixel Format (bpp = your screenshot) which is required by some applications like Adobe Photoshop, when a 10bit monitor is connected.

Adept III

Due to my curiosity i tried 18.Q1.1 obtaining 60hz/10bpc/4K/4:4:4


The usual ramp.psd file in Photoshop is showed at 10.bit

Journeyman III

I have the BenQ SW271 but running on an AMD Vega 56 - had the same issues, not able to display 10-bit at Full RGB, only 8-bit.  I decided to drop the refresh rate down to 30 hz and I am now able to select 8-bit, 10-bit, and 12-bit Color Depths at Full RGB.  However, when selecting the HDR option on the monitor itself, it still says HDR Emulated.  I am currently connected through HDMI 2.0.  Have not tested DP as I do not have the required DP to DP cable to connect to the GPU, only DP to Mini-DP that was provided with the monitor.

I'm not sure if this would be a fix though as I would rather display the full 60 hz refresh rate...


Fixed in 19.Q2 driver available on May 8th.

Root cause:

Whenever a monitor has a CEA extension block with a CEA SVD for 3840x2160@60Hz the current and some previous drivers (except 18.Q1.1 and older) use 594MHz pixel clock and for that we do not have enough bandwidth to do 10bpc, that's why the color depth jumps back to 8bpc. Obviously the monitors without the above mentioned CEA extension block did not have any issues reporting 10bpc/RGB444/4K@60Hz

CEA extension block with a CEA SVD is mostly used for digital TVs & HDMI connections

Interim Workaround:

Emulate the EDID of your monitor with a Bit Rate of 8.1 GHz, that might work for some monitors. If you need assistance with that, PM me.


BenQ EW3270 still reports 594MHz, which seems to be a monitor issue (still under investigation). However changing the Bit Rate to 8.1GHz (HBR3) resolves the issue.

After setting to 8.1 I can no longer enter the OS (BenQ sw320). Even with safe mode there is no video output when the OS has loaded (Server 2019). I would not recommend that others try the 8.1 option at this time (re the sw BenQ monitors) and instead wait for the new driver release. 

I tried emulation with 8.1GHz bandwidth on port 3 (an unused port with the SW320 EDID loaded) as well, and the GPU driver reported 10 bpc, 4K@60Hz. Then I changed one active port (port 2) to use bandwidth of 8.1 GHz and got the same result as you — a blank screen. But fortunately I have a dual SW320 monitor setup and could recover.

Adept III

All the issues of this thread regarding a RADEON PRO WX 7100 and the lack of support to connect in Displayport a Monitor BENQ SW271 at:

  • UHD 3840x2160
  • 10bpc
  • 60hz
  • RGB 4:4:4 Full

are completely solved with Driver release 19.Q.2


Many many thanks to  fsadough for his precious support


Adept I


I still can't get 10 bpc with my new Radeon PRO WX5100.

I can select the 10bpc from the pull down menu of the Radeon driver, then the monitor turns black for a second and comes back with 8 bpc.

My system:

OS: Win10

Board ASUS X299


RADEON PRO WX5100 (driver version19.Q4.1 and  ** 19Q2 **)

Monitor: Benq sw271

Connected via DisplayPort

 The problem is still not solved, even with driver version 19Q2

Thanks for any advice





Problem solved so far:

The reason for not being able to switch to 10 bpc was simple: for whatever reason, the refreshrate was switched to 59Hz instead 60Hz in windows settings.

Whereas the system settings in AMD pro software reported a refresh rate of 59,939Hz. I assumed this is about 60Hz, therefore I didn't check the Windows setting.

Only one further question: I run no driver version 19Q2. Is there any problem with the latest driver reported regarding this issue?

Now i run 19.Q3.1 without problem


It works flawless on my end.

  1. What is the resolution and refresh rate set to?
  2. What is the pixel format you are using?
  3. What is the cable you are using (DP, HDMI)?
  4. Any adapters involved?