Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

Powercolor RX6900 XT and HP Reverb (G1& G2) problems


I've also posted this on the HP Support forum: 

I have a BSOD problem with my G2 upon connecting the DP cable to the GPU my system instantly freezes and after that shows a BSOD with Stop Code MEMORY_MANAGEMENT. To rule out a headset problem I tried my dad's G1, with that headset the system doesn't crash but both the screens stay black.

Ultimately I fired up my old Dell Visor WMR and it worked. Curious fact is that the Visor has a HDMI plug and the G1 & G2 obviously only feature DP plugs. Both the G1 and the G2 worked perfectly on my 2080Ti. Could this be a similar driver issue as what AMD had fixed for the 6800 (XT) in the current driver?

System Specs:

AMD 5800XT

MSI X570 Tomahawk

Powercolor 6900XT Red Devil

32GB G.Skill F4-3600C15 @ XMP speed


Came from a 2080Ti which had no problems running the G2. After switching GPU's I ultimately even re-installed my W10 to ensure no "left-overs" would interfere with the G2. If I install the AMD GPU driver while keeping the G2 plugged in (i kept it plugged in during the whole W10 installation and first few Windows Update cycles) the driver installer flashes the screen briefly and after that the system reboots.

If I unplug the DP cable of the headset while installing the AMD GPU driver the installation finishes successfully, however as soon as I plug in the DP cable a BSOD appears with stop code MEMORY_MANAGEMENT. I'm utterly disappointed because I already sold my 2080Ti...

37 Replies

you might need to update your bios for this video card biso 7C84v153(Beta version) is for 6800 video cards but it is beta so you might get i to lot of problems . never sell you video card when you getting new one until you test it for 1 week or so 


I have that BIOS installed already, also tried a few previous versions to rule out that casuse. I get what you say about not selling it, but ultimately I feel this top end hardware (both the 6900Xt and the G2) should be a working combination, I was also not aware of problems as there is very little information about it. Also the fixes for the 6800 (XT) GPU's in the current driver for the Reverb state no known issues with the 6900XT.

I'll just hope something is found very soon.

Adept I

I have the exact same issue. Instant crash restart when plugging into an port including external usb hub. Tried uninstalling drivers even new windows install.

6800xt Merc via riser cable. 

z490 Maximus Xii Hero Wifi


32gb trident royal z 3600

@kman83 @marcoschaap it is more likely your mother board think that G2 is a graphic card or boot able device.  


Do you guys have usb c connector for your G2 ? Because the USB c part is is for VR gaming they might F it up with DP. 


Yes. Tried that too. 

I can cause the same error to happen with nothing plugged in via the windows verifier. So it looks like its a driver issue.

A device driver attempting to corrupt the system has been caught. This is
because the driver was specified in the registry as being suspect (by the
administrator) and the kernel has enabled substantial checking of this driver.
If the driver attempts to corrupt the system, bugchecks 0xC4, 0xC1 and 0xA will
be among the most commonly seen crashes.
Arg1: 0000000000002000, Code Integrity Issue: The caller specified an executable pool type. (Expected: NonPagedPoolNx)
Arg2: fffff80b3d3f1d93, The address in the driver's code where the error was detected.
Arg3: 0000000000000000, Pool Type.
Arg4: 0000000000726274, Pool Tag (if provided).

Check your firewall see if it blocked the AMD drivers also check the administrator permissions. You might accidently block the driver 🤣. Check the registry to see if AMD software is block or not . 



With 2080Ti in that same motherboard the G2 worked like a charm. How could this be a motherboard issue? I've tried multiple combinations of things which all did not help. I have tested three headsets (2 DP connectors and 1 HDMI) and only the latter works. I've read multiple users which report problems on DP connected hardware with very high resolution / frequency combinations. I'd suspect the error is to be searched in that corner.


"because the driver was specified in the registry as being suspect (by the

check if your system is blocking the AMD software or not 


 check this one


I have gone through and checked. All AMD stuff is allowed in firewall. I have done every step in that check list. I'm suss on the realtek usb 2.0 when it loads it crashes. 

If I use my usb 2.0 slot it doesn't crash and the realtek usb 2.0 will load and sound comes out of the headset. But then mrp wont go any further. 

My main monitor is 49rg9 5120x1440 120h.




I was so hopefull seeing the new optional driver on the website just a few minutes ago. De-installed the driver, fired up the PC installed the new driver, reboot, plug in the Reverb....

BSOD dammit

On a positive note, I hung on the phone with HP support this morning and they are working with AMD on a fix for this. The HP support rep. told me the BSOD is caused by a AMD driver issue. So now we wait....

and wait...and wait... unfortunately. I've seen issues relating to this with the Valve VR from Steam just yesterday I happened to see some gripes with that not working part of the time or at all. All were AMD that I saw.

"It worked before you broke it!"

Yep... still getting the same memory stop bsod. After updating to the latest driver. Also changed registry for wmr to install in developer mode to at least change some settings. 

Sent emails to XFX and they're looking into it. 

Wasted many many hours on this **bleep**e.


Can you share the regs for the developer mode? I've also sent e-mails to Powercolor / reported the issue on their forum but no reaction whatsoever. Yesterday in the evening on Reddit there was a HP Rep. answering questions about the G2 but even then I only got some answer like "did you install the latest driver for your GPU?" I'm hoping for the next driver to solve the issue, but the fact it isn't even listed as a known issue does not create a lot of faith for that.

I'm almost ready just to send it back and settle for less with a 3080 if I can get my hands on it...



If the "PreallocateVirtualMonitors" REG_DWORD isn't present, create it by selecting Edit > New > DWORD (32-bit) Value and entering PreallocateVirtualMonitors as the name

If the "PreallocateVirtualMonitors" REG_DWORD is present (or you just created it), double-click the entry and change "Value data" from 1 (its default value) to 0 (zero)

TRUE - 1



I even tried unplugging all external devices. Change to basic keyboard and mouse. Removed the riser cable. Swapped ram. Reinstalling windows twice. Installed windows using local account. Firewall and defender off. Different bios. Running driver verification fails with the same error when nothing plugged in. Mem test pass. All oc off. 

The only thing we have in common is 6000 series cards. But others have no problem. I don't get it. 

Are you running 1 or 2 nvme drives? What mode in bios for your drives? That's about the only thing I haven't tried. 



I'll try unplugging one of the two NVME drives. I have 2 980's in PCI-e 4 mode which I don't expect to make any difference but for f*ck sake I'll break one of them apart if that would've been the cause. I tried every single thing just like you and I'm furious for the lack of communication...


They have a newer driver out, 21.1.1 not sure if it helps. A few threads in here about the HP G2 Reverb, Valve not working, it's a VR nightmare.

"It worked before you broke it!"

Ordered a RTX 3080, if that works the 6900XT will be returned. With pain in my heart but for two companies (AMD & HP) with such a great collaboration (as said by the AMD CEO on the CES 2021 livestream) I can't conclude otherwise then that priorities for solving this issue(s) with their products are on the low side.

For example another thing that is happening, but that was not the root of my problem; the x570 **bleep**show. How can it be that months and months go by and these issues seem to be unsolvable.


My response back from XFX:

From the minidump file,  the error is caused by ntoskrnl.exe bug check string MEMORY_MANAGEMENT.
It seems to be a common problem on systems with  AMD gpu and reverb G2 as seen from discussion forums. A user has the latest Windows update, but still can't get the device work completely :
You may open a ticket with AMD to report the problem or wait for driver updates later on.
Also AMD release another optional driver 21.1.1  last week, maybe check again with this verison.

Hi @kman83,

I have opened support tickets with both AMD & HP Support but I've heard nothing but uncertainty about when a fix will be released. The recent 21.1.1 driver doesn't fix the problem, I saw a topic on Reddit recently where apparently devs are harvesting bugs and incident reports. I've also reported it there:

I've created a full memory dump for the support rep. to investigate the issue. Meanwhile I'm sick of waiting on a problem that should have been fixed a long time ago. Multiple RX 5xxx users also have reported the same issues over and over again. Ordered an RTX 3080 the other day and it will be delivered today. If that GPU does work my 6900XT will be returned. Sick of it....


Good luck with that. Nvidia has it's issues as well, fair notice. 

"It worked before you broke it!"

Connected and installed the 3080, works instantly. Bye 6900xt

Say "bye" on AMD corporate's site. Not many staff read or even care if someone switches brand. When AMD releases a fix, and the RX 6900 XT is kicking that 3080's butt, you'll regret losing it. Shame AMD lost a customer because of a VR issue though. Good luck with that card.

"It worked before you broke it!"

That bye was not meant as some sort of provocation, but merely an outing of my frustration with the whole situation.

I get what you say about the butt kicking, but at the price I got the 6900XT **bleep** should work. I have a 30-day no hassle return policy and do not want to be stuck with a GPU that has issues with my main purpose for it: gaming in VR. I got the 3080 far cheaper and it works out of the box.

End of the day, I love the 6900XT and it's potential, but it's big money not working against cheaper, working and 10 fps less in VR..

I am actually a bit worried about AMD and VR. I also bought a RX6900 XT. And I truly enjoy how fast it is, for now it's amazing for me in VR. I play MSFS, ACC, DCS all really heavy sims and it is really fast. But here is a rather big problem and it worries me....I maybe have to sell my RX6900 XT...

I don't know about other amd GPU's, but ASW and reprojection are basically not usable in the RX6900 XT, it's just not smooth at all. Even if I turn down my graphics, it's just not smooth whatever you do. Also lower Hz is not smooth. Nvidia is seriously way smoother with asw (asynchronous spacewarp) or lower Hz, I am a Rift S owner. I have also read about reprojection that it's not as good as NVIDIA. My 1080ti is smoother with less fps in asw and lower hz. Without asw the RX6900 XT is smoother as expected. So for now the RX6900 XT is amazing for me with better fps.

But this is a really big problem, the advantage NVIDIA has with smoother asw and reprojection is big, it's really big VR nerds know what I am talking about, it's more future proof. For example 1080ti owners have a pretty smooth experience in MSFS with a 30HZ lock. This is impossible with my expensive RX6900 XT. And I know MSFS with 3d party addons will demand fps in the future and then the RX6900 XT can't compete without good asw or reprojection, not even with a rtx 3070.

You guys also experiencing this? I will address it to AMD, hopefully, it's something minor... and they can solve it with drivers. Otherwise, I have to consider selling it.... a shame really...



Also selling my 6900XT, Visual Pinball VR doesn't work and freesync works better with Nvidia (brightness flickering with the 6900XT). Wireless streaming also got some issues.


Zielho, how is the reprojection or asw with your VR glasses? yeah it's a's a strong GPU, but it seems like amd doesn't support VR that great....


I dunno what happened, but ASW works perfectly now. Keeping my RX6900XT, I need to find out what it is....

It seems like it has to do with settings and not with AMD hardware...


Not sure all I know somethimes mostly or only with steamVR I do see some stutter.
For example when playing Visual Pinball VR (free, go try it just awsome:
It (Visual Pinball VR) works now btw with my 6900XT, dunno how I got it fixed I think it was a windows update.
Pm me for help setting it up if interested (if you can do pm's in this forum).

But compared with Nvidia when watching the ball it doesn't move smoothly. Or when just looking arround at stuff very close I see it's just isn't as smooth compared with Nvidia. And my Nvidia isn't as powerfull (3060Ti) as my 6900XT so it shouldn't be a fps issue. And in some games when using steamVR games I get a little freeze as well.
Still have my 6900XT but most likely since I don't think this will be fixed any time soon will sell it. Bit of a bummer  currently AMD VR performance overall compared with Nvidia.

But this issue you had but is ok now? or you mean something else.

Sounds like a CPU bottleneck causing stutter. Need full specs or if you are running a CPU less than a 5000 series, that's the issue. Many upgrade to the 5900X and issues go away, I think a 5600X would do the trick. It opens up the GPU to use the L3 cache on the CPU and on games that allow for SAM, that works as well. 

Another "trick" you can try is move the minimum GPU clock to within 100Mhz of the maximum clock, and set the VRAM to "fast". 

"It worked before you broke it!"

You could be right about that. But I doubt this pinball game is using allot of processor power though.
I got GPU usage spikes like crazy. Going from 99% to 5%, 50%, 90%, 10% which follow eachothers up pretty fast. Got that as well in other games often. Don't have that with my 3060Ti at al, pretty much always at 99%.
Processor: I5 8600K @ 4.7Ghz.
I was thinking about upgrading but since the HP G2 got some USB issues with x570 boards I didn't yet.


Did you use DDU in safe mode to uninstall the Nvidia drivers? Display Driver Uninstaller Download version (

You might need to run it twice. If using a VR headset, in the release notes for the newest driver it says to leave the headset disconnected during driver install and it should work. GPU spikes can be smoothed out with moving the low and high clock to within 100Mhz of each other and make sure the VRAM is set to "fast", it's usually not set to that out of box for some reason.

Think of "pinball" as the "sphere" test on Userbench. It could use more CPU than you realize, depends on game engine. Things written is C#, C++, others can actually use the CPU more than one thinks. Not saying that's the case here. 

"It worked before you broke it!"

What happens without connecting the VR and just the monitor to eliminate a driver issue? It could be an HP issue as well, so ask them. I'd also just for kicks, run Memtest X86 or similar from HCI to confirm your RAM is OK. Perhaps a stick got knocked loose during install of the card.

Are you using 2 separate power cables off your PSU to the card? I recommend doing that as someone else had an issue where that was the problem.

Lastly, seems to be a lot of Power Color RedDevil cards having various issues on here and in other forums. Check with Power Color as well. 

"It worked before you broke it!"

The problem is that just a monitor works fine, on a 2560x1440@60Hz screen, both the G1 and G2 have a resolution of 4320x2160@90Hz, so that's a completely different ball park. 

In the release notes for the 20.12.1 driver they fixed an issue with the 6800 series GPU and the G2:

  • The HP Reverb G2 VR headset may fail to sync or may have a black screen when run with Radeon RX 6800 series graphics products.

Also there are still known issues with some screens with (very) high resolution and frequencies:

  • Some displays such as the Sceptre C series or Samsung™ Odyssey G9 series may experience an intermittent black screen on Radeon RX 6000 series graphics products.
  • The Samsung™ Odyssey G9 C49G95T may experience display or corruption issues when set to 5120x1440@240hz.

I've read some info in the manual of the Samsung G9, and as one can read on page 20, the optimal resolution as above can only be set by using DP, that's another reason why I suspect the AMD GPU drivers to not work as they should.

To answer to your other points:

- My RAM is OK, Memtestx86 is not the best RAM stability tester, OCCT does that job a little better, but my PC is completely stable.  

- I use two seperate PCI-e cables from the PSU, as the Red Devil has three 8-pin inputs I split one of these cables. Not that this is of any use because AMD hard limits the total board power to 325W and it sits on that precisely during stresstesting or benchmarking.

- I also contacted Powercolor about the issue, good point.

It sure did work for it broke me ;-)

It must truly suck to spend $700+ on a VR set and it not work as intended. Hopefully AMD fixes the driver issue you pointed out. If you go into that software, you can report driver issues that go right to the team. They "might" answer or ask you for the DXDiag and MSInfo to be emailed to them after waiting until the next driver roll out. In other words, they are slow to respond, quick to take your money.

I'm just glad I stick with my 32" 1080p and never messed with VR or even higher resolutions. That is a ton of power, 325W.... crazy.

"It worked before you broke it!"
Adept II

Got the same card and the HP G2. It's working for me! 
But you have to set resolution in WMR settings on 4320 x 2160, on auto my screen goes bad.

Your problem isn't with the X570 chipset? there is a problem with that and the G2 I know, maybe try a different USB port or a hub.


I received a couple of e-mails from AMD support and after some troubleshooting the issue is forwarded to the driver department for a possible driver issue. Anyone having BSOD's MEMORY_MANAGEMENT it might be helpfull to refer to incident: 8201047628.

Also report via the Bug Report Tool is helpfull for the driver team.