Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

No signal with 2 monitor set up. Black screens on bootup and when changing game resolutions.


I recently got a new monitor, which is the Acer 27" Nitro VG270UP (2560 x 1440 @144hz). I've been using a dual monitor setup before this fine with my Acer 24" Predator GN246HL (1920x1080 @144hz and some old Samsung 21" TV (1920x1080 @60Hz).

Now, specs:
GPU: Asus ROG Strix RX480
CPU: AMD Ryzen 5 5600X
RAM: 16Gb 3200MHz
PSU: Corsair RM750x

So first I had the fine idea (ofc) of making my setup a 3 monitor. Plugged them all in:
-Acer 27" Nitro with Display Port in the middle of my setup
-Acer 24" Predator with Dual link DVI to the left of my Nitro
-Samsung TV with HDMI to the right of my Nitro

Ok. No problems so far. All resolutions and refresh rates are up where they should be.

Now. Let's get to the fun part. Gaming. I launch Ready or not and yeah boots up fine and even properly on the monitor set as the main monitor, which is the Acer Nitro. Now during the game session, I went to check if the game was running on fullscreen or fullscreen windowed. And I changed it into fullscreen. This is where all the problems started and I've been trying to troubleshoot this for 2 days now. During the fullscreen change, the game went to my Samsung TV and my main monitor went black screen. I instantly went to check windows monitor settings and the main monitor was set as "Disconnect this monitor". Tried setting it back to "Extend this monitor". Pressed confirm and oh. Changed back to "Disconnect". Well, what about duplicate this display? Well, that works, I got picture. Try setting back to extend and now it works again. But the game is still on the wrong monitor. This I managed to fix by using Shift+Win+Left arrow. Okay. The game session ended. I felt a little worried that is this the life I get again for wanting to upgrade.

Okay. Fast forward to couple of hours later. Turns out, after restarting my computer either the Nitro has a black screen or the other 2 screens have a black screen. So I figured through googling a little that my GPU can support only 2 "clock generators" or whatever. So I ditch the Samsung TV in favor of the higher refresh rate of the predator. Now we have 2 monitors left with only 1 DP and 1 DVI cable. After restart, Nitro was getting a signal, predator was not. So I tried doing the "Extend this monitor" thing again. Reverted back instantly even though I confirmed it. Duplicating works and after that so does extend. So I tried switching the DVI to HDMI and did another restart. Nothing on the predator still. And again going through the same duplicate and then extend loop it starts working. At this point, I started to get a little frustrated and uninstalled all inactive monitors from my device manager and also uninstalled my AMD drivers with DDU in safe mode and reinstalled them. Restart after installation. STILL NOTHING.

All games, if I touch the settings to change my resolution to the one I want, jump straight to the predator screen, and this blacks out my main monitor by setting it to "Disconnect this monitor" in windows for some reason. And it is almost impossible to get the game back to the main screen after this has happened. At this point, I'm pretty desperate for answers and I can't find a similar issue anywhere on google. It seems like my GPU wants to prefer the predator over the nitro and is looking for the samsung TV to go with it completely disregarding the Nitro. And yeah, I've tried my previous setup of the Predator and Samsung and it works as it should. It even remembered my desktop icon setup.

1 Solution
Adept I


Disabled HDR from the new monitor in its settings and in windows. By miracle, my second monitor instantly started up. This might be the fix.

View solution in original post

3 Replies
Adept I


Disabled HDR from the new monitor in its settings and in windows. By miracle, my second monitor instantly started up. This might be the fix.

Volunteer Moderator

I know running HDR on my setup when I was using 2 monitors, one supporting it and the other not, I had issues.

ASRock X570 Taichi, Ryzen 7 5700X, 32GB RAM 3600Mhz, AMD Radeon RX 7900 XT, Corsair HX1000 1000 Watt Fully Modular PSU, Win11Pro

That really seemed to be the problem in it's simplicity. I kinda feel dumb for not realizing. Going to accept my reply as the solution.