Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

No BIOS video output when it's in UEFI mode

Hello everyone!

I encountered a problem with my machine running Fedora Workstation 36 (up-to-date) and Microsoft Windows 11 (up-to-date) in dual boot.



GPU:  XFX Radeon RX 6600 XT 8GB (model RX-66XT8LBDQ)
CPU: AMD Ryzen 7 2700X
RAM: DDR4 Corsair Vengeance LPX Black 16GB (2 x 8GB) 2666MHz
Power Supply: EVGA 650W 80+ GOLD


  1. Samsung Pro 980 1TB M.2 (Fedora Workstation 36)
  2. Sandisk 120GB (Microsoft Windows 11)


  1. Seagate BarraCuda 1TB
  2. Seagate BarraCuda 2TB

Screens: Acer Nitro VG270Sbmiipx FreeSync x 2





When I change the "BIOS CSM/UEFI mode" setting in the BIOS (Advanced\Windows OS Configuration), my monitors yell "Input Not Supported" during POST and it stays if I press the DEL button which opens the BIOS configuration.

Video output gets restored as soon as the operating system takes over.
I can reset the CMOS to get back to a working state but I'd like to enable Secure Boot on my machine.

Toggling the dual BIOS switch on the card does not help.

UEFI BIOS works on my old graphic card (MSI GeForce GTX 1060 6GB)


Thank you for your help!

15 Replies
Journeyman III

I had no video output after upgrading (flashing) to latest AMI BIOS7B85v1G on my MSI B450 Carbon Gaming Pro AC. I needed to flash back to the previous rom to get anything to work as my PC wouldnt boot up without needing a trip into the BIOS settings (which I couldnt see!).

Sorry for the very late reply!

I tested with another graphic card (MSI GeForce GTX 1060 6GB) and it did work so I now doubt this is a problem in the motherboard firmware as I also changed my motherboard meanwhile.


Is the problem that you can't enter the BIOS when pressing the del key at startup?  If so perhaps I can shed some light on your problem.

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

Sorry for the very late reply!

That is correct. I can just let my system boot without pressing anything but if I press the DEL key while the system is booting, my screen will just keep screaming "Input Not Supported" as the BIOS configuration is open.


Just a couple of things learned about the 2700X and the no screen on boot up.  If your running your monitor in freesync mode try disabling it.  At one point AMD did fix the GPU drivers to solve that problem  You could not access the BIOS by pressing the delete key with Freesync running.  Or at least with a Samsung 27" curved monitor I have.  the driver version was somewhere around 27.2 or there abouts where that was corrected.

Now for your Samsung 980 Pro NVMe drive that is another issue where the only solution is a CPU upgrade.  The 2700X does not support PCIe4 NVMe drives and will opperate at PCIE3 speeds, which is about 1/2 that as PCIE4.

I can't believe that you do not have the option to disable the integrated graphics in the BIOS, or did I just misunderstand one of the replies.

Another problem that may be of concern that I have experienced in the CSM and UEFI modes.  If you installed Windows in CSM major problems tend to fly up and slap you in the face when you simply switch the mode to UEFI.  First of all, I can't understand why anyone would want to install Windows 10 / 11 in an obsolete mode like CSM. 

My suggestion is to wipe the drive clean and reinstall Windows 11 in UEFI mode.  Your probably experiencing some of the obsolescence in the CSM mode that has conflicts with newer technology and the services are simply not there or not compatible.  

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

Hello Vynski,

I've tried disabling FreeSync on both my monitors (one connected via some Amazon Basics HDMI cable and the other one via a DisplayPort to HDMI adapter because the graphics card only has one HDMI port) and didn't succeed in viewing the BIOS configuration screen.

Thank you for the information about PCIe4 not being supported by my CPU, will consider upgrading in the future.

I don't know if I do have the option to disable integrated graphics in the BIOS configuration screen but I doubt it could have an effect on the problem since my CPU doesn't have integrated graphics.

Windows 11 is not my primary operating system as you may have guessed by its installation on a lower performance disk. I since wiped it from the disk and reinstalled my Fedora Silverblue operating system. The operating systems are working fine while UEFI mode is enabled, not the BIOS configuration though.

The CPU may not have integrated graphics but the motherboard might.  Depends on the model and brand.  Although, if you can't get a BIOS screen that won't help.  You have to be able to enter the BIOS.

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

I now have a Gigabyte X570 AORUS ELITE motherboard and it seems - according to a Google search - that modern motherboards don't have integrated graphics anymore?

I can get into the firmware configuration with another screen.


Is this the first time you set BIOS to UEFI Mode only ?  You had video output from your AMD GPU Card with CSM Mode enabled?

Do you get the Dual OS screen when booting up to have you select which OS you want to boot up with?

Or do you not have any video Output until Windows 11 starts loading automatically?

I remember when I had a Dual OS Boot configuration when I boot up I get a menu to ask me which OS i wanted to boot up with.

On my computer my 4K LG monitor is not compatible with UEFI Mode. I have no video output until Windows 11 starts to load. Then I have Video Output. But in CSM Mode I do have video output from my LG Monitor.

What I do is connect my 2K Smart TV which does have video output when booting up. Thus I have access to my BIOS under UEFI Mode.

Sorry for the very late answer!

I do have video output from my AMD GPU with CSM enabled but I needed UEFI for Secure Boot for some app. I can see the GRUB menu but this is the same on a non-dual boot system.

I contacted XFX (the card's manufacturer) about the problem and they finally said the graphics card in fact didn't support UEFI BIOS but this is kinda weird...

Yeh; that is kind of weird.  I think there tech person probably has that reversed.  I can see it not supported by the CSM mode but not UEFI.

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"
Journeyman III

Alright so this is what we know:

  • Issue is not directly related to GPU brand or model (I have a GTX 1660 Super and i suffer from the same problem)
  • The issue happens after disabling CSM / enabling UEFI Only
  • The BIOS/UEFI is not displayed but it is there
  • The issue probably lies on the monitor or the video cables (HDMI/DP)

I've tried 2 monitors and neither of them show the BIOS, we need to know what feature the monitors are lacking that makes them not display anything

Please let me know if any of you discover a definitive solution

Also, please try this if you can 


Some things which can cause this (shouldn't, but can):

1) System trying to use onboard graphics even when there is a discrete GPU. Fix by disabling integrated graphics adaptor from BIOS (not in your case as you have 2700X)

2) System knowing how to use first video output port only, when you have connected your monitor to some other port. Often HDMI is primary. See BIOS if there is an option to change, which is primary display.

3) Weird incompatibility, where  using different version of display port cable than what monitor supports  (DP1.2 vs DP 1.4 - even though should be backwards compatible). Should be ok if monitor and cable are of same version.

4) Try disabling quick boot

5) Sometimes you need an updated firmware to GPU. See if one is available to your GPU from the brand that made your card.

6) Would also try through all the ports if only one of them sends out signal. Youi could also try to use TV as monitor for testing purposes

Sorry for the very late reply, I didn't receive any email notifications about this forum thread...
Did you find any solutions for your problem?

I contacted XFX (the card's manufacturer) and they said that, in fact, the card doesn't support UEFI BIOS which is kinda disappointing and weird??? I checked with all of the HDMI and DisplayPort ports and it didn't change a thing, maybe I should try another monitor...

Adept I

I figured out that my screen was the problem, with another screen and the same HDMI cable the problem is not there.

I can't even see GRUB's menu with my Acer Nitro...