Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

New RX560-4GB crashing intermittently.

Hey everyone, not exactly sure which part of the forum to post this, mods feel free to delete this if it's in the wrong place. I thought I'd try here after searching around on google, reddit, youtube, and several other places and couldn't figure out what is wrong with my PC.

-AMD Graphics Card


-Desktop or Laptop System


-Operating System

Windows 10 64bit Pro

-Driver version installed

Latest as of 10/9 (18.9.3)

-Display Devices

Acer 23" monitor HDMI to HDMI on RX560

-Motherboard + Bios Revision

Gigabyte AB350M-DS3H - all chipset and bios up to date as of 10/9


Ryzen 2200G, stock clocks with wraith spire cooler + arctic silver five TP

-Power Supply Unit  Make, Model & Wattage



Corsair Vengance DDR-4 2400 4GBx2 kit


I just recently installed a new RX560 4GB (with a 6pin plug that is plugged in) in my system to game with. I was previously using the built in APU on my 2200G. Now that I have a graphics card in my system, I am getting all kinds of issues from black screens to reboots to driver failures to full lock ups that require a manual reboot. Sometimes my game will freeze then go to a black screen. Sometimes it hangs there and forces me to manually reboot the computer, sometimes it turns off my monitor and tells me no input and I have to manually reboot, sometimes it just reboots my computer immediately.

Before I had a dedicated graphics card I had zero issues with this system.

I have checked the event log and have these errors:

"Warning - Display - Display driver amdkmdap stopped responding and has successfully recovered." (this happens about 2-4 times a day, both while gaming and browsing the web)

"Distributed COM - The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID" (like 20-30 times a day)

"Critical - Event 41 - Kernel Power - The previous system shutdown at 3:19:47 PM on ‎10/‎9/‎2018 was unexpected." (this happens about 1-2 times a day while gaming)

This is all while playing Forza Horizon 3 (the only PC game I currently have, I built this computer to play it)


So far I've tried:

-full wipe & reinstall of windows 4x

-ssd diagnostics tool

-memtest for 8 hours, no faults found

-PSU test with OCCT

-Updated bios, changed CMOS battery, ensured nothing is overclocked or altered

-Furmark GPU stress test for several hours

-Furmark GPU & CPU test at the same time

-Prime95 test for 30 minutes

-wiping all drivers with DDU and trying both older drivers and newer drivers (currently on 18.9.3)

-Fully updating all windows updates and chipsets and everything else I could possibly update the drivers on

-Ive tried a spare 500W PSU I had, same issues, same reboots and freezes

-Reseated the ram, the psu cables and CPU, even got a new cooler and TP for the CPU

Does anyone have any suggestions? Things I should try? I don't have another PC to put the graphics card in unfortunately.

22 Replies

450-500w should be plenty for the card, but depending on how the PSU is designed it may not be providing enough peak power if the card is trying to draw more current, unless the system is powering off while no games or 3d applications are running of course. Games provide unique load for GPU's so tests may not always reveal every potential issue.

If it's not the power supply, you may have gotten a card with faulty video memory; the only solution there is to RMA I'm afraid.


I actually returned the card to Microcenter and got another of the same card. Same problems still happening. I tried with a 700w PSU from a friend yesterday and the same thing was happening, as it was with my backup corsair 500w psu I tried. It's starting to happen outside of games on the desktop and when I'm browsing chrome as well. :\

Ok, so that rules out the PSU or faulty card theory, which is helpful.

What were your GPU temperatures while you were stress testing? Are you using a custom fan curve in Radeon Settings or any other 3rd party tool such as Afterburner? You could also completely disable the APU graphics and to avoid any sort of proprietary GPU power saving function, just to be safe. That'd be a stretch but I typically disable everything that I don't use.

Do you have any other PCIe graphics cards to try on the board? Could be anything... something a few gens old even.


It stayed around 61c when 100% maxed out. Haven't used any third party over or underclocking utlity, and my APU has been disabled in the bios since I got the card.

Unfortunately I don't have any other cards to try, except onboard graphics.


Odd. Is this system protected with a UPS of some type? Is the power reliable in your area?


It was working fine. But nowadays it starts crashing the system. I have 600 Watt Power Supply


Crappy software

Journeyman III

Did your computer doing a sound like "drrrrrrrr"(in your headset) ?


No, I don't have a headset hooked up. The only odd sound I've had happen was a beeping sound through my speakers like Morris code when I moved my mouse a few times that I googled and was linked to a windows 10 update, but that's stopped since the latest update.


I have the same problems as him and when the music plays in the headset makes such a sound, what do you think about it?


Hey, you want like what i'll say but there is no curse for it x_x, i got my r9 390x allmost 2 years ago and it still crashing. There is a technique that may work cos it work for me : when the crash arrives just restart your pc by the restart button on your computer, it wont crash next time.

Télécharger Outlook pour Android<>


in my opinion your method does not help me, the most strange thing is that it does not happen when I play games

I notice everytime my rx560 crashes and causes a black screen, there is always either chrome or zoom open. Another strange thing is that it never happen in game, even when i run it more than 24 hours. It is really annoying to unplug the HDMI cable from the gpu and use integrated graphics every time i need to work on schoolwork, while to play games, i need to unplug it from the MOBO, and plug it in the GPU.....i really hope someone could find solution to this issue and @amd with a better driver...thanks.. 

I don't think you need zoom OR chrome to instantly crash my pc, 

As soon as I boot, It instantly crashes.

Bro please someone help I have the same problem 


I7 3770 

12GB ddr3


250 Hdd

128 Ssd



Journeyman III

Did anyone ever come up with a solution to this? I have the same card and the strange thing and this was found out by accident over the summer by noticing that when the inside temperature of the trailer home I live in, rises, the system does not crash. As such, if I pre-heat the card by placing a space heater near the computer vents and letting it run for several minutes to warm up the computer, it does not crash. If I don't heat it up, the system keeps crashing non stop. I don't have to leave the heater running. Usually after about ten minutes or so, I shut it off and the computer is fine and runs like normal. It's like it just has to get up to temperature or something. Now I know the AMD software automatically adjusts voltage and power settings for the card and it's fan according to whatever the temperature is.

Journeyman III

I have exactly the same issues with my PowerColor RX580 Red Dragon 8GB since I swapped my mainboard (MSI 970A G43 to ASRock AB350M HDV) and cpu (FX6300 to Ryzen 3 2200g) with Win 10 clean install.

"Warning - Display - Display driver amdkmdap stopped responding and has successfully recovered."

"Distributed COM - The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID"

"Critical - Event 41 - Kernel Power - The previous system shutdown"

When i play a Game, there is no problem but when i play a second game (example: at first AC Odyssey and then Forza Horizon 4) i got the issues listed above.

I dont get the issues when i play AC Odyssey and then i restart my PC and play FH4.

It is strange that the problems occur more often when I have spotify or firefox open while I am playing.

I also thought at first that it was due to a weak power supply (500W), but these problems also occur in game menus or games that do not need power. In addition, the RX580 previously worked with the same power supply and the FX 6300 needs more power than the Ryzen 3 2200g.

I've tried so much:

-Driver Updates (GPU, Chipset)

-Bios Update

-RAM Clock

-VC++ Updates, net.Framework Repair Tool

-AiO Runtime Package

-GPU Undervolting

-GPU Bios Switch to Silence Mode

-PSU Cable (1x 6+2 (8) Pin changed in 2x 6 to 1x 8 pin adapter)

...and many more but nothing helps.

Journeyman III

I have the same problems as you with similar specs... Ryzen 3200g, RX 560, 16GB DDR4 3200mhz, 400W PSU. I’m getting the same errors too. I’ve tried so many potential fixes and haven’t been able to solve the problem. Did you ever find a way to fix your system?

Journeyman III

TURN OFF AUTOMATIC UPDATES  (type updates in cortana bar and manually update, then pause auto updates for 7 days,,,,,,,, then run that card, i have the same gpu and its only thing that worked so far,, (just remember to update manually once a day & pause the auto each time,,,, you should be good to go)

Journeyman III

I have been suffering with the same problem for a year now. 

I want to add that in certain cases, the crash happens much more often than usual.

Like in Victoria 2 in multiplayer, when you are not a host it happens all the time. Those. unplayable. But I have not had a single crash if I played single player or was a host in multiplayer.

On Yandex maps, it also crashes very often.

I tried to change hdmi to dvi, everything worked without problems, even in victoria 2 multiplayer, but the crashes returned after a week or two.

Almost never happens in big games like RDR2, EFT (But it happens in GTA Online for some reason)

There are times when it doesn't happen for about a week and sometimes several times a day for a week.


VID 20200708 191525 - YouTube

Journeyman III

I may have found a solution.. 

These were the steps

1. Go to your control panel and uninstall AMD Adrenalin software completely. Restart you pc.

2. After that go to and select and download the lastest drivers / Adrenalin software for your gc and install. Restart your PC. 

3. Once you are back on you desktop after performing restart, right click on desktop and open the AMD Adrenalin software. 

3.1 Go to settings and perform a Factory Reset. 

3.2 At the settings make sure that check for updates is set to manual.

(this is what worked for me I believe)

Additionally I left all the settings as the factory default except for one. At the Global Display I have set my GPU scaling as enabled. 


I really hopes this helps some people cause I have had this problem for several years and I know how frustrating it can be.