Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

MSI B550 Tomahawk and RX6800 BIOS Issue

Good day to you who reads this, i have pasted the conversation with MSI Support so i don't have to write everything again:

Good day,

i have bought a new GPU a few days ago and with that GPU i cannot enter BIOS. I have tried every DP and HDMI slot and the same thing is happening. I tried another monitor, the same thing. I have inserted another GPU RX5600XT into the motherboard, set the BIOS to default values, and the same thing is happening with RX6800 (With RX5600XT the BIOS works normally). I have tried to place the RX6800 into Asus motherboard and the BIOS shows normally. I updated the BIOS to the latest version (in the pictures attached is the old BIOS version) and nothing changed. I have tried everything that comes to mind and nothing worked.. To be clear, the GPU works in windows fine without a hitch, games and everything, latest vBIOS is on the GPU. I found only one similar case on the forum from linustechtips, but unfortunately no one answered or helped ( I contacted ASRock support, but they couldn't help me, they said that they don't have a B550 Tomahawk for testing.

With kind regards,
Check File Check File Check File Check File
Last Post : 2022-12-19 16:53:00/Create Time : 2022-12-16 15:38:
Dear Danijel ,

Thanks for contacting MSI technical support.

Regarding your concern, please try the following steps:

1)Please adjust the CSM/UEFI option to CSM in bios for a try, can it work in CSM mode?

2) Please check the DP cable, is it DP 1.3 or DP 1.4?

3) Please check the monitor, if it supports G-sync / FreeSync, please disable them.

4) Please adjust the resolution of monitor after you enter to bios for a try.

Thanks for your cooperation in advance!

Best Regards,

MSI Technical Support Team

Last Post: 2022-12-16 16:14:39
1) I did try that, but it didn't help, i set it again to UEFI because my OS is in UEFI
2) I don't believe that the cable is faulty, with RX5600XT and RTX2080TI it worked fine, i tried to connect the same monitor with HDMI cable and it is the same
3) Monitor is Acer Predator XB271HU, it has only G-sync and it cannot be turned of in the monitors menu
4) I cannot "enter" the BIOS thus i cannot change the resolution, i can only force shutdown the PC when i enter with the button on the PC case, you can see on the picture that it shows a few things on the upper left side of the screen and that is everything

My guess is that this is simply a problem/combination with only MSI BIOS and ASRock RX6800 GPU. Every other combination works, other GPU (RX6800XT and RTX2080TI) works on this motherboard (B550 MSI), and other motherboard (ASUS PRIME B450M) works with RX6800 GPU
Last Post: 2022-12-16 16:40:19
We do not mean the cable is faulty, if the cable version is too low, please try the DP1.4 cable. About the resolution, is there any button on your monitor, please adjust the resolution by button. And when you check the issue, please remove all SATA/M.2/USB device, only connect with a USB keyboard for a try. If your graphics card has new vbios, please also update the vbios to latest version.
Last Post: 2022-12-18 14:46:25
I have tried to connect 4k 60hz tcl tv and a samsung b2240w samsung monitor with 1680 x 1050 resolution, both with Premium High Speed HDMI Cable (18Gbps bandwidth), the same thing is happening. The later i have done with everything plugged out of PC, including sata cables. I have the latest vBIOS for GPU, L05 is the version of vBIOS, an the latest version is L04 on the ASRock website.
Check File Check File
Last Post: 2022-12-18 16:40:35
From your description, we are really sorry, this problem may be caused by the high resolution of graphics cards and monitors. It may not occur in all monitors and graphics cards, but it usually occurs in TVs and high resolution monitors, some NVIDIA graphics cards have fixed this problem by updating the firmware, if user takes different graphics card or monitors(not TV or high resolution monitor), this problem may be improved, we have reflected to the relevant department before, but it is hard to be fixed by bios.
Last Post: 2022-12-19 08:17:54
But if it is caused by the high resolution of graphics cards and monitors, why does it not work on b2240w samsung monitor with 1680 x 1050 resolution?
My problem right now is that if i RMA the GPU or MBO and receive a new GPU and MBO i will have the same problem, what should i do now?
Can you maybe get in touch with ASRock and try to resolve this problem? My hands are tied, i tried everything that i could..
Last Post: 2022-12-19 16:09:47
We are really sorry, as we replied before, it may not occur in all monitors and graphics cards, some users may be unable to access the BIOS or have a blank screen, we have have reflected to AMD before, which is difficult to fix by bios, currently, AMD graphics card does not provide firmware updates.
Last Post: 2022-12-19 16:26:56
I understand, thank you for the help.
What are you suggesting that i do next? Contact AMD?
I cannot RMA the card or MBO because i will have the same problem..
Last Post: 2022-12-19 16:36:40
We are afraid, at present, there may be no better solution. This is a display problem, except for the BIOS display, it will not affect other functions, under system it can work normally. We have also been paying constant attention to this problem, if we receive any solution in the future, we will also provide it to users. Sorry for any inconvenience caused.
Last Post: 2022-12-19 16:48:23
Ok, thank you for the fast replies and help. Have a good day.
With kind regard,
Last Post: 2022-12-19 16:53:00ASRock RX6800.jpgBIOS.jpgBOOT MENU.jpgASRock RX5600XT.jpg

1 Solution
Adept I

Solution to my BIOS issue. Reached out again to ASRock support, they sent me new vBIOS for my GPU, version is 113-EXT800248-L06. And after flashing and restarting the PC i can normally enter BIOS.

Thank you all for the help.

View solution in original post

9 Replies

I didn't read your entire Original Post but from what you are saying you have no video output during POST so you can't enter into BIOS but it does have video output when loading Windows Correct?

I found out some Monitors doesn't have video output if BIOS is set to UEFI Mode but does have video output if BIOS is set to CSM Mode ( Legacy mode)).

I have a 4k LG Monitor witha Asus Motherboard. The LG Monitor ONLY has video output in BIOS when I set Asus BIOS setting to CSM Mode but when I ugraded to Windows 11 I needed to set BIOS to UEFI Mode thus losing video output to my LG Monitor but I still have video output to my 2K Smart SAMSUNG TV.

Recently I purchased (Returned for being defective) a 4K Samsung Monitor and in UEFI Mode I had video output during POST.

Not sure If you tried changing BIOS setting to CSM Mode or not. But if it is set in CSM Mode and still without video output I would check your Monitor cable or Monitor Settings and Radeon Settings and Windows Setttings.



Thank you for your reply. I have tried CSM, the same thing..

I tried HDMI cable and another monitor with 1680 x 1050 resolution, without gsync or freesync and with 60hz, same thing.
Tried with TCL tv 4k, same thing..

On the pictures in the original post i used DP cable.


First AMD doesn't support G-Sync as far as am aware of. AMD supports FreeSync. So G-Sync should be automatically disabled:

Unlike Nvidia G-Sync Compatible monitors, which often (unofficially) works with AMD Radeon GPUs, G-Sync is unique and proprietary. It only supports adaptive sync with Nvidia graphics hardware. It's usually possible to switch sides if you own an AMD FreeSync or Nvidia G-Sync Compatible display.Jul 15, 2022

G-Sync vs. FreeSync: Adaptive sync gaming monitors explained › Accessories › Feature




Reading further your contact with MSI I seemed to have repeated some of the tips they mentioned especially putting BIOS is CSM Mode.

Since you both tried Non-G-Sync Monitors/TV with the same results it Sounds like you may have a defective MSI GPU Card unless you get video output once Windows starts loading. Otherwise I would RMA it to have MSI check the GPU card and see if it needs to be Repaired or Replaced.

NOTE: Best way to eliminate your PC as the problem and verifying it is the GPU card or Monitor is by installing your MSI GPU card in another compatilbe PC or take it to your local Computer shop and have them install it and see if they get the same results.

When I was having issues when I first upgraded from a AM3+ PC to a AM4 Ryzen PC I also didn't have video output in BIOS. Finally I took my GPU card to a local computer shop who installed it in a motherboard and it works flawlessly. But I had the same issue when I got back home. So this time I took my Tower to the same computer shop with the same results. It worked flawlessly.

I now knew that the problem was either my Monitor Cable or Monitor itself. That was when I realized that I was able to get video output in CSM Mode or to my  TV in UEFI Mode.

EDIT: Luckily the local computer shop didn't charge me a fee to check my GPU card and PC since all he did was just installed it in a working motherboard or connected a Monitor. I still paid him $30.00 as a tip for his generosity and help.


Thank you for the reply.

Long story short, GPU and MBO that i have:

GPU - ASRock RX6800 Challenger Pro 16GB OC

MBO - MSI MAG B550 Tomahawk

Cannot enter BIOS with ASRock RX6800 and B550 Tomahawk (Pictures in the first post)

I can enter BIOS when i plug in ASRock RX6800 into Asus B450 MBO (I have that MBO at my workplace)

I can enter BIOS when i plug in ASRock RX5600XT into B550 Tomahawk (Pictures in the first post)

So the only problem is the combination of ASRock RX6800 and B550 Tomahawk. And i can enter windows os and play games and use the pc without a hitch or any kind of problem, only the BIOS is how it is..

And if i RMA MBO or GPU i will have the same problem.


Thanks for the update.

Yes I mentioned to RMA unless your get video output to the Monitor when it is booting into Windows.

Personally the way you described the issue in your last reply it sounds like a MSI BIOS issue that isn't 100% compatible with your RX6800 GPU card or your ASRock RX6800  vBIOS isn't compatible with the MSI Mobo BIOS.

I know how you feel about not getting video output during POST to enter BIOS. It is crucial that the User has access to BIOS to enable or disable important BIOS Settings to get your PC to boot up and run correctly.

NOTE: In MSI Forums many times the Moderators offers BETA BIOS (Not yet listed under BIOS downloads) to MSI Users to test to see if it fixes whatever issue they are having.

So i would open both a MSI and ASRock Forum threads to see if anyone else is having the same or similar issues.


Yes, you are right.

I have already wrote to ASRock support before i wrote to MSI, and they said that i should RMA the card, that was their answer..

And MSI said that that is the problem of AMD, and that i should contact them for futher support.

Im just disappointed at this point..

I have found only one same case of this problem, and the guy had a b550 gaming plus and asus 3060ti and the same problem, so it looks that this is the problem of MSI boards, i believe.

Adept I

Solution to my BIOS issue. Reached out again to ASRock support, they sent me new vBIOS for my GPU, version is 113-EXT800248-L06. And after flashing and restarting the PC i can normally enter BIOS.

Thank you all for the help.


Would you be able to share the vBIOS version or a place where someone could download it? I contacted ASRock about a similar issue except I can't boot up the computer anymore even with a flash drive with a new BIOS version on it. They asked me to resit my GPU in a different PCIE slot or they could get me a new card if they found it to be defective(I don't want to do this since I would have to go weeks without a card at all). Any advice would be great! I did manage to get the computer working for about a week when I updated the BIOS with a flash drive while connecting with HDMI instead of DP. But now its back to being unable to boot up with a display signal.



i shared it on my google drive. Here is the link:

This is vBIOS for AMD Radeon RX 6800 Challenger Pro 16G OC

Version is 113-EXT800248-L06, hope it helps.