Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Minecraft is not using my AMD Graphics card instead using my Integrated graphics card

Hello everyone. 

I've noticed that I've been getting terrible performance on Minecraft and have narrowed it down to the fact that Minecraft is not able to switch from the Integrated graphics card to usisng my AMD Radeon Graphics card. I will leave my specs and software versions at the bottom of the page if you want to skip to that.

I've tried many other 'solutions' in other threads on multiple forums but unfortunately they all lie with the same problem that they're either too old to be compatible with the current version of Radeon Settings or don't actually answer the issue. (upgrading my drivers or disabling integrated graphics. I have updated my drivers and I'm not going to disable my integrated graphics because they're used for other software that are always open.) 

Do notice that the Minecraft launcher is different from the actual minecraft game. The Minecraft launcher has been detected by the graphics card and I believe it's powering it but the actual game is powered by the integrated graphics card. The Minecraft game is a java environment which when I added it to the Radeon Settings showed me that it was another game called Jedi Academy or something along those lines. Even when Minecraft is running, the graphics card it uses is still the integrated one after adding the Javaw.exe environment to the Radeon settings.

Does anyone have any suggestions or fixes of their own? Thanks in advance. 

- Note that I have a Dell Inspiron 5567 laptop. 

 Graphics Chipset
AMD Radeon R7 M440

CPU Type
Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz

System Memory
16 GB

Radeon Software Version

Radeon Software Edition
Adrenalin 2019

1 Solution
Journeyman III

Exactly the same issue. Previously I could enter radeon additional settings and force java run with AMD card, but now with the new driver this feature no longer exist.

Edit: I fixed the problem. Try to find your java.exe and set it to high performance mode. See here:

View solution in original post

16 Replies
Journeyman III

Exactly the same issue. Previously I could enter radeon additional settings and force java run with AMD card, but now with the new driver this feature no longer exist.

Edit: I fixed the problem. Try to find your java.exe and set it to high performance mode. See here:

Thank you so much! It worked! 

For anyone who may stumble upon this thread with the same problem: This is what you do 

Go to your Switchable Graphic then click on 'Running applications' and switch over to 'Installed Profile Applications'. Then click on add application then browse. 

Minecraft > Install > runtime > jre-x64 > bin > javaw.exe 

Click on javaw.exe and you'll add it to your switchable graphics section. That's all! Just make sure it's on high performance and you're set. 


Adding on to what you said. I had set java.exe. javaw.exe. Minecraft.exe. And a whole bunch of things to high performance in the graphics settings. It wasn't using my dedicated gpu still. If this helps anyone. I remembered doing research on this in the past and I checked my power options and set my power plan to high performance (Actually ultimate performance). Thus switching from those settings that focus on power saving and probably overwrite the command to use the dedicated gpu in my case.


I have an updated Radeon Software, and I added the javaw.exe, but it still uses the integrated GPU instead of my AMD GPU, while I try to add another app, it uses the AMD GPU, like for example, I add and opened up Minecraft, and it's using the Intel UHD Graphics GPU, while I add and open Roblox it's using the AMD GPU, which is weird, but I already updated the OpenGL and stuff, but it still doesn't work! I tried via the Settings app, it also doesn't work, help me pls

 Graphics Chipset
AMD Radeon (TM) 625

CPU Type
Intel(R) Core(TM) i7-10510U @2.30 GHz

System Memory
8 GB

Radeon Software Version

Already solved. I used the settings in windows to add the javaw.exe to use AMD graphics and it did work


Im having the same problem.  I tried going into Windows 10 Systems Display Graphic Display

and set minecraftlauncher to high performance (radeon rx560)

then i went into catalyst and set minecraftlauncher to gaming mode.  Since they removed the

function of switchable graphcs.

Result:= 1 fps  (F3 shows its using Vega 8 integrated)

Then I went back into Windows 10 systems graphic display and set

jawa.exe which is the java platform running  and set that to high performance (radeon rx560)

Then went back into catalyst and set jawa.exe to gaming performance mode.

Result= 1 fps (F3 shows its using Vega 8 integrated)

? What do I do now?



I got it to work !

--I uninstalled Minecraft completely using Revo.

--Then reinstalled it.

made sure java and javaw  were set on high performance in windows 10, settings graphic settings.

ran minecraft.

Now fps is from 45 to 55 which is better than 1 to 25 fps.

Odd tho F3 shows its using integrated card? but it can't be since frame frate is much higher?

Still 45 fps seems a bit low for Radeon Rx560?

Oh well its better.


Wups maybe I spoke too soon.

for some unknown reason frame rate dropped back to 1 to 2 fps while playing, lasted

for about 7 min, so i logged out.  Not sure why it seemed to go back to slow frame rate?

Anyways, Ill keep trying to fix this.

It would be of great help if you could tell me what fps you get in Minecraft. I am currently getting ~35 and have the same setup as yours. A few days ago it was hitting ~ 55 fps and now it doesn't. 

Could you help me with it please?


Starting Windows 10 17093 the switchable graphics are not controlled in the Radeon Settings as AMD dropped support because it is now controlled by the Operating System.

This page will show you what to do:


Good Luck!


i am using tlauncher but i am not able to use my amd radeon graphic cards



i am using tlauncher but i am not able to use my radeon graphic card



I saw the release notes for 20.3.1 but there is no mention of fixing the Minecraft java

problem? and it recognizing dedicated gpu?

Adept I

This has become a problem for me recently, I bought an Acer Nitro 5 with a 560x which does really well in most games, but since the 2020 drivers I can’t set Minecraft/java to high performance.  I just tried the most recent 20.4.1 and now I’m reinstalling 19.12.1 where I can still set javaw to high performance and Minecraft works fine.  Anyone else dealing with this?

Journeyman III

I was having this issue lately too, after poking around for a while and looking at other sources I found a solution that seems to work for me.

As stated previously using windows built-in Graphics settings you can force the applications to use the graphics card. The main applications that you are looking for are java.exe and javaw.exe.
You can find these files in a number of places:

For modded using the lastest Curse Forge launcher by Overwolf:

(jre-legacy is probably the one you are looking for as they said they would continue to use the legacy launcher)

The latest (recently updated) Minecraft Launcher from Mojang:

Feel free to add any other locations there might be as the install locations have changed from launcher to launcher
The legacy win32 launcher and I believe one older version exists. To find out where these files are just launch the game, open task manager and right-click the Java(TM) Platform SE binary program, and click the open file location to find out where it is running from.

You want to set those to the High-Performance setting.
-As of writing this may be optional.

In order for these files to be configured using Radeon, you have to go into your Radeon application and add the javaw.exe and maybe the java.exe files to your game, in the Gaming tab. To add a game go to the said tab and look for three dots on the right, click them. and press "Add A Game..."

You can then configure the game however you wish, with the exception of the "Anisotropic Filtering" setting, which you want to disable, This setting was causing white borders around blocks, which has to do with the texture filtering.


Also, the Anti-Aliasing setting needs to be set to "Use application settings."
And just finding one version of the file seems to set correctly for all other locations, so only one is needed in Radeon and only the javaw.exe file is needed.


that's a basic thing to do if u want to force use of gpu. Already did all of this and nothing is working, my integrated is giving me around 80-90 fps but after a while of playing the screen starts stuttering. I have tried vsync and all the video settings and they didn't work so i'm lost. any ideas?


The in game settings are not going to enable/disable gpu usage. From what I can tell it could only be a driver issue, I would make sure other games use the gpu. I would also make sure you have a currently supported gpu. I do not really see why the gpu would not be recognized and use for minecraft by windows if you followed the above steps. Therefore, it would have to be either the gpu itself or the game. Minecraft java can be a bit finicky to work with due to its age too.