cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Draxirch
Challenger

KINGDOM HEARTS Crashing Issues on ASUS ROG ALLY. (ON GOING ISSUE SINCE JUNE NEEDS TO BE ADDRESSED!!)

Hello,

So I bought the ROG ALLY back in November and I was so excited to play Kingdom Hearts on this device but then I ran into crashing issues and its very easy to consistently crash in KINGDOM HEARTS 2  just play the cutscene with Kairi and Selphie on Destiny Islands and you will crash EVERY time the camera starts panning to the island. You can also crash very easily by pausing and unpausing sometimes.

The nature of the crash is the game will freeze, and then the display driver will crash resulting in a blackened screen, sometimes it will fail to recover and you will need to power off the system to restore your display driver, this worries me as it could potentially cause huge issues in the future.

This issue has been known since June 2023, the release date of the Rog Ally, I think this issue seriously needs to be addressed it is game breaking and I guarantee that people will not want the Rog Ally if they can't enjoy KINGDOM HEARTS on it.

This does not happen on KINGDOM HEARTS 3 mind, but it happens on the REMIX collections.

Please we ask for your assistance and help on this matter, we need a driver update to fix the Display Driver time outs.

I really want to enjoy KINGDOM HEARTS in 60 fps portable, that's all i want, everything else works fine except for FINAL FANTASY X HD REMASTER (weird graphical bugs) and KINGDOM HEARTS (Impossible to play as it crashes way too frequently.)

Kind regards to the AMD community

Draxirch

P.S. I have reached out to Asus Directly via a ticket but they're just saying to reset to factory settings or to send it in for repairs, which I think will not resolve anything this is a DRIVER ISSUE. not a HARDWARE ISSUE.

0 Likes
1 Solution
Draxirch
Challenger

Play it at 720p.

Set Refresh Rate to 60hz.

Turn off AMD RSR.

Turn off AMD RIS.

Make sure Freesync is off in Adrenaline and Turn off Refresh Rate in game and lock FPS to 60. Play game in Borderless. Using these settings I haven't crashed at the usual places since, so I'll close this call off, this is a workaround but also a solution.

Hopefully AMD may still fix it crashing more on higher resolutions though. It still crashes at times but it is significantly less with the above settings.

Make sure you're on 23.12.1

Update: I still crash randomly at times. Ugh... this is just saddening.

View solution in original post

0 Likes
4 Replies
Draxirch
Challenger

I swear I'll get this issue more noticed, we the Kimgdom Hearts fans want a smoother experience, help us AMD please!

I don't really want to buy a Steam Deck yet but if left unresolved I might have to do so... they report no issues except some FMV crashes with KH2 Refined but that's a mod so that's something different.

I was told that turning off Vsync and Refresh Rates can make it crash less and yes it is true to an extent but it is NOT classified as a solution.

 

It would make my Christmas if this issue was addressed soon. All we need is someone to look at why it crashes and issue a driver update to the Ally via Adrenaline.

Please also note that I am using the latest drivers for AMD Adrenaline, and no new updates have been issued under MyAsus yet in this matter. I'm beginning to think this issue might never be resolved...

Draxirch
Challenger

For all we know, the new driver 23.12.1 might already have fixed this issue but we are just waiting for the driver to come across to the Rog Ally.

But I'm not holding my breath, I'll be saving up for a steam deck soon JUST so I can enjoy KINGDOM HEARTS on the go and not on the abysmal Cloud Versions on Nintendo Switch.

Update: Asus confirmed we will have to wait for AMD or Square Enix to fix this. Its all a waiting game now.

0 Likes

Driver update 23.12.1 does not fix this issue at all.

Please AMD, notice this issue and issue a fix please!

You've fixed Finsl Fantasy X which is great but can't you please do the same with Kingdom Hearts?

0 Likes
Draxirch
Challenger

Play it at 720p.

Set Refresh Rate to 60hz.

Turn off AMD RSR.

Turn off AMD RIS.

Make sure Freesync is off in Adrenaline and Turn off Refresh Rate in game and lock FPS to 60. Play game in Borderless. Using these settings I haven't crashed at the usual places since, so I'll close this call off, this is a workaround but also a solution.

Hopefully AMD may still fix it crashing more on higher resolutions though. It still crashes at times but it is significantly less with the above settings.

Make sure you're on 23.12.1

Update: I still crash randomly at times. Ugh... this is just saddening.

0 Likes