Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Heavy stuttering in League of Legends with RX 6400


I've stumbled upon this problem with my brand new RX 6400. I brought a RX 6400 about two weeks ago and the first week was really smooth sailing, it was an upgrade from my older graphic card and thus, I've downloaded and tried games that demanded heavily from GPU, like detroid: become human, GTA V, Final Fantasy XIV and they all are played without any issues. But as soon as I tried an less demanding game as League of Legends, that was always 144fps smooth with my old RX 570 now it is hardly playable.

The issue is, at the start of the game, when there are almost two minutes of nothing happening on the screen my fps, if I uncap then, will go up to 200-300, but as soon as the minions clash my fps already drops bellow 144 and as the game progress and in game effects become more present, the fps hits numbers below 60fps, all with massive fps ossilation, or stuttering, going from 200 to 20, then back to 200 again. (and as the game progresses and the new fps celing is lower it will bounce back it, from 100 to 20 then back to 100, from 50 to 20 then back to 50 again, and so goes on).

My specs are:

MOBO: Gigabyte B450M DS3H, AMD AM4, mATX, DDR4
CPU: AMD Ryzen 5 1600, Cache 19MB, 3.2GHz (3.6GHz Max Turbo), AM4 - YD1600BBAFBOX
GPU: ASRock Radeon RX 6400 Challenger ITX, 4GB, GDDR6, 64-Bit, 90-GA3CZZ-00UANF
RAM: 2x HyperX Fury, 8GB, 2666MHz, DDR4, CL16 - HX426C16FB3/8
PSU: Corsair 550W 80 Plus Bronze CX550 - CP-9020121
SSD Kingston 2.5´ 480GB UV400 SATA III
operational system: Windows 10 Pro 64 bits
monitor: AOC Led 24´ Widescreen 1ms 144Hz VGA/HDMI/Display Port G2460PF

Something to be taken in consideration is: this GPU have PCI 4.0 and my MOBO only PCI 3.0, but I've made some researches about the performance on 3.0 and it was calculated something like 15-20% fps loss.

Possible solutions that I've already tried to fix:
- Update Drivers
- Update BIOS
- Update windows
- Downgrade BIOS to prior versions (Fresh install with DDU)
- Enabled Windows Ultimate Power Plan
- Tried almost everything in Andrenalin, dozens of combiations V-sync on, off, shaders, etc, etc.
- Of course tried to change the graphics in game to almost every possible combination too, high, low, medium, anti aliasing on, off, v-sync, directx 9, 11.

What I would like to know is, should I RMA this GPU or is it something like driver incompatibility, direct x fault or something else?

2 Replies

First, disable Windows 10 gaming mode, and then watch this video and make the changes, and see if it helps:

Journeyman III


I had the similar problem to yours. You need to log into your lol client, click settings (next to the X button),  go to GAME section and click  Prefer DX9 Legacy Mode (Turn ON). I used this option and it helped me.