Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

Half-Life: Alyx Blackscreen Problems (Radeon VII)

I am experiencing frequent blackscreening while playing that doesn't seem to correlate with any specific gameplay actions. This doesn't happen in intervals but rather at random times leading me to believe this is a graphics card or driver issue.
The longest I've been able to play consecutively is 30 minutes.

The GPU drivers are the latest release (20.3.1 release for Doom Eternal and Alyx).
The blackscreen will lock up the system and requires a reboot.

I am playing on the Oculus Rift S, and everything is up to date.

My Specs:

AMD Ryzen 7 2700x

16GB 3000MHz RAM
AMD Radeon VII
MSI Tomahawk B450
1TB WD Blue SATA m.2 SSD

A similar issue occurs everytime I (try to) play The Labs Robot Repair (Source 2?).

119 Replies
Journeyman III

I also have this exact same issue with Half Life Alyx and my Oculus Rift S. 30 minutes of gameplay maximum, with other times it crashing immediately after loading into the level, or at other random points during gameplay. Everything is also up to date on my system as well, and I have even tried reinstalling Windows and using DDU several times to reinstall various driver versions. Windows Event Viewer doesn't seem to say if anything went wrong either with Half Life Alyx. Previously, I did get a Bugcheck with code 0x0D when a similar hang appeared to occur with Robo Recall, but here, there is no error code. I also believe this is an issue with the video/graphics drivers with VR games/applications at this point and should be very easy to reproduce.

AMD Ryzen 3900X (formerly 3600X where issue occurred with Robo Recall)

16GB 3200MHz RAM @ 3000MHz

Asus B350F STRIX Gaming

AMD Radeon VII

Look at my latest answer

Journeyman III


I've experienced same issue with my radeon VII on the soliuce project game with my oculus rift.

black screen randomly and in some area, very frequent, unplayable, crash every 2 min.

Downgrade my amd driver to march 2019 has solved my problem. The first ones drivers for this card are very stable for me, i can't says that's for 2020 drivers series....

Drivers of amd in 2020 for this card seems very bad, it's not serious for amd.

This has sadly not fixed my Problem, the old drivers were installed after a DDU and Alyx keeps crashing.

For a 700€ GPU this is a sad display of instability that does not make me more inclined to buy Radeon products.

Adept I

I am also having this issue. I bought this card specifically for VR and Ultrawide purposes.

Radeon VII

Ryzen 7 2700x

32GB 3200 Mhz Corsair Vengeance RGB

Asus Prime X470-Pro

I have had instability issues across the board in many games, that have only gotten *worse* with newer drivers! I've had to use drivers from mid november to not crash every one-two hours. I have upgraded to 20.3.1 for Alyx.

It seems that whenever I change altitude the graphics card and at random intervals, the card just stops responding. On game start it also says that there is a "lack of VRAM available - this may cause issues" which doesn't make any sense considering the copious 16 GB of HBM2. This issue persists with an earlier version of the drivers.

Fix this please. I am thoroughly unimpressed. Support for the Radeon VII has been extremely disappointing.

Adept I

I am having the exact same issue.

ASRock B450

Ryzen 7 2700x

Vega 64

Depending on where it's at, I can play 5 minutes to 5 seconds.

That's actually rather interesting. So it seems like more of a Vega issue than a VII issue.

That does increase our chances of getting it patched.

Adept II

Glad I've found this thread. For almost two weeks I'm trying to make my HP Windows Mixed Reality to work with my Vega 64. I did a lot of things, disconnecting one monitor, reinstalling everything, even pulling out my second Crossfire GPU. Just when I was about to return the thing I decided to try borrowing a GTX1070 from a friend of mine, and it worked. At least I was getting picture from his card, even if it was glitchy, the headset appeared in my device manager and after hitting driver update everything worked fine.

I put back in my Vega 64 again, WMR portal works, but I'm not getting anything through my headset, its all black, no matter which of my two GPUs is in the system at the moment. I saw the text on the portal saying I'm in the desktop mode, but even after hitting the shortcut keys for the VR view I'm not getting anything...

Adept I

So I was able to fix my issue. I had noticed during gameplay, usually when I am getting into a corridor and I suspect the game is swapping out resources for the next section of game, it would start to artifact in the headset. Just random blips of color in the headset. I actually thought all along this was my Vive headset cable as I've noticed this for a long time. It would very occasionally crash with other games. Black screen, dead for 20 seconds and then come back. I would have to restart to play anything else. Not until Alyx did I put the two together and it was very repeatable. The artifacting would start just before it crashed. I would have other VR games that would do this occasionally but rarely crash.

I was able to actually fix the problem by going into the performance settings and drop my VRAM speed from 945Mhz to 900Mhz and I set my GPU clock to -10%. After that, the game plays perfect and the artifacting is gone. It kinda sucks my GPU is bunk, it's outside of the warranty period. Its been doing this since I got it. I wonder if I can re-paste it and get the performance back up. I suspect something is weak in my card though. Might not be worth the risk of breaking it.

So it started doing it again tonight and I figured I'd try the repaste. It didn't do anything. I tried cranking my fan up to full tilt. Still crashed... but then I realized somehow Half-Life Alyx had ended up with it's own profile with the normal settings. When I clocked it back down to the settings I had before it was good. So it appears to have nothing to do with heat, it's just my hardware is not up to the task and maybe it was just binned incorrectly. Kinda sucks, but at least it works.

Adept I

Same here. Alyx has been black screening quite a bit. Sometimes though the it's a blue screen on just the VR headset. In that case the whole system won't crash and it'll eventually get back to the desktop with error messages from steamvr and wmr. When it's a black screen in VR, both the headset and monitor go black with the audio still playing before the computer just reboots. However, I've been having the black screen issues for a while even without VR when doing simple things like browsing the web or with more demanding stuff like rendering videos. VR, at least with Alyx, makes it even worse.

To me it ocassionally happens with other titles as well, although that has been rare. Blade and Sorcery tends to crash every now and again, and Pavlov has done it before too.

For me the audio keeps playing as well and the picture in the headset remains still without positional tracking which drags the stillframe around in front of your view when you move the head. That indicates to me that the Oculus software is still tracking but it's not getting through to the GPU. At that point the PC needs a reboot.

It's a rather nauseating feeling.

Adept I

The problem is not with the Radeon vii, but eather steam VR or the app for the head set. I tried with the GTX  1070, the Radeon vii and the R9 390 on 3 different PC's and all does the same, crashing all the time. Black screen on headset and monitors and then comes back a few seconds later telling it lost connection to headset.

Thanks for the post. Nonetheless i will ask engineering to take a look at the issue just in case. 

Could anyone confirm if they have a browser open in the background when the issue occurs?

Happens with and without a browser open for me.

Problem for me personally is that I didn't even get to play the game. I saw people playing with the HP WMR, but they are having a 5700XT. WMR portal seems to track but I don't get anything through the headset. I was getting with a borrowed GTX1070. Didn't try the game yet because I'm also having issues pairing controllers with bluetooth, but that's Windows related. Again, its Vega 64 here. I'm having two and its the case with both of them.

I have had this issue occuring both with and without Opera running in the background.

I do agree that the issue might lie with SteamVR and/or Oculus, it doesn't necessarily need to be an issue on AMDs end. I have also posted this in the HL: Alyx Steam discussions, but it didn't resonate.

On Reddit I got one response with the same issue, also with a Radeon VII and a Rift S so it might well be an Oculus problem. That would be bad as Oculus/Facebook isn't likely to listen.

Edit: I don't get an Error Message upon crashing, just a straight up loss of video signal on both monitors and the headset.


I do know that I made a deliberate effort to close all browsers before plugging in the VR unit as I had read that the browser hardware acceleration may contribute to the issue. Despite having the browsers closed, the black or blue screen crashes happen in VR. I do know that the Radeon VII does the black screen crash occasionally when I just am browsing the web without the VR headset plugged in. I feel like it typically happens when a video is open, though I could be wrong about that. 


Also, I have a Samsung Odyssey +, so I don't think it's just an Oculus problem.


Could you look into this more to see if you can provide accurate steps on how to reproduce the issue?

We were able to reproduce the issue with Half Life Alyx and the Oculus S. However your issue with regards to browsing and a black screen is likely different. 


So it just happened. I am running Folding@home. At the same time I had chrome open with a video playing. However, hardware acceleration was disabled in Chrome due to advice I had received about disabling it to prevent black screens. I then enabled it to see if I could recreate the black screen issue with browsing. About 10 seconds later, the screen went to black and rebooted. Now that the computer is rebooted and hardware acceleration is already enabled, it seems to be doing ok for now. But will update you if it crashes again.

I know in the past I was also having problems with renders in DaVinci Resolve. It would happen randomly though. I'll see if those issues have persisted in the latest driver set as I have not rendered anything since updating the drivers.



Crashed again. This again was with Folding@home open along with Chrome with hardware acceleration enabled.


@agoman Interesting that it happens with your other cards as well. I got a 5700XT to use after my Radeon VII was giving the black screens and not once did I have a single black screen hang/issue with my 5700XT. That card does stutter however, and glitches out when pulling up SteamVR or Oculus menus, but I played from Ch5-end of the game without issue. 

My friend with a GTX1070 also finished without any issues, though he was using an Intel 4770K. 


Im running i5-4690K on 2 pc's and one with ryzen 5 3600, I swaped all 3 cards around in all 3 pc's and the same result on all of them. But if u serch the net of the problem with Alyx crashing, it's on all model VR headset og all kind of GPUs I guess some are just lucky to get to play the game and then there is us who are not

Adept II

The same issue here as well, anywhere from 45 seconds to 10 minutes Black screen and the system locks up and restarts. I also get the same issue in the new Modern Warfare although the minimum time for it to happen is 45 minutes. No overclock on anything.

R7 1800x

MSI X370

Radeon VII

32gb @ 3200mhz

I have tried underclocking my GPU and increasing the virtual memory with only the virtual memory increase bringing my playtime to about 25 mintues.


With patch 1.2 I seem to be able to play for 90 to 120 minutes.


Tried playing 2 days ago back to around 30 minutes before crashing.


Have the same issue with Radeon VII and COD MW. Blackscreen after 30-40 min gaming.


COD on the current version will crash within 5 to 10 mintues for me on my VII especially the warzone mode, while the Vega 64 just did a 2 and half hour session no crash nothing wrong.

Just Installed the 20.5.1 driver and now am getting near instant blackscreen with the system locking up in the occt memtest, where as before with 20.4.2 non-WHQL version [ Never tested the WHQL one] there were no crashes. Although windows will recover in about 5 mins and occt will report the driver crash. Windows event viewer reports that amdkmdag has stopped responding and then has successfully recovered. This is happening on a Vega 64 will test the VII later.

I'm gonna try games on the 20.5.1 version, but one thing for sure is that overdriventool isn't working anymore. 

Wattman overclock is not applying my overclocking whatsoever on the core. 

i'll edit later


Are you sure you have "global settings" selected instead of a specific application?


I put my VII back in and OCCT is causing the same memtest crash, while the Vega 64 could not launch COD without the dev error crash and causing my system to freeze up afterwards. The VII can launch and play COD so far for 1hr 1/2 to 2hrs with no crashes so far. And I also done a couple stress tests with 3DMark with no problem.

Btw for 20.5.1 version they also mentioned in the release notes they fixed crash for Red Dead Redemption 2 when internal intel graphic card is enabled in BIOS. It's a total lie. Crashing continues, I can't play RDR2 without disabling igpu in the bios.
About COD: MW + Warzone
Also I tried to use default settings, increased fan speed, decreased memory frequency etc.. - nothing. Blackscreen in 40m - 1h. @AMD It's not possible to use your graphic cards in games.

@AMD I'm ready to send you any dumps, logs, just fix this. 

This is entirely inconsistent. I couldn't play more than 30 mins the other day without a crash. The next day I played all day with no crashes, no driver updates or anything...

There's something really funky going on here. AMD really needs to work with us on this instead of telling us to RMA and end up just getting the card shipped back because it's "fine" 

From the latest AMD Driver Release Notes concerning Known Issues:

I suggest to open an Online AMD Service Request to let them know of the Black-out issues so they can find out what is causing it in certain User's computer setup from here: 

Adept I

This is not an issue with this driver but with all driver that came out since 2020 i.e drivers 20.x.x. 

I have been using Radeon VII since 09.2019 and everything was stable with these releases. Currently im still using 19.10.1 as it gives me the best performance with no tweaking needed. Also why would i not want to use enhanced sync and disable the vsync in game? the difference in FPS especially when using a projector for gaming is stupendous. (we are talking unstable 40-50 fps in doom eternal against 200+ with vsync off)

anyway alyx runs great but it is outrageous that a flagship card that cost A LOT! of money gets no support whatsoever. 4 months into 2020 and still can not update. If anything it taught me to stay with middle range cards like the RX480 (which i upgraded from) that ran flawlessly for 3 years and did not burn a hole in my pocket.

My only hope at this point is that either AMD will pull a bunny out of their hat or just admit that they released an overpriced and unstable card.


was able to finally fix my problem (or at least i think it's fixed) by replacing my old HDMI cable which i have been using since early 2010. (it's 32ft cable which cost me quite a lot at the time and i didnt even think about replacing it as it worked fine for a decade)
Purchased a new 32ft HDMI v2.0 and so far i have had no issues with the latest driver. can even use OC functions and Enhanced Sync.
Its been 2 days since i have began using it and everything works flawlessly.
For comparison with the old cable i have never even got to 12 hours of stability, not to say 48 hours.
will update again in a week.
If you are using an old HDMI cable you might want to give this "fix" a try as cables are really cheap nowadays.