Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

Half-Life: Alyx Blackscreen Problems (Radeon VII)

I am experiencing frequent blackscreening while playing that doesn't seem to correlate with any specific gameplay actions. This doesn't happen in intervals but rather at random times leading me to believe this is a graphics card or driver issue.
The longest I've been able to play consecutively is 30 minutes.

The GPU drivers are the latest release (20.3.1 release for Doom Eternal and Alyx).
The blackscreen will lock up the system and requires a reboot.

I am playing on the Oculus Rift S, and everything is up to date.

My Specs:

AMD Ryzen 7 2700x

16GB 3000MHz RAM
AMD Radeon VII
MSI Tomahawk B450
1TB WD Blue SATA m.2 SSD

A similar issue occurs everytime I (try to) play The Labs Robot Repair (Source 2?).

119 Replies

So another 2 weeks have passed since my last update here.


I really dont know what is the difference between the 2 cables (HDMI 1.4 & HDMI 2.0 for the GPU) but even after updating to latest 1st of April driver i had no issues whatsoever.

Replacing the cable really did the trick and i could not recommend it more for a cheap fix that is definitely worth the try.

Also OC parameters now stick! even after a PC restart. Same with Enhanced Sync. No Black Screens, No Crashes NOTHING!

Looking at Event Viewer last crash was on 30th of March.

Also another thing that is worth noting:

DO NOT USE! any automatic "Choose when to turn off the display" settings. Or any other option that is shutting off stuff after X minutes of PC being idle. Seems like some processes (Especially in VR) do not get recognized as a process which is using the screen. This CAN cause the game to hang/steam VR crash till you move the mouse again. Which in the headset can seem like a "Black Screen" issue.


are you saying replacing the cable to the monitor stopped you having crashes in VR? It uses its own cable


Correct, but you still have a main monitor which displays the game. also my issue was not limited to VR games but with daily use with the Adrenaline drivers that came out since Jan 2020.

As i said in my previous comment, maybe my cable was faulty, or maybe just old (since i have used it for a decade now) combine this with the incompatibility from AMD drivers resulted in frequent crashes (since up to 19.12.1 everything worked well even with the old cable)
Now everything works with no issues.


I'm not using hdmi for my main screen, but displayport.   Not had any issues playing traditional games like Borderlands 3 - but still having this issue with Alyx.  The randomness of it is the most infuriating part.  

As I think already mentioned, my rift has it's own custom cable.  Don't believe a replacement is available anymore.    Having said that not getting any display problems on the headset anyway.


exactly, every system is a different problem and a different use-case.
It took me lot of troubleshooting and by the process of elimination i have finally got to the point of replacing my old 32ft HDMI cable.
Currently this is what connected to the card and i have 0 issues:

DP1: Projector via HDMI cable (32ft) + HDMI to DP converter
DP2: DP dongle dummy (for headless display, very usefull if i try to connect to my PC with TeamViewer while the projector is off)
DP1 & DP2 are set to Duplicate.

Im just happy that i do not need to RMA this card and the whole "fix" cost me around 30$ (although the total amount of time i spent on this crap since January is much more than what this card deserves and i could easily afford a new 2080 nvidia card by now) 

The word "HATE" is an understatement for my feelings on this card.


I’ve tried 4 different cables and I thought it had worked until today when it crashed again. I don’t think replacing the cable has anything to do with it. I used several brand new cables out their packaging and all with the same results. Sadly this is still not resolved for everyone


Update since my last comment. Ever since i purchased a new HDMI Cable to connect to my main screen i have not been experiencing any crashes or black screens (last logged crash on event viewer is from end of march). Everything has been working without a hitch throughout the last couple of driver updates. currently on 20.5.1.


Displayport here, The new driver 20.5.1 now has it's own weird bug. While I'm no longer black-screening and or full on crashing, Warzone now will freeze and then windows will say Application has been blocked from accessing Graphics hardware around 20 times and I will have to end task. I've never seen this issue before. I've DDU'ed the driver and will reinstall and do some more testing.

Have the same issue in the warzone


Same. Been using 20.5.1 for about a week and started to notice "4101" Warnings in event viewer "Display driver amdkmdap stopped responding and has successfully recovered." These are generated along with a SteamVR crash (which requires me to basically restart the PC). can not pinpoint exactly the cause but for now i reverted back to 20.4.1

and i will keep watching the issue. 20.5.1 is a no go for me. Been using 20.4.1 since June 3rd and errors stopped for now.


So now i REALLY did solve all my R VII problems by just trading it for an EVGA 1080 TI (+ some cash from the guy). I'm just amazed by how well it works, taking into account that its about 2 years older.

Apart from some raw benchmarks where im getting 5-15% (Even on OC) lower than what i scored with the R VII, the whole gaming experience (and frame times) is just far better. Should have done so 6 months ago and save lots of time and headache.

If you are playing VR and ESPECIALLY if you are looking for the best experience for Quest+VD. Go with team green! It took me quite a while to admit that i sunk my money on an under performing card but better late than never.

And on a side note: EVGA Precision X1!!!! HOLY MOLY why tools like these are not a standard in the GPU industry. one click on a button and all OC configuration are auto tested and applied.

Congrats! You're lucky dude. I'm stuck on AMD Radeon, because for my work I need in dual boot system Windows/Mac, and only AMD working well on hackintosh. Before Mojave I was on Nvidia + High Sierra. I'm thinking to buy nvdia for windows and keep radeon for hackintoh, but this solution is not cheap. So this 2020 year too much crappy, and buy one more performance videocard is not easy for me.

Adept I


1. Right click on desktop and sellect screensettings... I think it's called that in english? And u get in to the window as shown below.


2. Scroll down and sellect the setting that i highlighted with red in img below.


3. Now turn on 1 (shown in img) And browse for the game in 2 (shown in img) Make sure its on "klassik app"


I hope it works for u 2??

I'd try it but I refunded the game while I was able to, if someone else with a Radeon VII can confirm this fix works that would be awesome. How did you figure this one out? If somebody else could confirm to make sure it wasn't a one off I'll re-purchase and give it a go.


I serched google for how to fix games going to black screen/crash. And i got into a link that showed me how to. But instate of it working for 5-10 min. it only made me game for 60-90 min before blackscreen came back. An i just tryed it again before writing u and the problem is back again, max 5-10 min gameplay before the blackscreen is back. 

Sry for my non working suggestion

Adept I


I've have been having issues with Alyx on my setup too.


Asrock X570 taichi

32gb 3600 DDR4

Radeon VII

Windows 10 1909

Oculus rift, 4 sensors.

On a few occasions I have been able to play for well over an hour without issues.  Other times it crashes within a few minutes or sometimes as soon as I load a saved game. 

Tried numerous versions of drivers, including latest.

The rift screen locks, then goes black although audio plays for a few seconds.   

On pre 20.x.x version drivers, my main screen comes back on but steam vr says it needs to restart driver, and oculus software restarts.  Checking the windows logs it shows that the display driver stopped responded but recovered, then steam vr and the oculus apps crash and restart.   If I try to bring up AMD control panel all I get is a window outline.  Trying to run any games or benchmarks afterwards results in them running slow.  Clock speeds don't seem to be boost from desktop speeds.  A reboot is required to resolve.

On 20.x.x drivers, rather than the driver recovering, it stays black and the pc reboots after a short time.  Windows states that it crashes and has created a crash dump.  Analysis of the memory.dmp file states that the likely cause of the crash was ATIKMPAG.SYS.

I've done memory checks on my pc and have done multiple runs of 3d mark extreme stress test with no issues.  Using hwinfo shows temps are reasonable, and hot spot is in 90's.  Tried numerous versions of the driver as well as underclocking the gpu and memory on the card but still have issues with Alyx.

I appreciate this may be a game issue and I have no other gfx card to test, by thought I would mention it in this post for information.  Happy to provide additional information or to help with testing if required.  

Also for information I checked the Graphics performance preference option in windows and it is already on "Classic app".



Adept I

Can we remove the “assumed answered” on this post?! This is clearly not answered yet. It’s an issue that locks my whole computer up and causes me to hard reset my machine just to try and take for another 2 minutes before crashing. This is my first time buying AMD and I’m so disappointed with this. I ran a 1070ti for over a year without issue. 

Assumed answered what the, Please remove that. Still crashing here as well.


Ignore it, it's something automatically applied by the forum and there is nothing we can do about it. Unless it says Answered, it's not answered. 

Journeyman III

Hi all,

Thought I'd share that I'm having the same issue on my system. Either full shut down, frozen image in the headset or complete jumbled display in the headset. I notice the game is still playing most of the time since I can hear audio still. But sometimes I've been able to play through 3 levels at a time no problem or it crashes in the loading screen. Weather I have other programs open or not in the background doesn't matter. this is the only vr game that has given me these problems.

Ryzen 5 3600

AMD 5700 xt

Valve index (oddly enough)

Newest drivers 

Journeyman III

I'd also like to chime in here as well. Having similar issues, no version of the graphics driver fixes it. I'm using an HP Reverb device with Alyx however. There's definitely something funky with the VII and WMR + Alyx. I've tried to troubleshoot this for about a day now, and well now I'm posting here about it.

Intel 10920X
Asus Prime X299-A II

64GB DDR4 @ 3000 MHz

XFX Radeon VII w/3 Monitors (144Hz, 60Hz, 60Hz)+ HP Reverb WMR

Windows 10 1909

I've tried 19.5.2, 19.12.1, 20.4.1. Half Life Alyx will randomly crash - sometimes immediately, sometimes within a few minutes. 20.4.1 handles it the crash best - all the other drivers cause various issues or cause my WMR device display to flicker in Alyx. I've also seen Alyx randomly complain the GPU does not have enough memory...which we know is 100% incorrect.

Anyways, the GPU driver itself stops responding according to Event Viewer. The crash symptoms that manifest can vary. Sometimes the HP Reverb will just go blank and then start flashing white like a strobe but audio will still play before the crash, other times it will track but the image will freeze and then the driver crashes. All of these crashes do involve the displays eventually going blank. SteamVR complains it has encountered an error, crashes, etc... Windows recovers, but  acts pretty funky and always requires a reboot to get my machine 100% back to normal.

I'm not here to berate AMD, but this is a "flagship" card that's treated like it's an unwanted adopted step child. I literally stayed on 19.5.2 as long as I could but the only driver that fixed some of the display flickering (seizure inducing) in Alyx has been 20.4.1 for me. This is unfortunately only adding to the negative connotation that is the Radeon VII has in the gaming community at this point, and the fact that AMD hasn't came out and at least acknowledged that the VII has serious driver issues (and it's extremely apparent the 2020 drivers really screwed up the VII compared to the 2019 series) is frustrating. I wish more effort was put into bugs and QAing the released drivers against the VII internally at AMD, because there's no way some of these can be missed.

The VII is a great value and a spec beast, but it's a shame the drivers and general bugs are forever going to taint the reputation of this card.

Journeyman III

I also have this problem! I initially thought it is due to my CPU shutting off at 60C but more cooling and keeping it under 60C didn't seem to help.

It happens randomly sometimes an hour into a session sometimes at startup. Sometimes it crashes to desktop but most times it crashes to a black screen with sound looping and I have to restart my PC.

Specs: Intel Xeon E3-1230v3
Radeon RX Vega 56
12Gb DDR3-1866

Adept I

Same issue here with a Radeon VII although I have seen it happen in other VR games as well and, although less frequently but still consistently on non VR games.

With and without a browser open.

On both Linux and windows... Has to be driver related or possibly hardware

Adept I

Thought I had cracked it!  New bios out for MB (2.80) which I installed.  Recent chipset drivers out - installed.  Upped voltage slightly for mem in bios.

Played Alyx for approx 1hr 45 mins with no crashes.   Played again and after just over 30 mins same crash - display driver stopped responding but recovered, followed by the VR apps crashing.   Monitored temps and everything looks fine. 

Played a bit again tonight and crashed after 35 mins or so.  How it lasted for the long run is anybodies guess.  

Adept I

Possible workaround for Radeon VIi owners.

Install the Pro/workatation drivers instead of the gaming drivers and see if that fixes the crashing. They're built for stability, so they might help here and it would tell us and AMD that this is an issue specifically with the adrenaline drivers. Post if this has affirmative or negative results.



Just tried the 20.q1.1-Feb14 pro drivers, and after approx 20 mins still crashed.    Same issues as before, amd panel only shows outline after etc.   The way it handles the crash is similar to 19.12.1 drivers (i.e. no bsod) but still crashes.


Yesterday tried latest for now Q1 Pro drivers, still crashed. Full driver version in device manager shows that it has version between 19.12.1 and 19.12.2, with all their problems.
I'm going to try other workarounds in this topic

Adept I

Ay what a shame. I'm going to try swapping the graphics into a completely different machine and see if I still get crashes. If so, I will rma 

Adept I

Just tried latest driver (20.4.1) - crashed after 40 mins or so.  Interestingly crashed to desktop this time, change from other 20.x.x I've tried.  Tried opening amd panel and again just got the window outline.  Windows reported "not responding" and when I selected restart application on recovery options prompt, I then got a system crash & reset.  

It wouldn't be so bad if the driver recovered properly and I was still able to use the amd control panel - at the moment even if it doesn't crash and reset, need to reboot anyway to recover.

Probably going to go back to 19.12.1 since I understand there are some issues with video acceleration in chrome and video apps on 20.x.x.  


disable hardware acceleration on all browsers. its always recommended.

Adept I

Similar experience here fiz. Just updated an now the crashes seem more frequent in other games. When the PC reboots, the graphics drivers are in an odd state and until I manually reboot again games are unplayable. 

Journeyman III

Same issue here with the Radeon VII and Alyx. After a random amount of play, from just a few minutes to an hour, the game will just stop responding with a frozen image in my Oculus Rift S headset and the monitor goes black, and either  goes back to desktop with the error log being amdkmdap has stopped responding and recovered and hlvr.exe has been prevented from accessing graphics hardware, or it will just flat out stop responding at the black screen and require a hard restart. I have tried driver versions all the way back to 19.10.1 with the same issue, and various driver settings like reducing the core clock, increasing voltage, increasing and decreasing the power limit, and still have the same issue after a random time of play.

Adept I

Could you try this?
Increase minimum clocks to a 100% and minimum volt to 100% too. make a profile for the game you have trouble and tell me. this fixed m y league of legends problems. i have been weeks without crashing, from crashing every two or three games.


I'll try this out when I get home today .

I swapped my Radeon VIi with my old r9 fury and was able to play for hours without a crash, didn't touch the drivers or anything. Definitely related to the newer cards and not just the driver updates


Tried it out, no luck. Crashed within 5 minutes.

Also tried the Enterprise drivers, no luck.

Going to RMA

Does anyone have a gigabyte brand card? Been reading similar reports of Nvidia cards from gigabyte.  


The VII wasn't modified by the board partners, theyr're all reference models. The only difference between two differently branded VIIs is the support policies of the vendor.

I've been thinking of RMAing too, but getting an adequate replacement shipped quickly is a bit too uncertain for me right now. Amazon says it'll take almost two weeks for a RTX 2080 Super to arrive rn. I wouldn't expect a new driver before the beginning of next month either, so it's a bit of a stupid situation.


I was thinking difference in assembly process, soldering and component selection could result in reliability differences. Trying to get an idea if this is an issue with everyone's card and many are just not noticing due to it only appearing in certain games or if my card is really bad and an RMA would fix.


If I recall correctly there are only one maybe two manufacturers of the reference model, possibly sapphire and power colour?  The others are simply rebadged, like Asus.   It's only when custom models come out this varies a lot, which never happened with the Radeon VII.


Tried this and it crashed after 10 minutes.

Adept I

Please to everyone, dont assume the problem is fixed until atleast it passes one month without the same issue. I've been a week sometiems without problem, then it comes back for no apparent reason, without changing or updating anything.