Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Graphics card not being recognised

Hey everyone, I have a problem with my graphics card. It is not being registered by the pc, I know this because when I go into device manager and look at display adaptors, my Radeon Rx 480 is not there. The only way that I can view it is by clicking view at the top and clicking ' show hidden devices'; when I click on the hidden Radeon Rx 480 drivers it says that the device is not plugged into the computer, however, I know for sure that it is plugged because of the RGB light on the card. As a result of this, I cannot plug in either of my monitors to the graphics card.

There are a few things that I have tried to fix the problem:

I restarted windows, and the card seemed to be back up because the drivers were appearing in task manager, so I downloaded the newest drivers for my graphics card, processor, and mouse. When I had downloaded all of the appropriate drivers I restarted the computer, and the graphics card was not being registered again.

I flashed the motherboard Bios. I read about this issue online and the most recommended solution was to flash the motherboard bios, so I did. It turned out that I was running the only version of my motherboard's bios that supported windows ten (also the newest version). So I just reinstalled the current version. Nothing happened.

I reset my bios. I did this once through the CMOS battery and once through the bios themselves. Nothing worked.

I cleaned the PCIe slots. Nothing worked.

If anyone has any solution, I would be glad to hear them. Thank you for your time.

System Spec:

Motherboard: Gigabyte GA-B85M-D3H

Processor: Intel I5 4590

Graphics card: Saphire Nitro+ Radeon Rx 480 4gb AMD graphics card

2 Replies

Have you tried, power off (and from wall socket) pc, disconnect monitor from mobo graphics, connect (only one monitor) to graphics card, power on & let windows discover it (should run from OS graphics drivers), then install graphics driver. Is your mobo bios set correctly (initial display first (auto/pci/peg (not igpu)).

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..
Journeyman III

The issue is solved now, I do not know what the problem was but all I had to do is plug the monitor into the graphics card, load the bios and reset everything to default. This seemed to solve the problem.