Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Getting a link failure on my Oculus Rift S?

I have a Rift S that I've been using no problem for weeks now, but today it's just stopped working and the Radeon app is telling me that "The system has detected a link failure and cannot set the requested resolution and refresh rate." I've updated the drivers for both the Rift and my graphics card and swapped the Rift to my other DisplayPort, but I get the same error. The Rift uses a proprietary cable, so I can't try a new cable or different hardware. I don't have any other hardware that uses DisplayPort. The Oculus software isn't showing me any errors.

Here are my system specs:

  • CPU: AMD Ryzen 7 2700 at 3.2 GHz
  • GFX card: Radeon RX 580
  • RAM: G.Skill Ripjaws 16GB DDR4 2400
  • Mobo: MSI Arsenal B450
  • OS: Windows 10 Home

Is there something I can fix on my end or am I going to have to reach out to Oculus to see if I can get a replacement cable?

5 Replies

What does Device Manager show? Any errors or yellow exclamation marks?

It is a good idea to open a Oculus Support ticket and find out if that link error is due possibly to a defective cable. It will at least eliminate the cable temporarily if Oculus Support says no.


There's one yellow exclimation mark, on a high definition audio bus, but I don't think that's the culprit. I've opened a ticket with Oculus, I'll update when I hear back.

Journeyman III

Hey did you ever find a fix for this ?

Journeyman III

No fix yet. I tried using HDMI and DVI with Rift S and error persisted.

Adept I

Oculus says that AMD's last 3 drivers will not work and that AMD does know about it!

According to Brett(Oculus guy I've talked to), AMD has known about this prior to release 3 drivers ago...about August'ish I think...AMD has been very difficult to work with and refuse to correct their code! Sounds like some inner drama is affecting us costumers. I would get on the horn and contact AMD, tell your friends as well, cuase if that's true, this is bull**bleep**! But tbh AMD has had driver errors for years, although they've said it's obviously isn't! As their drivers used to work fine last March, and before then! It says on the box of our AMD cards that it's VR Ready, and Oculus is pictured so that's false advertisement!