Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

Doom 2016 vulkan issues

Recently when I boot up Doom 2016 with Vulkan the screen is taken up by a large black rectangle on the bottom half of the screen. This all started to happen after I temporarily switched to OpenGL to see how it ran with that. I've seen other people with similar issues and it seems to be a very niche problem.

MY specs: OS: Windows 10

gpu: rx 580

cpu: ryzen 5 3600

ram: 16gb

I'm using the 20.11.3 version of the amd adrenalin software. So far it seems to only be a problem for doom 2016 as I have tested this out on other games.

12 Replies

Now you issue is that you can't switch it back to normal ? 


No I can switch it back to openGL but I’d like to use vulkan for the better performance 


Does the game run in a Windowed version with Vulkan?  Just for troubleshooting purposes. Some games run best in a Windowed version than in full screen.

Are the any new Patches for that version of DOOM?.

I see that in Reddit several Users have the same exact issue as you do with the rectangular black screen.

It is possible the Black Rectangle is a Window that is not showing correctly in Vulkan.

Have you tried to reinstall the game to see if it fixes the issue?

Try using a Previous AMD driver in case the latest is causing the issue.




So I tried all of the things you listed and unfortunately nothing worked. It can’t be an issue with the driver because I already tried rolling it back with ddu and it was the same. Running it in windowed made the vulkan graphical errors slightly worse. I don’t know what could be wrong at this point honestly I’ve tried everything 


could you do me a favor and run and post an image of GPU-Z in your next reply.

Just want to make sure your AMD Driver is installed correctly and Vulkan API is check marked at the bottom indicating Vulkan is enabled for your GPU card. It should be if your other games work in Vulkan.

If this only occurs in one game than I suggest you contact the developers of Doom 2016 and see what they suggest.

When you reinstalled DOOM 2016 did you delete your personal DOOM files with your saved configuration by any chance?.

Maybe if you delete the current Config file for DOOM it might recreate a new Config file that might make Vulkan work again or after your install the game over. It could be one of your personal saved DOOM profiles with all of your personal settings causing the issue since it worked before your used OpenGL.



I didn't think to delete the config files when I uninstalled doom I'gpu.gifll try that. Here's the picture


By GPU-Z seems like the AMD Driver is correctly installed and VulKan API is enabled for your GPU Card.



So after reinstalling doom after deleting the configuration files it still has issues with vulkan


You said it worked before in Vulkan fine before switching over to OpenGL correct? So some setting must of changed in the game or something got corrupted that it won't work correctly in Vulkan now.

I  suggest you can open a thread at DOOM website forum and find out if other Users are having the same issue and if they found a fix or not.

I know many times a User may need to enter the Config file and change some settings to get the game to work or some other file needs to be deleted etc.

But I am not familiar with DOOM 2016 so that is all I have as far as troubleshooting goes.

The problem isn't with the AMD driver but with the game itself. 

Maybe some other Users who play DOOM 2016 can offer better suggestions or more technical troubleshooting tips.

Possibly a Windows Update screwed up the game some how.  just guessing thou.



I’ll see if I can find anybody. I already asked Bethesda for help. Thanks for the help!

Sorry I couldn't at least direct you in a direction towards a fix for your game issue but hopefully someone at Bethesda will be able to figure out what is wrong or at Bethesda Forums for DOOM.

Take care and good luck.


I had the same issue with my RX 6900 XT recently, I forgot to reply how I fixed it.
Mine wasn't showing Vulkan supported in GPU Z like in the above picture, though.

It was showing up to date in Adrenalin and wouldn't update.

I had recently done a DDU clean when I installed the card at the end of January. Vulkan worked fine in RDR2 but I guess that worked differently.

On closer inspection my Adrenalin wasn't the latest version it was from Dec, there was a new version listed online in Feb.

I may of broken something the first time I did a DDU clean. This time I uninstalled the Radeon software via Windows and reinstalled and it was working again.

Anyway it may not be the solution to your problem but if you recently installed your drivers something may of gone wrong so worth trying a second time.