Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

Display driver amdkmdap stopped responding and has successfully recovered.

Display driver amdkmdap stopped responding and has successfully recovered.

Sept 2016 when we test up this pc I thought the blackscreen was normal until it become more frequent and pain in my *** I cant play games,vids or browse any website that have gifs on their homepage. I try to find the problem and I saw it on the Event viewer and "Display driver amdkmdap stopped responding..." I already reset this pc many times and still the error occurs

MSI B150M Bazooka
XFX AMD Radeon RX480
Intel i5 - 6402p

Windows 10 Home

Toshiba 1TB 3.5″ 7200 RPM Hard Drive DT01ACA100

LG 24x DVD CD RW DL M-Disc Optical Drive

60 Replies
Adept I


My first keyboard was destroyed of that crash

Community Manager

Have you tried the steps listed here > Clean Install AMD Graphics Drivers ?

Assuming you have tried everything from a software side, it could be a hardware fault, either with the graphics card or the PSU or possibly another component like the motherboard.

Can you try the GPU on a different system?

When I change it into ms basic display adapter it runs smoothly
and then  this  Rx 480 automatically installed and crash again ang again
I already tried the clean install nothing happens


Sounds like potential faulty hardware.

I agree with amdmatt's post.  My PC was locking up once to twice a day.  I had to power off and restart.  Rarely would I get an event in the event viewer.  So I thought it was a hardware issue of some sort.  This is a brand new HP Pavilion Gaming Desktop TG01-0xxx.  I've had for two months.  Worked fine for the first few weeks then would freeze mostly on Facebook and YouTube.    Then it started freezing up on MS Video Editor.  I messaged HP support and they did not care.  They said hey, we can't help you but you can buy some premium coverage and maybe they can help.  Anyway, finally, I uninstalled the AMD video driver and chose the REMOVE DRIVER from PC feature.  Then I went to AMD's web site and used the tool from the website to detect the video card.  It recommended that I install a driver which was more than a month older than the AMD driver that was already installed.  So I did that and it's been about three days now with no lock ups and that is very good.

I speculate that somewhere along the line the Video Driver was updated or it became broken.

Windows 10  x64 Desktop 32 GB Memory.  1 TB SSD drive and a 1 TB SATA secondary drive.

Journeyman III

In my brother's computer the screen would blink and sometimes the computer would freeze. In the event logs there would be some Display warnings saying the display driver had stopped.

What solved the issue was put the energy power plan in high performance or go to the advanced settings in Balanced power plan and set the PCI Express -> Connection State Energy Management setting (I don't know if it's name is actually like that, but I think it will be the only option inside PCI Express) to off.

Adept II


Well, curious. I wonder if some of those changes might have softened possible transient power spikes? I think I've read the Vega (and maybe 580) have bigger transient spikes than in the past? Anyway despite all the time that has passed since this post and all the things that seemed to help sometimes even for weeks, recently I had another HORRIBLY maddening run of random crashes in game.


PROBLEM SEEMS TO BE SOLVED: power supply. God bless it.

So, I had quality Antec 750 watt power supply that I think I bought in about 2011. Right up until I replaced my R9 280 (first with a 580 then Vega RX56) I had incredible stability so it never occurred to me the PS could be the problem. I'm pretty sure the Vega RX 56 doesn't draw MORE power than an R9 280 but I have read that possibly it does spike quite high sometimes.
Anyway, I bought a brand new Corsair HX850i and have now gamed for at least 12 hours with no crashes. Interestingly, the power drawn through this PS shows that it's not pulling even half of 850 watts so it's total overkill apparently. I mean, the power supply fan hasn't even needed to come on yet.

I need to post this in the forum, but I had this problem for almost a year (see here my terrible crashing for months fixed - RX 580 and Vega RX56 )and I was ... losing my mind. In short, I had NO stability issues for almost 3 years with an Intel box and an R9280. I upgraded to an RX580 and started to get the amdkmdap error constantly. Then the Vega RX56 came on sale and I hoped that the 580 was defective and the Vega would fix the issue. Nope. These crashes were just constant, no matter what I was doing.

Now, I have a few posts on this forum about this and thought I had it figured out a couple times, thinking something else was causing it, but no. I've fixed it now. NO MORE CRASHING. It took me a very long time to track down the specific problem by starting to take notes to any changes made by me, Windows Updates or driver updates. I had tried the TDR_Delay fix and that seemed better for a while but wasn't good enough. Also, either this key or another key (I'm not at home to see my notes) kept changing even DURING my gaming sessions. I'd set it, it would be fine as long as it remained then the O/S would change it back and it would crash.

Okay, the fix for me was to set (or add the key) TdrLevel to "0". This means that a graphics driver crash means you'll need to fully reboot the PC, but I had no choice. I had so many nights where I couldn't even play for 3 or 4 minutes without a crash. Here's a URL that describes the key. TDR Registry Keys | Microsoft Docs

One interesting note. On my work PC which is running Windows 10 1803, there are no TDR keys at all. So, I'm wondering if the cause of going from a system that had an AMD card (the R9 280) and was stable for years and then the frequent crashing (after upgrading to the 580) is because AMD added the TDR key themselves with the newer cards.

Adept II


I'm having a problem where my PC often cannot wake up from sleep or hibernation and in the event log I can see 7 rows of "Display driver amdkmdap stopped responding and has successfully recovered." right after start - and then reboot.

Is it OK that my GPU driver needs to be recovered 7 times during waking up from sleep???

I have RX 480 4GB and I'm pretty sure this was not happening few months ago, so I suspect this is related to new drivers. I have now 18.10.1.


I've found out what was causing the problem - the EVR, Enhanced Video Renderer. I'm not sure why, but after watching any movie or episode using MPC, something would break without any sign and next sleep / hibernation would fail. Switching to a different renderrer helped - now I'm using madVR and everything works again.

Adept II

I have the same problem with "Display driver amdkmdap stopped responding and has successfully recovered."  Happens every so often.  I've tried removing drivers, I've tried updating the motherboard BIOS, I've tried many things and it just still happens.  I'm just built my Ryzen 7 1700 with a Asrock AB350 Pro4 motherboard with a RX480 4GB running Windows 10. 

I'm gonna try @davejb idea but I'll be using TdrDelay first set to 8 to see if that stops the issue.  As far as I know there's no delay cause I'll be using my PC as normal and then suddenly the screen goes off and comes back. 

Adept II

After a week of using Chrome I've had no driver crashes, but as soon as I use Firefox with multiple tabs open it will crash the graphics driver.  It seems there's an issue between the AMD driver and Firefox.  I will avoid using Firefox until a fix is made. 

Journeyman III

Hi. I have same problem. WIN 10 Radeon Fury.  Display driver amdkmdap stopped responding and has successfully recovered. All the time.

Not only in games but everywhere where is used some 3d acceleration.

My investigation end with this. Any Win 10 64bit driver from AMD for Radeon Fury after 17.4.4 is not working. Same issue. But 17.4.4 works ok in any cases without crashes.

It's same version of drivers what Windows 10 install automaticly after complete removed any AMD drivers and Software.

I don't know how it's possible that AMD leaves Radeon Fury without support for One and half year.

Sam, please see my post above that starts with TL/DR. I can now game for hours and days with no crashes.

Hi,thanks you for answer.
Do you mean remove whole TL/DR section?


No, I think you just need to set TDR level to zero. I think this over rides the other TDR settings.

Yes, the instructions on that webpage are not clear at first. So, at this location in the registry: "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers" add a new DWord 32 bit  called "TdrLevel" value and set it to 0 then reboot.


I tried the delay but that didn't work so I tried the TdrLevel at 0 and that surprisingly worked. No more random driver resets, except for Deus Ex Mankind Divided in DX12 but that games DX12 implementation also crashed my old Radeon HD 7850. So far I've been using FireFox for days and nothing crashing, as well as Deus Ex but in DX11. Only problem is when it does crash the system has to be rebooted which is not a good thing.

So whens AMD going to fix this?


Mother of God. After all my attempts to help people someone actually tried what I suggested?! Sweet! This HAS worked for me, though I still get hard crashes sometimes. Basically the display just freezes while the audio keeps playing. CTRL ALT DEL then causes a black screen. Have to hold the power button in to cycle the power. I've found that with Windows 10, I signfigantly reduce the frequency of this type of crash by REBOOTING after I've powered up the PC. That is, enter room, PC is off, power on PC and log in, wait a few seconds and hit Restart. I believe this has to do with Windows 10 not doing full shutdowns (even though I've set it it to do that). 

Man, someone finally listened to me and the only fix for this that I've seen work, after years now. Cool!

Actually I removed TdrLevel after reading that maybe it's my dual monitor setup.  People are saying that dual monitors that aren't set to the same frequency might cause the driver to crash, and found that my main 1080p monitor was set to 59hz and not 60hz, while my other 1680x1050 monitor was set to 60hz.  So far no driver crashes though it maybe due to dumb luck.  I'll post again after a week of using my PC. 

I also hibernate my PC now instead of sleep though that hasn't stopped the display driver from crashing in the past.  AMD did release a new driver today that sounds like it might address this issue so I'll install that later as well. 

Good luck with removing that. Removing it didn't work for me; this has been the only reliable work around for me. Don't forget how to do this because you'll be back

Also, Hibernate will not suffice. Look up how Windows 10 shuts down, or hibernate or sleep vs. what restart does. Essentially, restart is the only one of those that behaves like Shut Down of all operating systems until Windows 10. 

Good luck and it's nice to finally see a dialogue going in a thread I've posted in. Seems like my posts and the threads I've posted in are black holes.

Thanks davejb. 48h without getting the error so far. I was getting mad trying to figure out what was wrong with my card.


I'll try that TdrLevel again but I don't think it'll work.  I've gone for 3-4 days and now it hits me with a BSOD and reboot.  The system has been doing this for a while now, since I've built the machine I think.  This happens again I have a RX 470 sitting in another machine I'll swap and see if the problem follows it.  If it happens again then my motherboard must be junk and it needs to be replaced.  I'll also pull out some ram for good measures. 

Here's the latest dmp of my BSOD.  You'll see it says "FAULTING_IP: atikmdag+13381".  It went from resetting the display driver to straight up crashing.

Could you give me some info on when this started happening for you? I'm inclined to believe it's definitely not your motherboard, I don't think your GPU is faulty either. I believe this to be an AMD and Windows 10 problem. Also, the reason you're getting BSOD's now is because Windows can't restart the driver since you either set the delay for too long or disabled it.

Before when the driver was crashing your games did you notice any ill effects when using your system after the driver crashed and recovered? Sluggishness, did videos play properly, did games drop in FPS, etc?

I've had the RX 480 since 2016 using my FX 8350.  In 2018 I upgraded to a Ryzen 7 1700 and that's when the problems started happening.  It happened rarely so that's why it was hard to catch.  It got worse a few months ago where FireFox would crash it.  Now the system just pauses for a few seconds and eventually the monitor goes off and I have to force a reboot.  Not sure why it doesn't just reset the drivers like before, and I've removed TdrLevel.  As for performance nothing seems to have changed.

My game plan is to keep lowering my memory clock each crash until I hit 2133Mhz, which is where I'm currently at now.  I have 4 sticks of Corsair Vengeance LPX and I know Ryzen isn't exactly friendly when it comes to having 4 sticks of memory, but all memory tests have passed for hours.  If this happens again I'm pulling out 2 sticks and see if that stops it as one set is version 3.21 and the other is 5.20.  Specifically the 5.20 as that doesn't clock as high as the 3.21's.  If that fails then I also have a RX 470 in a HTPC that I can just swap and see if the problem moves.  If the problem persists then it must be the motherboard, which wouldn't shock me as the ASRock AB350 Pro4 and similar boards have a lot of complaints from people about stability.  It's either that board or my Ryzen CPU which I doubt is the issue.  My boot drive isn't the issue either as last month I upgraded to a 1TB SSD, where before I had a 2TB HDD.  So recently swapped drives and reinstalled Windows 10 to 1809 as well.  My gut feeling says ASRock but I'll exhaust all other options first.  I can't imagine this being a driver or Windows 10 bug for such a long time.  I could try Linux Mint 19 for 2 weeks and see if the problem persists as I'm proficient at Linux.  I'm sure I have a spare drive laying around that I can temporarily use for 2 weeks and see if the problem persists. 

Same thing for me. Can't fix it for 2 weeks. Tried everything, looked like TdrDelay fixed it this morning but crashed again later.

It's my experience that Ryzen on most motherboards have fixed a lot of the memory compattibility issues, even four slots of RAM. I'd be surprised to find out it's a mobo or CPU problem. I've seen so many people witth this exact same issue with vastly different systems, usually the only similar thing is AMD GPU and Windows 10 , especially the 1809 update. I myself am having an issue with 1809 and have done everything my power and knowledge short of a Windows 10 reinstall to fix it. My PC will not play videos and will almost certainly crash when playing a game if it's been woken up from sleep mode. A reboot is the only solution, restarting the driver doesn't work but installing the Microsoft Basic Graphics Adapter driver fixes tthe issue. But reinstalling the AMD one in the same boot brings the same problems back. It's very very strange. I even pain stakingly removed every driver and non-essential service I no longer needed on my system, even went as far as manually removing nearly every component of AMD's graphics drivers, even things DDU missed and still nothing. But the fact the basic driver fixes the issue leads me to believe it's driver related in my case.

Also, did you return TdrLevel to it's previous state? If you out right disabled or deleted the entry this will cause your graphics driver to never attempt to recover.

I just deleted the TdrLevel entry in the registry, I didn't put it to 1 or whatever.  That might explain why the GPU doesn't try to recover.  I guess I'll have to put it back with a value of 1?  Also at this point I've removed the 2 sticks of Corsair Vengeance LPX v5.20 memory for now and seeing if this is the issue.  Since I have 4 sticks of 4GB memory I can live with with just 8GB for now.  Another thing to point out with the v5.20 memory is that it would do a very quick first pass in memtest86+.  Usually it takes 20-40 minutes for a single pass but this memory likes to do a 3 or 5 minute first pass, which might indicate an issue.  Then again it could be a witch hunt but it's worth trying until I try swapping GPU's.  I haven't played any games in a week so maybe today I'll fire up a game and see if this accelerates a BSOD or a driver crash since I now know the TdrLevel might not be set for driver recovery. 

You can add the registry entry back in and set it at 10, it's in seconds. When the entry is missing Win10 will out right not even try to recover the driver, you can set something like 10 seconds so if the driver actually locks up it'll wait 10 seconds before restarting it which prevents it from restarting when a game is just loading or something and it locks the HDD up.

Plus some DX12 games like the Forza series can cause the driver to lock up when loading into a track and can cause the driver to prematurally recover and crash the game.

That's a bit strange, Memtest86+ usually takes a while to complete, I've heard of some mobo BIOS causing issues with RAM configurations on Ryzen systems so maybe it's got something to do with that.

I ran my system for 2 weeks without issue with just 2 sticks of memory clocked at 2666Mhz as that's as high as it's able to go in Memtest86+.  I read online that people like to increase the SOC voltage to increase memory compatibility and the ASRock AB350 Pro4 doesn't seem to allow me to adjust that.  It's stuck at 0.95V.  There is a VID setting in the bios but no value I give it will increase the voltage.  Ryzen Master did increase the voltage but after sleeping hibernating or restarting it didn't remember it.  So I broke down and bought the MSI B350 Tomahawk which I now set the SOC to 1.1v with 4 sticks of 4GB ram and so far so good.  Time will tell if this is the reason I'm running into issues.

Keep us posted, I'd like to know if that fixed your issue as well. Memory instability can cause issues that mimic other hardware problems so it would be nice if this ends up fixing the problem. Was your old mobo stable at 2600MHz without crashing the driver? Did you reinstall Windows 10 with this new mobo? If so I wonder if this new mobo has better driver support as well. I recently fixed my issue by force nuking a ton of old drivers from my system that weren't being used and I have a feeling the included HDMI Realtek audio driver may have been conflicting with my 270's AMD HDMI drivers. Did you ever set TdrDelay?

The issue with the old motherboard was that memory stability was inconsistent.  Four sticks of 4GB Corsair Vengeance LPX 3000Ghz was running for 8 hours at 2800Mhz with Memtest86+ and HCI Memtest.  But with 2 sticks in the A1+B1 only got 2666Mhz with Memtest86+.  Anything higher and errors would occur.  With all 4 sticks 2666Mhz wasn't stable, so I ended up running at 2133.  Not sure if 2400Mhz was stable but I was worried if the memory was the cause not how high I can run the memory. 

With the MSI B350 Tomahawk I can set the SOC to 1.1v and I'm running the same memory at 2800Mhz with no issue yet.  I haven't run any heavy duty games yet but I plan to play Metro Exodus soon and see what happens.  Historically I've had more issues with FireFox than games with the drivers crashing and I have FireFox loaded up with multiple tabs with no problems so far.  The driver crash would occur once or twice daily.  I didn't reinstall Windows 10 cause I'm super lazy, and just removed the old drivers and reinstalled them.  Gotta remove the drivers before swapping the motherboard, and yea I had to activate Windows 10 again.  I don't use the onboard Realtek audio but have the Creative Recon3D which is very problematic as that sound card has a known issue with resuming from sleep and losing sound and Creative doesn't update the drivers anymore cause it's "legacy", whatever that means.  So I hibernate my PC but I may end up using the onboard Realtek if this continues.  I also have a Asus sound card I can use as well.  I didn't set the TdrDelay cause it never worked for me.  I've tried in the past setting it to 16 seconds I think, and it just froze longer before the driver resets. 

It's nice to know you've figured it out. I am a bit surprised it was your mobo not having proper support for your RAM since Ryzen has made leaps and bounds to support as many RAM configurations as possible since the early days when it was attrociously incompatible and these updates were often forced onto the mobo manufacturers as BIOS updates. So I wonder if your old mobo was just defective or they simply never added compatibility.

I myself won't touch any Creative hardware anymore. Many of their sound cards designed foe Windows 10 are now no longer supported after certain updates, I find they have some of the worst drivers I've ever come across that range from confliction problems to out right system instability even with a fresh Windows install, a lot of their updates can be very buggy as well. I usually just opt for a motherboard with a very good internal sound card, like ASUS' Supreme FX audio chipsets, some of the better sounding chipsets I've used and usually shielded separately from the motherboard to lower interference and background noise. If you really want the best quality sound though I recommend setting up an HDMI audio receiver and outputting from your GPU unless you need analog surround for some reason then onboard should be alright, if you need clean headphone or headset audio a USB DAC is your best choice, USB headsets work as a USB DAC as well.

You should definitely turn TdrDelay at least to 10, not having it may cause your GPU drivers to not recover in the event something truly does cause them to hang or crash.

Metro Exodus should be a good benchmark for the system, it's pretty heavy across CPU, RAM and GPU usage so it should put your PC through it's paces, as for Firefox, there's good reason for that. Firefox has some very aggressive garbage collection, so it's constantly filling and removing data from the RAM when it doesn't need it to keep RAM usage low.

I'm considering increasing the TdrDelay just in case.  My situation may not be the same issue everyone is dealing with, and the issue may still be there cause I need lots of time to see if the driver crashes.  Sometimes it takes a week and sometimes it happens multiple times a day.  As for sound cards I have a plethora of choices like the Asus DGX, Auzen Xplosion 7.1, and of course the onboard.  But I do like the way the Creative cards sound.  Also I have 5.1 speakers not headphones, so it has to be analog out. 

As for the ASRock Ryzen boards they're known for instability issues, specifically the B350 chipset ones.  Nobody knows why but they're known to cause issues.  My belief is the lack of the ability to adjust the SOC which maybe causing these issues.  I have no experience with Ryzen and this is my first Ryzen system so I assume if memtest86+ can run for hours without any errors then everything must be fine.  Lots of people have reported they can't adjust the SOC so it's maybe a design flaw or maybe ASRock doesn't want people increasing the SOC voltage.  This doesn't explain this issue people have with Intel CPU's or other Ryzen motherboards, but it maybe a clue that some people may have bad memory or bad memory settings?  Ryzen with its infinity fabric maybe even harder to test for issues with traditional memory test tools like memtest86+ and HCI? 

Here's some videos of people explaining their frustration with ASRock B350 motherboards. <- This guy ended up buying another motherboard

That's actually the first I've heard of the ASRock boards having so many issues so that's good to know. I'm just a bit surprised since AMD wanted the BIOS of Ryzen boards to be pretty much Iidentical. I guess it's up to the manufacturers to lock out or not support certain features and/or cheap out on power delivery like they've always been. I personally don't use ASRock or Biostar for builds, I've never had an issue with ASRock (Just avoided them because they were usually cheaper which can translate to cheaper components used in manufacturing.) but I have had lots of issues with Biostar boards, usually cooling issues on south bridge or blowing caps on older motherboards.

Yeah, after some hours with Memtest it's usually safe to say it's working, you can run AIDA but I've seen perfectly good systems crash under AIDA where as they wouldn't crash even under the most demanding workloads/games pinging the CPU at 100% usage. AIDA is just another beast all together since it stresses every portion of a CPU.

Yeah, I was in the same boat audio wise. I personally like a clean flat sound with slightly bumped mids and lows, I was running a 5.1 analog setup with my old Yamaha but I upgraded to a newer Yamaha unit without analog 6 channel and use HDMI solely now, the biggest difference is almost no interference or hissing in the background and my Supreme FX ASUS chipset already had very low background noise for an analog card but that's the problem with analog sound in general, no matter what it'll probably pickup interference. I also run Equalizer APO and have my system completely customized that way as some audio enhancements were not supported via HDMI out, I used EAPO to setup stereo surround on stereo signals and created my own faux "Bass Management" by setting a low pass filter on the sub channel and a high pass filter around 150Hz on the other channels to funnel all low frequencies to my sub woofer. My speakers can handle the low frequencies but this ensured LFE sounded proper in movies and games. I find EAPO to be much better than any kind of gimmick software that comes bundled with sound cards since you can configure every single detail how you want it and with the PEACE GUI you can save multiple configs and even per device configs.

So far its been over 2 weeks and nothing crashed or driver reset.  I have stuff running forever like Firefox, games, and etc without rebooting the machine.  Whatever the problem was, it revolved around that motherboard.  Again, no problems running memory and CPU tests.  All passed without problems on the ASRock motherboard, but this driver crashing still occurred. 


That's good to hear. I wouldn't be surprised if an unstable system may cause problems, especially in DX12 or Vulkan titles since they swap  memory around more often and more efficiently. Then again, it's been announced recently that the October Update for Win10 is causing graphics problems now after they thought they fixed all the issues.

Adept II

Well, obviously I can't know what's causing this same problem for others, but I wish I could explain how after over a year of hell, I went from crashes all the time to now, weeks without even one crash and the only thing that did it was disabling the TDR feature. 

That sounds like your GPU isn't recovering after a driver restart. Have you tried extending the time for TdrDelay? Can you also try hitting CTRL+SHIFT+WIN+B? Make sure you're not doing anything on the PC and close all programs before attempting. This will force Windows 10 to restart the video driver and all services attached to it. I'm curious if your PC will recover from it or crash as it does pretty much the same thing as TdrDelay, the only difference is that when TdrDelay kicks in is when something has caused your video driver to freeze, so if doesn't crash that could be the difference, whatever is causing your driver to freeze is also causing the crash.

Journeyman III

Same issues here really, in particular with Mass Effect Andromeda which I think is a punishing test for the card (and also to my knowledge quite buggy). Game will freeze and then screen just dies and the monitor asks for input. Card is on but not responding somehow. Tried the TdrDelay and it looked like it was coming back to life but then locked up and had to reboot. 

It's quite infuriating, I had this issue on an older setup and two weeks ago changed my Motherboard, PSU, RAM and CPU in order to ensure there wasn't any issues with power/hardware as the old stuff was getting quite old. The only thing that got "better" was that the system didn't reboot itself when this happened but rather just froze, so I think it fixed one issue but not the other. 

Running a Sapphire RX580 with 8GB RAM on a ROG STRIX B450-F Motherboard with a Ryzen 2600 Processor. 650W PSU. 

Adept II

FFS people. TURN THE TDR FEATURE OFF. OFF. NOT DELAY. OFF. Look at my post. Look at the URL. I explain how to turn it off. I tried setting the delay to 60 seconds a while back. That just delayed it by... 60 seconds. 

Also, I've asked many times for the error from the event viewer. We're all running around in the dark here without each of your exact error messages. 

I'm done trying to help. I'm unsubscribing to this thread.

Adept I

Turning TDR off does nothing for me. It just makes my pc hang completely instead of recovering.

I've been struggling with similar issue for six months since I upgraded from R9 390 to Vega64.

The difference is I am getting this eventid 4101 "Display driver amdkmdap stopped responding and has successfully recovered." error only after rebooting my pc. If I shut pc off and then turn back on everything is ok. But If I reboot my pc, sometimes randomly my screen goes black for a few secs and I am getting eventid 4101.

I tried everything I found on google, TDR, fast boot, tried endless versions of amd drivers, bios versions, disabled power saving features in windows and bios, reinstalled Windows (with deleting all partitions and reformat as well), disabled all peripherial devices that i don't use, onboard sound and unused sata ports and such. The last thing I bought new PSU Seasonic Prime Ultra 850W Platinum, which at first I thought it fixed my problem, but only partially, with this new psu sometimes after every other or third reboot everything is ok, which confused me.

Since I dont do overclocking, I never tried and shouldn't messing with voltage settings in BIOS. I was wrong.

I increased PCH core voltage from 1.050 to 1.15 in bios and so far everything works ok. I am testing for two days, rebooted my pc many many times, no eventid 4101 errors so far. This is very weird, because according to technical data, videocard communicates directly with the controller in CPU, not the motherboard PCH.

Anyway all I can say, perhaps Vega64 puts alot of stress on the good old Z97 chipset so it needs more power or something like that.

My Specs:

Windows 10 Home 1809
Benq XL2730Z display
Gigabyte Radeon RX VEGA 64 GAMING OC 8G
GA-Z97X-SLI (rev. 1.1)
i7 4790k
16GB DDR3 1600Mhz Crucial Ballistix Tactical
Samsung SSD 960EVO 500GB system disk, and two hard disks for storage

Seasonic Prime Ultra 850W Platinum PSU