Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Disappearing RX 560X

I just bought an Asus FX505DY, had just a few days. It has an RX 560X installed but every few minutes if the computer sits idle the GPU will up and disappear from every window I can think to find it on, including the Device Manager, Task Manager, the Radeon Setting panel, and even DxDiag.

The drivers are fully up to date. Power management and being plugged in or unplugged don't seem to matter. Any help or advice would be appreciated.

194 Replies

yea my GPU held on for like 5 mins and then again it dissapeared.

Amd should fix this issue man!

I'm currently on BIOS.309  and Radeon Software 19.5.2 which came with the laptop when purchased and still it still shows Vega 8 graphics


Did it work ?? 19.7.2 ??


No 19.7.2 is not working... I'm replacing my laptop with a fresh unit now


Resetting windows takes it back to the preinstalled driver, but the thing is , it is outdated. 

When I flashed 19.7.1 , I didn't have any idea about this disappearing thing. I thought that maybe I made some mistake but now I know it was the software not me.

After searching for hours , now I know amd isn't going to fix this thing. They have clearly mentioned on their website to use the driver from the manufacturer.

I was just hoping that Paulson's idea might beat the glitch. And I have no intention of trying it myself before confirmation , have already spent hours trying to bring it back , at the end resetting did the thing but still stuck with the old driver.

And the thing is , latest adrenalin driver may allow us to use dual graphics through amd crossfire , afterall it is possible in maximum amd apu-gpu combinations.


AMD Driver 19.7.2 is working as good as was 19.7.1. I detect no issues, no flickering, no disappearing devices, no glitches etc. New driver works really good and anti lag feature really gives some nice stability and smoothness to the games. I decided to make a thorough research over my laptop settings, as it is clear to me, that issue we experienced is not a result of the driver itself. Think about it. We all have the same hardware configuration, which means that driver is implemented the same way for each and every one of us. Or should I rather say, "It should be implemented the same way". Obviously it is not. My conclusion is, that if after trying every possible solution with the driver, you still get the same result, which is persistent failure of device working properly, the problem is not in the driver. Why would it work perfectly fine for other people but not for you? To me it is clear that the fault is on the side of Microsoft. It wouldn't be the first glitch that they created in their history and definitely isn't the last one.

What I am trying to say, is this: most likely settings of your OS cause the failure of correct implementation of the driver.

I will give you now precise description of the path I took to update driver, including my windows power settings, cause I certainly believe the problem lays there. Please try and let me know how it works for you. If the glitch will remain also let me know, so in that case I will do some more checkup and try to find the solution for you guys.

Attention! Make sure that before you start, you are not plugged in to internet and that you disabled driver auto update in windows option. This is very important!

Lets get started with windows power setting.

1. Right click battery icon on task bar and left click power options. Make sure that your checked power plan is high performance.

2. Left click "change power settings" to the right from active high performance power plan. Change "put the computer to sleep", both on battery and plugged in, to "never".

3. In the same window left click on "change advanced power settings".

4. In the new window scroll down and left click "AMD power slider/overlay" then make sure that both options are set to "best performance".

5. Next Left click on "switchable dynamic graphics/global settings". I have it set "on battery:optimize power savings" "plugged in: maximize performance". But I am using laptop to play games only plugged in, if you are playing while on battery only, I recommend to swap "on battery" to maximized performance" as well.

6. Lastly expand "AMD Graphics power settings/AMD Powerplay Settings" both to "Maximize performance". Apply changes and close the window.

Now proceed with driver installation following these steps:

1. Using DDU switch laptop to safe mode (recommended) then, after system reboot, uninstall your gpu driver. Your laptop should now reboot back to normal mode.

2. After reboot install chipset driver that I provide in the link to my gdrive (for the reason I do not understand, asus has removed most recent version of the driver (2520141501) which was published on july 17. In my case this driver fixed the issue, cause I had same problem as all while using previous version of the asus driver. Link at the end of this post. To install the driver properly you need to right click "install.bat" file and open it as administrator. If you double left click it, the cmd window will open and process of installation will proceed, however driver will not be properly installed. This is very important, cause it's very easy to overlook this step. If you rushed and double left clicked no worries, redo the procedure by right clicking. I tested if it works and it does. Just make sure you install this as admin at least once . Reboot.

3. Now get amd driver 19.7.2 if you didn't download it before and install it. I tried both express and custom install and both works just fine. If you custom install make sure that you know what you are doing . After installation reboot.

4. After restart, open device manager window and go to display adapters. Expand it to make sure that there is no error. Even if there is not, right click 560x and chose update driver, then use option to install driver from your hard drive and chose directory where you unpacked the driver from amd. If you haven't changed driver destination during installation process, it will be on C:/ AMD (I recommend to don't change anything while installing AMD driver to avoid searching for packages in case something will go wrong). Proceed with driver update, if everything is OK, you will get response that the newest driver have already been installed. Be sure to do that, cause sometimes for no reason. driver fails to install and this is the best way to make sure that you have what you really want to have installed. In case the driver failed to install correctly and manual update implemented it, make sure that before reboot you will do one more amd 19.7.2 installation, but this time do not use express install, only custom! Leave everything as it is and proceed with installation of the driver and all components that were auto checked. Reboot. Test.

If I was right (pretty sure I was ) your problems are all over and you will no longer experience disappearing rx560x glitch.

I sincerely hope that this is the end of the problem. I will be looking forward to your responses to see how it works for you. In case it doesn't solve the problem I will dig some more to find out what setting in my laptop makes it work perfectly fine and without the glitch that you guys still suffer.

In the end, if this solution will solve your problem, I will appreciate if you hit the like button under this post and mark it as helpful (also I will be happy if you can follow my profile and throw me some "thank you" badges there ).

Here is the link to the driver mentioned before: 

And here is link to AMD driver that I am using without any problem:

Radeon™ RX 560 Drivers & Support | AMD 

Amazon sent a technician and after some troubleshooting...voila!

Rx560x stays on idle and is very stable on 19.7.2

Have some awesome 120+ framerates on high settings in CSGO, Rocket league,

and Pubg lite

It gets kinda troublesome but in the end this is the One to get!


Glad to see that! I hope it works for everyone.

they removed the driver because it did not really contain any amd driver software


Actually it does contain driver for chipset. No amd software but there is definitely something in it. However now as you mentioned I am curious if everything is fine when you skip installation of that driver published by asus and stays only with amd 19.7.2? Perhaps someone could try that and drop the comment?

BTW, how is it working for you? Problem solved?


I don't think it would work. Had tried with 19.7.1 and guess what ?! Even Vega 8 disappeared

Tried cleaning and got stuck in a loop , everytime the system would start in the safe mode , and after 10 to 15 seconds a dialogue box would keep on appearing which had the title Microsoft Windows and read , "This application has stopped working...". Had to reset. And then I sticked to the asus driver.

Gonna get my replacement product by the evening I guess. Gonna try it your way this time.


Hey if u have purchased the product from Amazon or Asus please contact

their customer support for onsite technical assistance...they can help

troubleshooting your issue.

Reset ur laptop and then give it to them so all settings are set to default


Can you tell me what did they do to fix the issue ??

You must have seen the technician do something right ?


I updated my Asus BIOS driver to .309 now. But which Amd Radeon Software version are you on?


Just follow the instructions in this thread, you're gonna have to back read

a bit to find it here. Just make sure you restart your system after every

driver install, you can update up to the latest amd drivers (chipset and

gpu) and have no worries afterwards.

Adept I

Dear Mir, below update from AMD gonna try it today on my laptop...

Thank you for the email.

In order to properly debug the issue, I would require some additional details about your system and let me know the following:

·         Have you done the clean installation of the driver?

·         Did you happen to remember what specific driver worked for you without any issue.

 I request you to give a try by performing clean installation of latest 19.7.2 driver or the available driver to your OS by using the DDU utility.

I suggest you to please disable the windows auto update in the "Show and hide" tool


To be on the safer side, I request you to please create System Restore point before performing any troubleshooting steps.

·         Step 1 – Please use DDU Utility (Display Driver Uninstaller) by launching it in Safe mode and uninstall the previous driver. It will help you completely uninstall AMD graphics card drivers and packages from your system, without leaving leftovers behind.

·         Step 2 – then restart your computer again and enter into the normal windows mode.

·         Step 3 - install all the critical and recommended updates from Windows. (make sure windows is not installing the display driver)

·         Step 4 – Again restart the computer and then install 19.7.2 drivers by clicking this below link. Please disconnect the network connection and disable antivirus before running the installer file.

And if the issue still persists, please check the issue status by updating the drivers from laptop manufacture.

And please note that laptop manufacturer provided drivers are often customized for the specific make & model of the laptop and recommended to use. AMD provided mobility driver are not customized according to laptop's make and model I request you to download the drivers from the laptop manufacture. if the still persists, I suggest you contact the laptop manufacture as then can provide better assistance.

Thanks for contacting AMD. 

Adept I

Dear Santhosh,

Your service request : SR #{ticketno:[8200884461]} has been reviewed and updated.

Response and Service Request History:

Thank you for the response

Still our driver team is working on this , Our driver team is working on this hope they will fix the issue shortly your I will apricate for your patience

Thanks for contacting AMD


In order to update this service request, please respond, leaving the service request reference intact.

Best regards,


AMD Global Customer Care

Adept I

Hey Guys ,

 I followed the steps from Galentot , i did the reinstall n uninstall 5 times n found that radeon software is the issue , so i uninstalled the software n left system idle yesterday whole night and graphics did not disappearing....  all games detect graphics card and my FPS is great too..

Journeyman III

Ok guys now it's getting very annoying i have tried everything in this thread but it's not working out for me.

AMD must fix it in next update it's been 3 weeks since this bug started and we are still waiting for a fix,i mean  "Are you kidding me"  I hope amd fixes it asap And that ddu solution which some people have mentioned is not working for everyone i tried the entire DDU process 5 times and did everything accordingly and still the graphics card was disappearing.

Journeyman III

So Today i noticed something really odd happening with my fx505dy. Yesterday night i have done the DDU process again and now it worked perfectly, I even played mortal kombat 11(with 30-40 fps) it worked flawlessly yesterday night. But Today morning strangely the glitch started again so i restarted the laptop to check again but same story so what's really happening. Currently I am using 19.7.2 version of the software.


Try my setup with windows power settings tweak. I have no problem at all. And disable windows driver auto update.

Adept I

To those, who are still experiencing glitch with missing/disappearing RX560X, please try my solution with windows power tweak (I suppose that it will also work on desktop, if the glitch appear there). If it doesn't work, pls let me know what kind of antivirus you are using.


I confirm that there is no need of installing any asus driver. Use DDU in safe mode , uninstall all the amd gpu drivers. The problem isn't with amd drivers , it's with the Asus one's (specifically v2520141284002).

After using DDU just install Adrenalin 19.7.2

You may check in the device manager after reboot , but I don't think it would be necessary.

Just make sure to disable driver auto updates !!!

It's working like a charm. No disappearing or any other issue.

Also you need to uninstall amd optimization app manually , even DDU didn't delete it.


I did this with BIOS version 308.

Don't know about 309.


It works on 309 cause Im using it without any problem after updating driver to 19.7.2

Adept I

This process was a little janky to believe but yes it worked for me,

So how my issue got solved was the amazon technician downloaded a software called drp(driverpack soluion) and then first he uninstalled Vega 8 drivers from device manager and then he started the drp software and then it uninstalled previous drivers and reinstalled the new drivers...the software does that automatically.

After that the radeon software gave an error as the vega 8 drivers were uninstalled earlier, so then onto downloading the asus drivers and installed them.

But still radeon software was not loading bcuz of uninstalled drivers. So finally he installed 19.7.2 driver from amd's website and installed that over.

And then a reboot later,voila! Radeon rx560x was stable on idle system.

So yes this was problematic but thankfully my issue got resolved.

Hope your issue gets resolved too.

Adept I

Tried every variation of the solutions listed here, including eliteshade's Amazon repair, paulson's alternate power plan, following each step of AMD's support email, and every other suggestion listed here.
Tried DDU > ASUS chipset > AMD driver, as well as DDU > AMD driver > ASUS chipset, as well as just leaving one or the other. Also tried these combinations with both new and old versions of each of these drivers. Been using BIOS 309 this whole time.
I was really hoping to troubleshoot this problem myself, but I'm starting to think I may have to send it in for replacement.
Gonna keep following this thread for a few more days before I give up, just in case.
I wondering why AMD has stopped listing it as a 'Known Issue' when many are clearly still having it...


I solve this to install 19.4.3 it's good and wait for amd and Asus fix it


You can try one last thing.

When you have all the drivers installed , rx 560x should be visible for about 8 to 10 mins of booting. Open radeon settings , configure whatever you want to , I don't really know if the configurations would be there after the step I'm going to tell you to take , but you would get a stable fps without the tears in image , flickering or any of that stuff.

After you've done that.

Do this... Open armoury crates , go to Featured section , download radeon settings from there and let it install it. Restart... Open settings , then apps , uninstall radeon settings. Restart.

Rx560x won't disappear. 

After 30 mins of booting into the OS you'll find that , the gpu has disappeared from armoury crates app but neither from device manager nor the task manager.

Download MSI Afterburner. Turn on the overlay in it , and test any of the games and see if they are using rx560x. 

According to me , this is the last resort.

Just let me know if this works for you.


bro u need to install 19.4.3 drivers its not have issu 

and wait for amd new drivers 


I prefer to use the newest driver if possible, so I'll try to use the alternate method suggested. If that still doesn't work, I'll roll back to 19.4.3


I'll give this a try, just need help understanding the last couple steps.
"Restart... Open settings , then apps , uninstall radeon settings. Restart."
When you say restart, you mean reboot the laptop, or restart the armoury crate app or the radeon app?
Also, settings and apps, you mean for Windows or armoury crate or something else?


By restart I mean reboot and uninstall radeon settings from windows settings , then apps.


The main motive behind doing this whole thing is removing radeon settings app.

When you install the app from armoury crates , the one which came with 19.7.2 gets removed first. The armoury crates one is only supported by asus drivers , which means that it wouldn't cause any harm to the amd site's driver when uninstalled or made changes with. Even if you try launching the radeon settings after installing from armoury crates it won't open , it would say that the app version is not compatible with the driver or something.

When I did all this , armoury crates showed that there's no rx560x but it was there in the device manager as well as task manager. Which simply meant that whenever armoury crates recognized that any driver other than the asus one , it makes the OS believe that rx560x does not exist and this thing is constant from 19.4.4 or some other version , I don't clearly remember. The latest driver on asus's site ****501 was removed , and I believe it was because it left some file or something which made armoury crates think that asus driver is installed and in turn rx560x didn't disappear.

Until it is confirmed from others , it's just a vague guess. And also one more thing , why's there such a problem with asus fx505dy and not with others having rx560x. This might be it.

Have someone tried the new 19.7.3? 


So far, so good... I performed your fix this morning and my video card has not disappeared all day. I hesitate to speak too soon, because some of the other fixes suggested here caused the problem to go away for a few hours only for it to return, but none of them have worked for this long. If I'm still not having any problems tomorrow, I think it'll be safe to declare the issue resolved.

I'm grateful for your suggestion, and very curious how you even thought to do this

bro your its work i install 19.7.2 in my laptop without issu thanks 

and my questions is what happen whan i unstall armoury crates tell me 

and new drivers 19.7.3 is her can i should update plz tell me thanks again


Armoury crates is just an application , shouldn't be a problem in removing it , but you won't be able to use Asus optimized silent/balanced/turbo modes (the ones working with Fn+F5 keys). The control would automatically shift to windows.

19.7.3 should also work.

If you're doing any of these two, just make sure you create a restore point first.

Hey klol , while you're updating to 19.7.3 just try one thing

Open armoury crates , you would see 4 profiles , windows/silent/balanced/turbo

Plug the charger in , and switch it to windows

Unplug the charger and when the profile changes on its own , again switch it to windows

Both while plugged and unplugged , the profile should be windows

Then install 19.7.3 , see if rx560x stays put , if it doesn't disappear then there would be no need of uninstalling radeon settings , and if it still disappears then uninstall radeon settings as you did with 19.7.2

If this thing does work , we would be able to use radeon settings as well.