Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

compre una tarjeta grafica pcie 3.0 y mi placa es pcie 2.0 (supuesto problema) instale la tarjeta grafica (sapphire r9 390 nitro tri-x 8gb) en mi placa (asrock FM2A88 killer) y cuando enciendo el pc, me enciende la bios, EL BOOT LOGO (windows10), y, a la

compre una tarjeta grafica pcie 3.0 y mi placa es pcie 2.0 (supuesto problema) instale la tarjeta grafica (sapphire r9 390 nitro tri-x 8gb) en mi placa (asrock FM2A88  killer) y cuando enciendo el pc, me enciende la bios, EL BOOT LOGO (windows10), y, a la hora de aparecer la pantalla de usuario, se me pone la mpantalla negra y me salta un frame azul y tiempo despues otro morado, el pc se reinicia y, tras varios intentos (3) se abre windows recovery. la tarjeta funciona, ahora estoy utilizandola para escribir esto, en modo seguro de windows, es decir el procesdor (amd a10 6800k), la placa... la reconocen, y windows es capaz de iniciarla en modo seguro, entonces porque no puedo iniciar en modo normal? intente instalar los radeon graphics (la instalacion con deteccion automatica y la manual) y no funciuona, se instala, pero a la hora de iniciar radeon me pone que no se han detectado drivers amd o que no estan instalados/funcionando correctamente, windows es de 64 bits y se llega a abrir si desconecto la tarjeta y urtilizo la grafica del procesador, pero va a 0.3 fps y no es una condocion de trabajo, muchgo menos de juego. tego 8gb ram, la motherboard yta la dijhe antes y el procesador tambien, si falta algun dato pregunten. gracias

8 Replies

First when you reply back please translate it from Spanish to English since this is an English Only Forum. Thanks in advance.

Second you need to post all of your computer Information like Make & Model of CPU, PSU, Windows version and AMD version you have installed.

The R9 390 is a high Wattage GPU Card. According to a PSU TECH site you need a minimum of 650 Watt PSU to run that card in your computer.

Your Motherboard has no problem supported that GPU card since it has a PCIe x 16 3.0 slot: ASRock > Fatal1ty FM2A88X+ Killer 

Here is the latest AMD Driver for the R9-390: 

Also be sure you have both (2) PCIe Power Cables (8 pins) connected from the PSU to the GPU Card. If they are not connected your GPU card will not work correctly if at all:

Follow this basic method to remove and install the AMD Driver in your computer to prevent conflicts:

Uninstall the current AMD Driver using DDU as per this method:

It could be due to a corrupted AMD Driver installation.

Download free program DDU (Display Driver Uninstaller). Run it in Safe mode with the internet disconnected.

You can also run it in Windows Desktop but then you would need to Reboot the computer for DDU to finish erasing all of  the AMD Driver traces from your computer.

 Once it finishes uninstalling the current AMD Driver in Safe mode and boots back to Windows Desktop, still with the Internet disconnected, delete the AMD Installation folder C:\AMD if it was created before.

Now install the full AMD Drive package you downloaded manually from AMD Download page. Not the express package. Run the package and if it installs correctly again delete C:\AMD folder and reconnect the internet.

This should prevent any conflict when installing the new version from the previous version.

By the way, C:\AMD is always created whenever you run the AMD Driver package


I have tried what you have told me and it has not worked for me, 70-80% my screen gets black, and it stays like that for hours
Journeyman III


Yes, I already knew that it supports pcie 3.0, but my processor is the amd a10 6800k I think it is fm2, not fm2 +, with which only pcie 2.0 supports me, even so, I have read in forums and the internet that it should work, that it should not detect the 8 gb but if something (in my case it detects 4gb, I have seen it from the configuration). even so, it is strange that the bios comes out, and more strange that the boot logo (which is already operating system) appears.
processor: amd a10 6800k (
ram: 8gb ddr4 (hyper x)
psu: urano nox 750w ( )(has the 2 pcie plugs of 4 pins each)
hdd: wd 2tb (
motherboard: asrock fm2a88 +
gpu: sapphire r9 390 nitro tri-x 8gb

pdta: now I'm in the office, in the afternoon I'll record a video and send the link to see what the failure is and give me a confirmed solution
(elstaci has told me I will also do)

sorry if it's bad, I use the translator


Okay, are you saying that your Sapphire 8 GB GPU card is only showing 4 GB?

Download a free program called GPU-Z and run it and post an image of the results. This will also show if your AMD Driver is correctly installed.

Also go to Task Manager "Performance" Tab and look at your GPU and see if it shows 4 or 8 GB for your GPU card.

Journeyman III

ok, but give me a while because I'm reinstalling windows (this time I'm going to try 8.1)

Windows 8/8.1 is not supported by AMD with Driver Updates unless you want to install the last Windows 8.1 driver from 2017.

Windows 10 & up to now, Windows 7 are supported with Driver updates.

Yes the A10 supports only PCIe 2.0 but as long as the Motherboard slot is PCIex16 - 2.0 the GPU card should work.

Journeyman III

Ok, Windows 8.1 dosen't worked, dame "error" aopears, two frames, blue and purple.

Sorry i confused, It detects 8192Mb


It is possible your used GPU card is defective.

You have a AMD APU  A10-6800K (Processor with Integrated Graphics). Try removing the R9 390 from your motherboard and use your A10 Integrated Graphics and see if you can now install Windows 10 again.

If you can and everything works correctly with your A10 APU then try installing your R9 390 in another computer and see if it works or has the same problem. This is to eliminate a defective GPU card.

Here is the last AMD Driver for your APU which isn't supported by AMD updates anymore. Delete the current AMD driver which isn't compatible with your APU and install this one: