Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Can't update Crimson Relive 17.4.3


im having problems to update my APU drivers from Crimson Relive 17.4 to any new version

i can only install 17.4, any new version causes the message  "no amd graphics driver is installed or the amd driver is not functioning properly" or "Radeon settings are currently not available please try again after conecting AMD graphics"

and 17.4 is causing a series of FPS drops and CTDs

i already tried this > Clean Install AMD Graphics Drivers

and im downloading my driver from here > APU

Captura de pantalla (11).png

Here is 17.4.3 with Radeon settings working:

Captura de pantalla (9).pngCaptura de pantalla (10).png

When i try to install anything higher than 17.4 this shows ups when trying to open radeon settings after rebooting (i manually downloaded every driver from here > APU after a clean install following this > Clean Install AMD Graphics Drivers

After the installation i cant change my screen brightness, the Screen "blinks" normally  when the drivers are installing

Captura de pantalla (16).png

Captura de pantalla (14).png

And installation finished "succesfully":

Captura de pantalla (15).png

My Windows and BIOS are up to date, i already disabled automatic driver updates on Windows Update, and tried every Driver available for my APU from 17.4.3 to 17.12.1 with no success

i downloaded every Driver manually, only full drivers, no minimal setups, only drivers for my APU ( AMD A10-8700P) and clean installs following this guide > Clean Install AMD Graphics Drivers

i installed the drivers on the High performance battery mode of my PC, all the folders of my PC are on the default location (My Documents, etc), i already scanned the registry for errors (none found) and registry repair, the only way for my video card to work is installing drivers 17.4.3, but im having CTDs and FPS drops

My specs are:

AMD Radeon R6 Graphics

AMD Radeon (TM) R7 M360 2GB

AMD A10-8700P Radeon R6, 10 Compute Cores 4C+6G (4 CPUs), ~1.8GHz

12gb of Ram

Windows 10 x64

Any help is greatly appreciated! thanks!

1 Reply
Journeyman III

Did you solve this issue?

I have the same problem.